Results 1 to 6 of 6
  1. #1
    Lounger
    Join Date
    Jun 2009
    Location
    London, UK
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi,

    I have used a table style in my Word template (Word 2003). I find that this is a very useful feature for creating tables with lots of formatting (shading, line colours and width, etc) quickly.

    However, the table style I have set up seems to have a bug in it. When I click the particular table style in the Styles and Formatting task pane, it mostly inserts just the header row, when it should actually display the insert table dialogue box. To make it work correctly, I have to press Undo and select the table style again. It generally works after just one press of Undo.

    Has anyone else encountered this problem -- is this something I have done wrong, or is it a bug, as I suspect, in which case is there a fix for it?

    Many thanks,
    Sam

  2. #2
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    5,016
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='Sam577' post='777951' date='02-Jun-2009 20:43']Hi,

    I have used a table style in my Word template (Word 2003). I find that this is a very useful feature for creating tables with lots of formatting (shading, line colours and width, etc) quickly.

    However, the table style I have set up seems to have a bug in it. When I click the particular table style in the Styles and Formatting task pane, it mostly inserts just the header row, when it should actually display the insert table dialogue box. To make it work correctly, I have to press Undo and select the table style again. It generally works after just one press of Undo.

    Has anyone else encountered this problem -- is this something I have done wrong, or is it a bug, as I suspect, in which case is there a fix for it?

    Many thanks,
    Sam[/quote]

    This article gives quite a rundown on some of the problems using Word's Table Styles. It may not help with your problem, but at least you know you're not alone!

    Alan

  3. #3
    Lounger
    Join Date
    Jun 2009
    Location
    London, UK
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Alan. I'll have a read.

  4. #4
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    [quote name='Sam577' post='777951' date='02-Jun-2009 06:43']...

    However, the table style I have set up seems to have a bug in it. When I click the particular table style in the Styles and Formatting task pane, it mostly inserts just the header row, when it should actually display the insert table dialogue box. To make it work correctly, I have to press Undo and select the table style again. It generally works after just one press of Undo.

    ...[/quote]
    Sam,

    I can't duplicate this problem and haven't seen it before (probably because I don't insert tables this way). If it is a software error, then running open and repair on the template and any docs generated from it may repair it. If Word finds no errors, then it just might be something in your table style, particularly if all the built-in table styles work as you expect. If you don't want to recreate the style, a workaround would be to create the table structure and then apply the style.

    I agree with you that table styles are a tremendous time saver and reliable formatter--as long as you do not set font and paragraph formatting in the style.
    Pam Caswell

  5. #5
    Lounger
    Join Date
    Jun 2009
    Location
    London, UK
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Andy,

    Thanks for that.

    I did use styles in the table and initially found it very problematic. The work-around I found though was that before inserting the table through the Styles and Formatting pane, I have to "Clear Formatting" at the paragraph mark where I want to insert the table. In this way, the table did not take on the wrong style.

    Many thanks,
    Sam

  6. #6
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    [quote name='Sam577' post='778313' date='04-Jun-2009 02:19']Hi Andy,

    Thanks for that.

    I did use styles in the table and initially found it very problematic. The work-around I found though was that before inserting the table through the Styles and Formatting pane, I have to "Clear Formatting" at the paragraph mark where I want to insert the table. In this way, the table did not take on the wrong style.

    Many thanks,
    Sam[/quote]
    Very interesting, and it's another good thing to know about W2003 table styles. You might be interested to know that in W2007 table styles work much better.

    Pam
    Pam Caswell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •