Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Jun 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello,

    Several sources I've checked say that to update all cross-references in a Word 2003 document (mine is 233 pages long) you select all and press F9. However, when I do this, the cross-refs don't update -- nothing happens. If I select the whole doc and right-click, the pop-up menu doesn't display the Update Field option. Nor do the cross-references update when I update the table of contents.

    I can't rely on the "update links" before printing feature (Tools > Options > Print) because I won't be printing!

    Any suggestions? As a reward for your trouble I offer you this virtual beer, but please drink it *after* you reply...

    Cheers,

    redbee

    PS: I'm running MS Office SE 2003 on a Dell Latitude D620.

  2. #2
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Control-A followed by F9 works for me, but it won't update fields in text boxes or in headers and footers.

    Even though you are not planning to print, you can still go into print preview and back to your usual layout to update all fields.

    You could also use a Macro to update fields in all storyranges, you can find an example Macro in Post 718738

  3. #3
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    [quote name='redbee' post='779478' date='12-Jun-2009 01:45']However, when I do this, the cross-refs don't update -- nothing happens. If I select the whole doc and right-click, the pop-up menu doesn't display the Update Field option. Nor do the cross-references update when I update the table of contents.[/quote]
    This could be caused by the cross-ref fields being locked - in that situation F9 would have no effect, and the Update Field option on the pop-up menu would be grayed out.

    You could try selecting all and then Ctrl+Shift+F11 to unlock the fields.
    (Ctrl+F11 will re-lock them should you need to do that.)

    Gary

  4. #4
    New Lounger
    Join Date
    Jun 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Many thanks, Stuart and Gary. The combination worked: Once I unlock them (using Ctrl+Shift+F11), the cross-refs can be updated by selecting all and pressing F9.

    Oddly, even with the refs unlocked, the Update Field option still isn't available -- it's not grayed out; it's not in the menu. But F9 works now, so I'm set.

    Truly, my blessings to you both for your quick replies!

    Kelly

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •