Results 1 to 4 of 4
  1. #1
    Lounger
    Join Date
    Mar 2009
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi,

    When I take up a new document for formatting, it contains loads of styles applied manually.

    I have made a protecetd template whhich contains styles as per our style manual.

    So, first I copy the corrupted document and paste it in our protected template. Manual styles gets deleted and normal style gets applied to the text.

    is it possible to automate this copy paste process and also the styles get applied correctly where they need to be applied.

    Actually the name of the corrupted styles are same. So we just need to replace the correct style of protected template.

    regards
    abhilasha

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Instead of copying and pasting, you could attach the template to the document:
    - Click the Office button.
    - Select Word Options.
    - Click Add-Ins.
    - Select Templates from the Manage dropdown.
    - Click Go...
    - Click Attach... to select the template.
    - Tick the check box "Automatically Update Document Styles".
    - Click OK.
    This will update the styles in the document with those in the template.

  3. #3
    Lounger
    Join Date
    Mar 2009
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi,

    By doing so, the corrupted styles still exist in the document.

    see, the one correupted style is Table text ( t in text is in lowercase) but the protected style is Table Text( T in Text is in uppercase)

    Now when I copy paste the content, because table text is corrupted style, it all gets changed into normal. beacuse I have provide protection to my document and no other style except the existing ones gets deleted and it applies normal style to the entire table text style.

    The steps u have suggested dont work. On clicking the checkbox, it does not apply the correct style to the corrupted one.


    regards
    abhilasha


    [quote name='HansV' post='782713' date='02-Jul-2009 11:29']Instead of copying and pasting, you could attach the template to the document:
    - Click the Office button.
    - Select Word Options.
    - Click Add-Ins.
    - Select Templates from the Manage dropdown.
    - Click Go...
    - Click Attach... to select the template.
    - Tick the check box "Automatically Update Document Styles".
    - Click OK.
    This will update the styles in the document with those in the template.[/quote]

  4. #4
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    If your problem is the style name in the document is not exactly the same as the template then we would normally not say the problem is 'corrupt styles' but we might call it 'changed style names'.

    A simple fix to the template which would allow you to merge variant stylenames into a single style would be to add a style alias in the template. If your style was called "Table Text, Table text" then pasting in content with either case sensitive stylename would give you a single style.

    I'm confused why you say the stylename changes to normal as a result of pasting - this is not the usual behaviour and not easily pinned on corrupt styles so you might be using macros which are responsible for changing the stylenames as you paste (or are you using Paste Special?).
    Andrew Lockton, Chrysalis Design, Melbourne Australia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •