Results 1 to 7 of 7
  1. #1
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Warrington, Cheshire, England
    Posts
    712
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have a form with three tabs. The colour of the tabs is the same as the background colour in the form header; this is shown in the lower half of the composite picture attached.

    Starting a new database, I copied the form into the new DB, but the tabs have 'lost their colour'; this can be seen in the top half of the attached photo.
    All the control labels also lost their colour but I have managed to get this back by changing the Back Style property to Normal - it had been set to Transparent. This can be seen in the top half of the picture where NI Number is as it was imported, but Title is as it is after setting this property.

    I've searched very hard but I can't find how to set the colour for a tab control or find the equivalent Back Style property.

    How can I return the form to looking like it used to (bottom half of pic), please?

    Thanks
    Silverback
    Attached Images Attached Images
    Silverback

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Open the form in design view.
    Select the tab control, either by clicking in the bar at the top, to the right of the tabs, or by selecting it from the Control dropdown.
    Activate the Format tab of the Properties window.
    Set the Back Style property to Transparent.

  3. #3
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Warrington, Cheshire, England
    Posts
    712
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hans
    Did that but nothing changed. Tab remains the same as in the supplied picture.
    Regards
    Silverback
    Silverback

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    I have no further ideas. I'd have to see (a stripped down and zipped copy of) the database with the problem form.

  5. #5
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Warrington, Cheshire, England
    Posts
    712
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hans
    I've attached a zipped copy of the DB under development.
    The form in question is EmployeeData.
    Controls layout yet to be sorted out!

    Silverback
    Attached Files Attached Files
    Silverback

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Try the following:

    Open the problem database.
    Select Tools | Options...
    Activate the Forms/Reports tab.
    Clear the check box "Use Windows Themed Controls on Forms".
    Click OK.

  7. #7
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Warrington, Cheshire, England
    Posts
    712
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Genius!

    Many thanks
    Silverback
    Silverback

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •