Results 1 to 4 of 4
  1. #1
    3 Star Lounger
    Join Date
    Apr 2001
    Location
    Warrington, Cheshire
    Posts
    355
    Thanks
    3
    Thanked 0 Times in 0 Posts
    As title suggest really. Office 2007 SP2
    Never had a problem disabling macros previously or with any of the security settings, but 2007 doesn't seem to want to play nice.
    Simple macro set to workbook open.
    In the macro settings I have tried:
    Disable all macros without notification
    Disable all macros with notification
    Disable all macros except digitally signed macros

    Neither setting prompts nor disables the opening macro.

    Is there a further setting I am missing somewhere?
    Thanks
    Alan

  2. #2
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post
    [quote name='ase001' post='784546' date='14-Jul-2009 13:53']As title suggest really. Office 2007 SP2
    Never had a problem disabling macros previously or with any of the security settings, but 2007 doesn't seem to want to play nice.
    Simple macro set to workbook open.
    In the macro settings I have tried:
    Disable all macros without notification
    Disable all macros with notification
    Disable all macros except digitally signed macros

    Neither setting prompts nor disables the opening macro.

    Is there a further setting I am missing somewhere?
    Thanks
    Alan[/quote]
    Hi Alan

    What file holds the macro which you are trying to disable? I am suspicious that the Personal file is immune from the Security settings.
    Regards
    Don

  3. #3
    3 Star Lounger
    Join Date
    Apr 2001
    Location
    Warrington, Cheshire
    Posts
    355
    Thanks
    3
    Thanked 0 Times in 0 Posts
    [quote name='wdwells' post='784573' date='14-Jul-2009 20:47']Hi Alan

    What file holds the macro which you are trying to disable? I am suspicious that the Personal file is immune from the Security settings.[/quote]
    Hmmm, good call.

    The errant file contains a workbook open macro which then rippled through all of the worksheets in the collection to perform a brief check (and minor reformat). Unfortunately the minor reformat changed the amendments the user had already made before previously saving the workbook, so it was a tad annoying.

    I have checked the personal file and all other xl start up file options but none appeared to contain any modules or macro code.
    However, of the available settings the first option to "Disable all macros without notification" also includes the caveat that it will NOT block macros from files which are contained within your Trusted locations. OK......but other settings do not contain that caveat so I thought they would not be affected by it. This is incorrect.

    To resolve..I moved the workbook to a non-trusted location and as soon as I opened the file it presented the 'options' conotrl indicating that a macro was present.

    I'm not so sure I like this new security setting as it appears that if you save the file to any trusted location such as your network home drive then macros are run without prompting.
    The original reason for making the location trusted was in response to an access database prompt, but it now applies to all other office files too.

  4. #4
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Weert, Limburg, Netherlands
    Posts
    4,812
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'd remove the folder from the trusted locations and put the database in it's own "private" folder. Add that folder to the trusted locations.
    Jan Karel Pieterse
    Microsoft Excel MVP, WMVP
    www.jkp-ads.com
    Professional Office Developers Association

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •