Results 1 to 13 of 13
  1. #1
    2 Star Lounger
    Join Date
    Apr 2008
    Posts
    188
    Thanks
    0
    Thanked 0 Times in 0 Posts
    In the past I have been able to disable the Lock computer function in the gpedit.msc. I need to do this in a school environment.

    I just got a batch of new Windows XP machines that apparently have a new gpedit.msc.

    I no longer can go to the user configuration > Administrative Templates > System to disable the Lock Computer function.

    I also tried disabling it in the registry. No luck.

    Any suggestions on how to Disable Lock Computer? Can I install the old gpedit.msc?

    Thanks.

    Paul

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    This should do it (it works on my Windows XP Home, where the group policy editor is not available):

    Start RegEdit.
    Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\System.
    Create a new DWORD value DisableLockWorkstation and set its value to 1.
    Do the same in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\Policies\System.

    If you want to enable locking the system again, change both values to 0 or delete both entries.

  3. #3
    2 Star Lounger
    Join Date
    Apr 2008
    Posts
    188
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I added both registry entries and it still does not work for all users, only the local administrator.

    Any other ideas?

    Paul

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Do these PCs have Windows XP SP2 or SP3? There was a bug that was fixed in SP2 that let users lock their PC using Windows key+L even if locking had been disabled in the registry.

  5. #5
    2 Star Lounger
    Join Date
    Apr 2008
    Posts
    188
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Service Pack 3, but I have had it work on that version before. Some more recent update must have changed things.

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    I'm afraid I'll have to leave this for the Windows experts, I don't know why the registry edit doesn't work. You don't even need to reboot for it to become effective...

  7. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    [quote name='pbien' post='785072' date='17-Jul-2009 08:32']Service Pack 3, but I have had it work on that version before. Some more recent update must have changed things.[/quote]

    On XP SP3 systems I have at work, the policy is under user configuration > Administrative Templates > System > CTRL+ALT+DEL Options.

    I'm pretty sure that when you use gpedit.msc and work with Local Computer Policy that changes you make to the User Configuration only affect the logged on user. Same with changing an HKCU registry key. If you want to have that policy affect all users that logon to that PC you need to push a GPO from a server or login as each user then use gpedit.msc.

    Joe
    Joe

  8. #8
    2 Star Lounger
    Join Date
    Apr 2008
    Posts
    188
    Thanks
    0
    Thanked 0 Times in 0 Posts
    On XP systems where I installed Service Pack 3 I could go to the gpedit and make the change so the Lock computer buton was grayed out.

    On the New Dells I got with Service Pack 3 installed the version of gpedit that came with it does not have
    under user configuration > Administrative Templates > System is no longer an available folder.

    Putting in the two registry lines that Hans suggested didn't work either.

    I think either a recent windows update or the preinstalled SP3 is the problem.

    Having the Lock computer button active in a school environment is a disaster.

    I am going to keep trying other approaches, but any suggestions would be really appreciated.

    Thanks.

    Paul

  9. #9
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    [quote name='pbien' post='785374' date='20-Jul-2009 05:20']On XP systems where I installed Service Pack 3 I could go to the gpedit and make the change so the Lock computer buton was grayed out.

    On the New Dells I got with Service Pack 3 installed the version of gpedit that came with it does not have
    under user configuration > Administrative Templates > System is no longer an available folder.

    Putting in the two registry lines that Hans suggested didn't work either.

    I think either a recent windows update or the preinstalled SP3 is the problem.[/quote]

    You are running with an account that is a member of the admin group?
    Have you tried adding the template?

    Joe
    Joe

  10. #10
    2 Star Lounger
    Join Date
    Apr 2008
    Posts
    188
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am logged in as the local administrator while I am trying to make the overall changes.

    How do you add a template to the gpedit? I have never done that.

    Paul

  11. #11
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    [quote name='pbien' post='785422' date='20-Jul-2009 09:26']How do you add a template to the gpedit? I have never done that.[/quote]

    Right click the group to which you wish to add a template (i.e User Configuration | Adminstrative Templates) and select "Add/Remove Templates".

    Joe
    Joe

  12. #12
    2 Star Lounger
    Join Date
    Apr 2008
    Posts
    188
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Joe-

    I figured that one out about the same time you sent your instructions. That solved the problem.

    Paul

  13. #13
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    [quote name='pbien' post='785525' date='21-Jul-2009 05:19']Thanks Joe-

    I figured that one out about the same time you sent your instructions. That solved the problem.

    Paul[/quote]

    You're welcome. Glad you got it worked out. Thanks for posting back.

    Joe
    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •