Results 1 to 4 of 4
  1. #1
    Star Lounger
    Join Date
    May 2009
    Posts
    84
    Thanks
    0
    Thanked 0 Times in 0 Posts
    My template's dialog box collects information after AutoNew runs. When OK button is clicked, form fills. The problem is when user runs AutoNew a second time without first closing the first document that's still on screen. The second document is then not populated correctly.

    Is the fix in AutoNew or another module? Because the first document is still on screen when a shortcut to AutoNew is clicked to run a second document, would that have something to do with the Active Document?

    What code do I need to add so that user can run two or three documents without first having to close any open documents?

    Thank you!
    Charlie
    charlie6067

    Sub AutoNew()
    'Displays form
    frmProposal_Generator.Show
    End Sub

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    How do you dispose of the userform? Do you unload it or hide it when the user is done with it?

  3. #3
    Star Lounger
    Join Date
    May 2009
    Posts
    84
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='HansV' post='786589' date='28-Jul-2009 15:00']How do you dispose of the userform? Do you unload it or hide it when the user is done with it?[/quote]


    Hi Hans,

    The form is unloaded.
    Thanks
    Charlie
    charlie6067

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    If you unload the form, there shouldn't be a problem, so we'll have to know more about the code you're using. Could you post a zip file with (a stripped down copy of) the template?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •