Results 1 to 4 of 4
  1. #1
    2 Star Lounger
    Join Date
    Feb 2003
    Location
    Melbourne, Victoria, Australia
    Posts
    139
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Reports, unusual behaviour (Access 97, SR2)

    I have an application running under W95 over Netware 4.
    I have a report which is driven by a query which links to tables in two other mdb's.
    The report groups down to four levels, but dependent on what level of grouping I have I don't want to print the header or footers.
    I have used the On Format event to call a macro which contains the criteria and the CancelEvent action. When in design mode and I preview the report, a momentary screen refresh and I'm back at the design screen. When I run the report, beside some screen activity, nothing happens.
    The logic of the criteria is correct as I have tested it on a subset of the data in a development environment and the report suppresses those headers and footers.
    Additionally, if I leave the On Format event in place on the report and delete the macro, close and re-open the mdb and open the report in design mode, the same non activity occurs.
    Additionally another report, which does not make use of On Format, exhibits a strange behaviour.
    On a group footer with only the field being displayed there is no problem, but if I concatenate "Total" with the field name I get the previous detail entry in the group.
    I think I've got a screwed up mdb, but how can I straighten it out?
    Regards
    Michael

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Reports, unusual behaviour (Access 97, SR2)

    The simplest method is usually to create a new database and then import all the objects from the one that's giving you problems.
    Charlotte

  3. #3
    2 Star Lounger
    Join Date
    Feb 2003
    Location
    Melbourne, Victoria, Australia
    Posts
    139
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Reports, unusual behaviour (Access 97, SR2)

    Thanks.
    Do you mean all the objects, even the reports that are giving me problems?
    Michael

  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Reports, unusual behaviour (Access 97, SR2)

    Yes. If there's corruption involved, those object probably won't import. If they do, then any corruption will most likely be cured along the way.
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •