Results 1 to 4 of 4
  1. #1
    3 Star Lounger
    Join Date
    Mar 2009
    Location
    Hong Kong
    Posts
    359
    Thanks
    0
    Thanked 0 Times in 0 Posts
    For a database, not sure why "Alike" is automatically replace "like" which I typed in the conditional format dialog box.
    But for another database, "like" can be entered as I type.
    Armstrong
    Attached Images Attached Images

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    It depends on whether you've set the database to use ANSI-92 SQL or not. Access SQL uses Like, ANSI-92 SQL uses ALike.

    To set the SQL dialect:
    - Click the Office button.
    - Click Access Options.
    - Click Object Designers.
    - Tick or clear the check box labeled 'This Database' under SQL Server Compatible Syntax (ANSI 92).

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Oh, and by the way, Access SQL uses ? as wildcard for a single character and * for any number of characters.
    ANSI-92 SQL uses _ for a single character and % for any number of characters.

    See Comparison of Microsoft Access SQL and ANSI SQL [Access 2007 Developer Reference] for more info.

  4. #4
    3 Star Lounger
    Join Date
    Mar 2009
    Location
    Hong Kong
    Posts
    359
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='HansV' post='790474' date='24-Aug-2009 21:49']It depends on whether you've set the database to use ANSI-92 SQL or not. Access SQL uses Like, ANSI-92 SQL uses ALike.

    To set the SQL dialect:
    - Click the Office button.
    - Click Access Options.
    - Click Object Designers.
    - Tick or clear the check box labeled 'This Database' under SQL Server Compatible Syntax (ANSI 92).[/quote]
    Hi HansV,
    Your solution works instantly. Above all, you diagnosis is amazingly accurate.
    Thanks a lot.
    Armstrong

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •