Results 1 to 6 of 6
  1. #1
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    Sometimes when I use the Word Spelling and Grammar check, I encounter a message that Word is unable to proof certain parts of the document, due to these parts being in a foreign language (Portuguese comes up a lot, for some reason). The entire document is in English, so I've no idea what Word is talking about. More to the point, I'm concerned that it is skipping over certain sections (it doesn't specify which sections, unfortunately). I would like to know what function there is to force English as the language for the entire document, and therefore get rid of this residual weirdness of the non-exstient foreign language that Word insists on detecting. I've done the following: Review>Proofing>Set Language>Enlgish (US)>OK. I have no idea if this is forcing English throughout the entire document. I suspect not, because this problem keeps occurring with new documents that are based off of the templates of earlier documents that I've been applying the above steps to.

    Anyone?

  2. #2
    Bronze Lounger IanWilson's Avatar
    Join Date
    Dec 2000
    Location
    Bristol, United Kingdom
    Posts
    1,523
    Thanks
    0
    Thanked 1 Time in 1 Post
    [quote name='ben000' post='792699' date='09-Sep-2009 17:05']Sometimes when I use the Word Spelling and Grammar check, I encounter a message that Word is unable to proof certain parts of the document, due to these parts being in a foreign language (Portuguese comes up a lot, for some reason). The entire document is in English, so I've no idea what Word is talking about. More to the point, I'm concerned that it is skipping over certain sections (it doesn't specify which sections, unfortunately). I would like to know what function there is to force English as the language for the entire document, and therefore get rid of this residual weirdness of the non-exstient foreign language that Word insists on detecting. I've done the following: Review>Proofing>Set Language>Enlgish (US)>OK. I have no idea if this is forcing English throughout the entire document. I suspect not, because this problem keeps occurring with new documents that are based off of the templates of earlier documents that I've been applying the above steps to.

    Anyone?[/quote]
    For an existing document, you could in addition to what you have done select the whole of the text (Ctrl+A or Edit-Select All) and then set the language. You should then find that the whole of the document is then set to your preferred language.

    If new documents are coming up like this too, then you'll need to open the template on which these documents are based and make sure that the default language is set to English (US). If by using previous documents as a template you mean that you take an old document and modify it to get a new one, then you'll find that the new document has the same languages as the old document and you'll have to set it every time.

    Ian

  3. #3
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    For the current document it should be sufficient to do:
    • Control-A (to select the whole document)
    • Click on the Language indicator at the bottom of the document (see attached image)
    • Select the language you want from the dialog box
    • If you have any text boxes, or text in headers and footers, or text in diagrams, then select these and repeat the above two steps
    For documents you create in the future you need to:
    • Click Default... On the dialog box you see in the attached image to set the default language for documents based on Normal.dot
    • If you use any other templates then check every style that you plan to use. From the Styles dialog box you can Modify > Set Language and make sure that the language is set correctly
    • Check your Windows regional settings to make sure that you have the correct default language selected
    [attachment=85470:Language.png]
    Attached Images Attached Images

  4. #4
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    thanks, folks

  5. #5
    Star Lounger
    Join Date
    May 2007
    Location
    Gloucester, Gloucestershire
    Posts
    60
    Thanks
    1
    Thanked 0 Times in 0 Posts
    This might also be relevant.

    In Word 2003 the Set Language dialog has a check box that allows you to switch off automatic language detection. Word 2007 presumably has an equivalent switch somewhere. If your document includes snippets of code, or the contents of a technical file with strange variable names, Word might decide that the strange names are in another language - Swedish came up a lot in my documents until I switched off the automatic language detection.

    Hope this helps.

    Anne

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    [quote name='AuthorAnne' post='792762' date='10-Sep-2009 08:42']In Word 2003 the Set Language dialog has a check box that allows you to switch off automatic language detection. Word 2007 presumably has an equivalent switch somewhere.[/quote]
    Good point, you can see this check box in the screen shot above.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •