Results 1 to 14 of 14
  1. #1
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post
    I have a couple of PDF files on my web page at AlHoffman.Org. There is a "pick list" bar that says stories and it is about my life around the nursing home.

    Some of my "readers" are real newbies and aren't familiar with PDF readers so I'd like to help them by having the file(s) open in "fit to page" zoom to make their reading easier. I see via Google all kinds of command line switches that seem to be for local machine use. Is it possible to put something in my HTML code that will accomplish this?

    (This may belong in Web Design but I figured it's about the PDF readers, so here I am.)

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Your web page merely provides a link to the PDF file (I presume), I don't think you can specify a view there.

    Tips & Techniques: How to force a PDF to open at a particular view describes how to set a preferred view in the properties of the PDF file.

  3. #3
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    [quote name='Bigaldoc' post='797965' date='14-Oct-2009 20:19']I have a couple of PDF files on my web page at AlHoffman.Org. There is a "pick list" bar that says stories and it is about my life around the nursing home.

    Some of my "readers" are real newbies and aren't familiar with PDF readers so I'd like to help them by having the file(s) open in "fit to page" zoom to make their reading easier. I see via Google all kinds of command line switches that seem to be for local machine use. Is it possible to put something in my HTML code that will accomplish this?

    (This may belong in Web Design but I figured it's about the PDF readers, so here I am.)[/quote]

    This should be set as an attribute of the PDF file. The attached screen shot shows how to do this using Acrobat Pro, but this may be different (or impossible) with other PDF creation software.

    [attachment=85980:FullPage.png]

    I have also attached a sample document set to full page initial view, for you to play with.


    [attachment=85978:Example_for_BigAl.pdf]
    Attached Images Attached Images
    Attached Files Attached Files

  4. #4
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thanks to you BOTH for the replies. Well, lo and behold, Open Office, from whence I create the PDF files, DOES have a PDF export option for view and I've been fooling with it since I read your two posts, but can't get it to accomplish anything. It may be that part of the problem is that I've now got my browser set for a FOXIT default, I don't know.

    But I'll keep plugging at it to see if I can get there from here. Thanks for the starter...

    [attachment=85983:2009_10_14_162215.png]
    Attached Images Attached Images

  5. #5
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post
    I reset my local machine to use Adobe as the default and the "fit window" file DOES open in the view I want it to.

    It's very embarrassing but I can't figure out how to make Firefox STOP using Foxit and go back to Adobe. Using Foxit, the files open in very large form. In IE the file open correctly, as I want.

    So how do I "go back" with Fx to Adobe?

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    [quote name='Bigaldoc' post='798020' date='14-Oct-2009 23:08']So how do I "go back" with Fx to Adobe? [/quote]
    Have you tried Tools > Options > Applications?

    [attachment=85985:Options.png]
    Attached Images Attached Images

  7. #7
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Does this help?
    - In Firefox, select Tools | Options...
    - Activate the Applications tab.
    - Locate the PDF Document entry (it may read "Foxit PDF Document" if Foxit is the default).
    - Click the dropdown arrow in the Action column.
    - Select "Use Adobe Acrobat (in Firefox)" or, if you prefer Adobe Reader to open in a separate window, "Use Adobe Reader (default)".
    - Click OK.

  8. #8
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post
    [quote name='StuartR' post='798023' date='14-Oct-2009 18:13']Have you tried Tools > Options > Applications?[/quote]
    Well, I did that but it didn't change anything, but... wait a minute... as usual, I forgot to clear the cache.

    Closed Fx, cleared the cache and it seems to be working properly now. I was trying to get rid of Adobe in favor of Foxit, but I guess I'll have to continue living with Adobe for awhile.

    Thanks again!

  9. #9
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post
    One last thing I'll work on when I get home this afternoon. Prior to all my Foxit messing, my Firefox browser used to open a PDF file directly in the browser. NOW, it launches the Reader on the local machine and downloads the PDF file to that application.

    Since, like a number of others, I updated Adobe Reader from within the app to 9.2 I'm thinking that my Fx plugin is now downlevel. See attached. As per your assistance, I have the Helper app window set to Reader 9.2, but the plugin looks to be downlevel. I may have to remove and re-install the Reader to see if that updates the plugin. Later today...

    [attachment=85994:2009_10_15_110120.png]
    Attached Images Attached Images

  10. #10
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post
    Just to finish this off since both Hans and Stuart have taught me what to do in creating my PDF files...

    Thinking that my Fx plugin was downlevel, I completely un-installed Adobe Reader and re-installed the program from the downloaded package. The Fx plugin still does NOT come up to level 9.2 so that wasn't my problem with getting PDF returned to opening IN the browser window.

    It turns out that a slight nuance in Hans' tip above was the answer but I didn't spot it there and went looking at Mozilla. You must select Use Adobe Acrobat (in Firefox) to get PDFs to open inside a browser window. I'm back to where I was before I messed with Foxit! I still have it installed however and may change my mind at some future time (again).

    [attachment=86009:2009_10_15_153808.png]

    (PS Humble Pie Time: As much as I occasionally rant about IE, it's interesting to note that IE did NOT give me any trouble during this whole "exercise" and has been dutifully opening my PDFs at the Open Office chosen size of "fit to page"!!!)
    Attached Images Attached Images

  11. #11
    Bronze Lounger IanWilson's Avatar
    Join Date
    Dec 2000
    Location
    Bristol, United Kingdom
    Posts
    1,523
    Thanks
    0
    Thanked 1 Time in 1 Post
    [quote name='Bigaldoc' post='798210' date='15-Oct-2009 20:49']Just to finish this off since both Hans and Stuart have taught me what to do in creating my PDF files...

    Thinking that my Fx plugin was downlevel, I completely un-installed Adobe Reader and re-installed the program from the downloaded package. The Fx plugin still does NOT come up to level 9.2 so that wasn't my problem with getting PDF returned to opening IN the browser window.

    It turns out that a slight nuance in Hans' tip above was the answer but I didn't spot it there and went looking at Mozilla. You must select Use Adobe Acrobat (in Firefox) to get PDFs to open inside a browser window. I'm back to where I was before I messed with Foxit! I still have it installed however and may change my mind at some future time (again).

    [attachment=86009:2009_10_15_153808.png]

    (PS Humble Pie Time: As much as I occasionally rant about IE, it's interesting to note that IE did NOT give me any trouble during this whole "exercise" and has been dutifully opening my PDFs at the Open Office chosen size of "fit to page"!!!)[/quote]
    I have been experimenting. I opened a Word document in OpenOffice, created a PDF with the initial view set to fit in window, and it opened for me in Foxit Reader fitting in the Window. (And it still does that even if I set the preferences in Foxit Reader for the default zoom to be 100% rather than fit page.

    I attach the file so you can see how it opens in Foxit for you. (It's just the words of Amazing Grace.)

    [attachment=86010:Amazing_Grace.pdf]

    Ian
    Attached Files Attached Files

  12. #12
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    Ian, your attachment opens in "Fit Page" mode in Internet Explorer 8, but in "Fit Width" mode in Firefox 3.5.3 (in a new tab in both browsers).

    (Using Foxit 3.1.1.0928)

  13. #13
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post
    [quote name='IanWilson' post='798217' date='15-Oct-2009 16:17']... I attach the file so you can see how it opens in Foxit for you. (It's just the words of Amazing Grace.)[/quote]
    Thanks for testing, Ian! I just duplicated your experience with not only YOUR file but my own two as well, so it's clear to me that Open Office IS producing PDF files that I've set to "fit page" and they are viewable on my local machine in either Foxit or Adobe Reader, regardless of the default settings of the reader - they come open in "fit page" view.

    It's clear to me now that my problem lies with how to tell Firefox to deal with PDFs in either Adobe or Foxit.

    This has been this week's learning session for me and I WILL pursue Foxit further, just to get away from the (alleged) bloat of Adobe's Reader, but that's for later...

  14. #14
    Bronze Lounger IanWilson's Avatar
    Join Date
    Dec 2000
    Location
    Bristol, United Kingdom
    Posts
    1,523
    Thanks
    0
    Thanked 1 Time in 1 Post
    [quote name='HansV' post='798224' date='15-Oct-2009 21:32']Ian, your attachment opens in "Fit Page" mode in Internet Explorer 8, but in "Fit Width" mode in Firefox 3.5.3 (in a new tab in both browsers).

    (Using Foxit 3.1.1.0928)[/quote]
    It opened in Fit Page mode in Firefox 3.5.3 for me, but then I went to Foxit and changed the preference there to Fit Width and then it opened at Fit Width using Firefox. So the position seems to be that Opera and IE8 follow the settings in the document when opening it with Foxit, but Firefox follows the preferences set in Foxit rather than those in the document.

    Ian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •