Results 1 to 5 of 5
  1. #1
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Ephrata, Washington, USA
    Posts
    683
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Subform doesn't refresh after data entry (97)

    I would like someone to look at my database and help me figure out what I've done wrong. I have a form to enter visitor badges (I posted questions about this before, and those questions were answered by people from the bbs - thanks!). It has two buttons on it so that if the company or employee is not already in the list, you can add the company or employee. The buttons call up either the personnel form or company form. You then enter the new information and press the DONE button to return to the main log form, where you scroll a list and pick the new company, which should switch the subform to that company's information. The problem is that once you press DONE on the personnel form, the company is listed on the main form drop down list, but it doesn't refresh the subform to enter the badge number.

    Whew. That sure sounds confusing. Much easier to see if you would look at the form and try to enter a new company and employee and then try to go back to the main screen and enter a tag number for that particular company and person.

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Subform doesn't refresh after data entry (97)

    Your message sounds like you're referring to an attachment. If so, it got lost along the way. Are you also requerying the subform from the AfterUpdate event of the combobox?
    Charlotte

  3. #3
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Ephrata, Washington, USA
    Posts
    683
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Subform doesn't refresh after data entry (97)

    No, I didn't attach it. It's too big (162kb). Last time I asked for help, I just emailed the database to anyone who was willing to look at it. I'm not sure how to "requery a subform from the AfterUpdate event of the combobox"... Is this something I do through the properties of the form?

  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Subform doesn't refresh after data entry (97)

    Is it still too big if you compact and then zip the file? If so, try a <A target="_blank" HREF=http://www.wopr.com/cgi-bin/w3t/showthreaded.pl?Cat=&Board=acc&Number=44732&page=& view=&sb=&o=&vc=1#Post44732>decompile</A> first and then compact the database without recompiling first. That usually squeezes out some additional space before you zip the file.
    <hr>Is this something I do through the properties of the form? <hr>
    No, it's something you do from code normally. In the AfterUpdate event procedure for your combobox, simply add a line something like Me!subform.requery, where subform is the name of the subform (not necessarily the name of the subform itself) control on your form.
    Charlotte

  5. #5
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Ephrata, Washington, USA
    Posts
    683
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Subform doesn't refresh after data entry (97)

    Thanks. I'll try those and will get back to you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •