Results 1 to 6 of 6
  1. #1
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,421
    Thanks
    33
    Thanked 195 Times in 175 Posts
    My settings are

    [attachment=86324:TimeZone.GIF]

    but when I post a message it shows as an hour earlier than the actual time.

    Here I have posted at 11:05 GMT (more of less...)!
    Attached Images Attached Images
    BATcher

    Time prevents everything happening all at once...

  2. #2
    Star Lounger
    Join Date
    Aug 2009
    Location
    Seattle, WA
    Posts
    81
    Thanks
    0
    Thanked 0 Times in 0 Posts
    (Reposted from the Test Area thread...)

    FYI: IPBoard seems to have acknowledged problems implementing time zones and DST. In the section of the software setup where we select the server's native time zone, it offers the following suggestion:

    If you have chosen the correct timezone and the clock is an hour out, this is because of daylight savings time and your members can correct this by editing their 'Board settings' via their User Control Panel.
    Helpful, no?

  3. #3
    Platinum Lounger
    Join Date
    Feb 2002
    Location
    A Magic Forest in Deepest, Darkest Kent
    Posts
    5,681
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Dan Engler View Post
    (Reposted from the Test Area thread...)

    FYI: IPBoard seems to have acknowledged problems implementing time zones and DST. In the section of the software setup where we select the server's native time zone, it offers the following suggestion:


    Helpful, no?
    I seem to be OK Dan but are you suggesting that the Loungers offset the time as a work around via their control panel?
    Jerry

  4. #4
    Brian Livingston
    Guest
    I'd like to investigate a bit further the Summer/Daylight Time adjustment in IP.Board 3.0. I have no technical details about the algorithm at this time. However, looking at the screen shot, I can see one possible interpretation. It's widely known that GMT (Greenwich Mean Time or UTC, Temps Universel Coordonné) never goes on Summer/Daylight Time. So some developer at Invision may have decided to ignore the DST Correction if the selected time zone is GMT.

    I'm not saying that that's what's happening, but from what I've seen of the internals of IBP 3, nothing would surprise me!

    While GMT never goes on Daylight Time, countries that exist in the GMT+0 time zone can and do switch to GMT+1 in the middle of the year. As I'm sure you realize, the U.K. rolled back to Standard Time (GMT+0 in London) on Oct. 25, whereas the U.S. and Canada rolled back on Nov. 1. I don't know whether that relates to the issue.

  5. #5
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Brian,
    It seems to be working now, at least over here. I did some changes with the settings earlier and got it to show the correct time, then suddenly, some hours later, now, I was 1 hour ahead. Resetting the boxes to DST correction got the time right. See thread in the Test Area started by BATcher.
    http://www.wopr.com/index.php?showto...dpost&p=801291

    BTW: Thanks for fixing the problem with "thread not displayed" when writing comments/posts.

  6. #6
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,421
    Thanks
    33
    Thanked 195 Times in 175 Posts
    Quote Originally Posted by Argus View Post
    It seems to be working now, at least over here.
    I'm happy that this problem has now been fixed! Thanks!
    BATcher

    Time prevents everything happening all at once...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •