Results 1 to 5 of 5
  1. #1
    5 Star Lounger
    Join Date
    Jul 2001
    Location
    Terneuzen, Netherlands
    Posts
    895
    Thanks
    0
    Thanked 0 Times in 0 Posts
    When I copy Excel charts (or ranges, that works too) into e.g. a WORD document or an email, I always make sure that the destination does not get too large. If one does a simple "Copy" / "Paste" actions, actually the data underlying the chart are also copied over. If your chart is large (many ranges with e.g. 4000 points) the past might make the size of your desitination-file many, many Mbs larger.

    So, my 'trick' is to first select the chart, then with the SHIFT button pressed down go to the Excel "Edit"-menu. As you will see, now "Copy" has changed to "Copy Picture" (and you are presented some options if you select that). Then I also do a "Paste Special" (-as picture-) in my destination to make extra sure and voila... there's a representation in my destination identical to the prior result but much, much smaller.

    OK, so far so good, right? Well, not entirely as now I have a spreadsheet where I'm doing just that as well (and some more permutations have been tried as well) but it simply doesn't work... I get an email (my destination) of 12 Mb just for one little chart. Scrolling the email shows that the chart builds first and then the markers are drawn on top. This is proof that the picture is really not a "picture" but still has the underlying data-points (many in my case). STILL, I did use copy as printed or as shown on screen... very strange.
    I know (and have used) the option to copy a chart as JPG in VBA (I think), is that not available somewhere from the GUI?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    You can copy the chart in Excel (without Shift), then select Paste Special in Word. Select Enhanced Metafile as format, not Microsoft Excel object.


  3. #3
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Weert, Limburg, Netherlands
    Posts
    4,812
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Did you try doing a paste special in Word and pasting as picture?
    I think the fact that you see the chart first and then the markes does not necessarily mean there is still a chart with data, it may also be the way Word renders the picture???
    Jan Karel Pieterse
    Microsoft Excel MVP, WMVP
    www.jkp-ads.com
    Professional Office Developers Association

  4. #4
    5 Star Lounger
    Join Date
    Jul 2001
    Location
    Terneuzen, Netherlands
    Posts
    895
    Thanks
    0
    Thanked 0 Times in 0 Posts
    By the way... I'm not using WORD but Excel as source. The suggested way to NOT use shift and "copy as displayed on screen or printer" to then paste-special in the destination does seem to help howver... very strange

  5. #5
    New Lounger
    Join Date
    Jan 2014
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I work with PowerPoint presentations A LOT. Most slides have Excel charts on them. I thought pasting the Excel chart as a chart rather than a picture was the way to go until a) I had the formatting of the Excel chart go crazy when I tried to make a change, and b) the size of the PowerPoint file quadrupled and I could no longer send it through email.

    Paste As Picture is the way to go and worth the extra effort of copy/pasting a new picture, if a change is required.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •