Results 1 to 2 of 2
  1. #1
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    160
    Thanks
    0
    Thanked 2 Times in 2 Posts
    I need to save a file into a subfolder of Program files (x86) to modify a component of one of my applications (JAlbum). 64-bit Vista Home Premium informs me that I need to contact the administrator in order to save the file, and denies me access. The files in the folder are set as read-only. But I AM the administrator on my own humble laptop computer. Vista goes through the motions of changing the attribute for me but when I check aafterward, the files are still read-only. How do I get around this nasty shell game so I can save the file? This did not happen under XP.

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,594
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Quote Originally Posted by jsallen View Post
    I need to save a file into a subfolder of Program files (x86) to modify a component of one of my applications (JAlbum). 64-bit Vista Home Premium informs me that I need to contact the administrator in order to save the file, and denies me access. The files in the folder are set as read-only. But I AM the administrator on my own humble laptop computer. Vista goes through the motions of changing the attribute for me but when I check aafterward, the files are still read-only. How do I get around this nasty shell game so I can save the file? This did not happen under XP.
    In Vista and later operating systems by default a user is not allowed to modify the contents of folders under Program Files. Even though your user account may be a member of the administrator group it does not have full adminstrative privileges. You need to check your account privileges and change them accordingly. In Windows Explorer, right click on one of the files you wish to change. Select Properties | Security. If your account is listed, select it to check the permissions. If the Administrators group is listed, select it to check the permissions.

    Use the "Edit" button change permissions. If you still can not change the flags, use the "Advanced" button at the bottom of the Security tab. You can then click on the "Owner" tab and take ownership of the file. You should then be able to change any setting on the file.

    Joe
    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •