Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Burke, VA, USA
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Contrary to Iolo's marketing literature, System Mechanic 9.5 doesn't work with Win7 Ultimate 64bit. I recently upgraded my desktop to Win7 64bit. When trying to reinstall sys mechanic, user account control asks if I want this program to make changes... I click yes... UAC window disappears... nothing happens. Called Iolo tech support multiple times over past 2 weeks for help. They are worthless... Been using System Mechanic for years and really like it. However, Iolo tech support seems to be doing everything possible to loose me as a customer.

    Has anyone else had this problem? Appreciate any feedback! :-)

  2. #2
    New Lounger
    Join Date
    Dec 2009
    Location
    White Rock, British Columbia, Canada
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello,
    I find many third party programs have not taken the time/cost of upgrading their older versions.

    They want us to buy a new version to go with an new OS.
    I had the same problem with Acronis True Image when Vista came out and again when Windows 7 came out.

    Marketing redundancy is what I refer to it as.

    Mike the mod

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Lawrenceburg, Indiana
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Have you gotten any further with this? I recently got a new computer with Windows 7 Pro (64 bit) and spent the 19.95 to extend my System Mechanic subscription so I could get the new 9.5 version that they say will work. Just like you, I can't get it even finish installing. I sent their support people an email but haven't heard back yet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •