Results 1 to 6 of 6

Thread: Code indenting

  1. #1
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post
    I find that the indenting of code is corrupted when wrapped with the code and /code tags as shown here.
    Regards
    Don

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    I reported this in Indenting between code tags incorrect. Not everybody has this problem, and it appears to have been abandoned.

  3. #3
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by wdwells View Post
    I find that the indenting of code is corrupted when wrapped with the code and /code tags
    All indenting after the first level was lost? There seems to be a problem preserving spacing during edits. However, I have been fortunate not to encounter that (I use the less rich editor, if that makes a difference).

  4. #4
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thank you Jefferson

    Unchecking the Enable visual (RTE) editor? in WS Home Lounge Lobby Settings Help Files Edit your general settings did the trick.

    That's reminiscent of the days of WordPerfect and Reveal codes.
    Regards
    Don

  5. #5
    Brian Livingston
    Guest
    The problem with the incorrect indenting of code styled as code lies deep within the core of our IP.Board platform software. We can't touch this code ourselves, only the look and feel of items on the page. The issue has not been abandoned by our developers, they are just dependent on a patch coming some day from Invision itself.

    I'll check on whether the fact that the WYSIWYG editor (rich text editor or RTE) is doing this is known to Invision, whereas the Standard Editor does not do it. The default for everyone joining the Lounge is to use the Standard Editor. However, people can switch in their Settings to the RTE, and some have no doubt done so, since it sounds better. (Who doesn't want to be rich?) Perhaps we should add a line of text to that Settings page, saying the RTE has known issue of corrupting code if you apply the code style to it. I'm not sure whether or not we can disable the RTE entirely. Many people probably only know how to use the RTE now.

  6. #6
    Brian Livingston
    Guest
    We've added a cautionary line to the check box that selects the rich text editor (RTE). It appears to be repeatable that applying the code tag to code in the RTE munges the correct indenting of lines. If so, users should be warned before switching the RTE on. The deafult for the RTE is off, I believe.

    The following options are shown when you click Settings on the main menu.

    [attachment=86972:settings-rte.png]

    If the cautionary line is still not correct, let me know and we can word this a different way. Of course, we might be able to remove the caution if Invision patches the errant behavior in the RTE.

    Thanks for reporting this.
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •