Results 1 to 9 of 9
  1. #1
    2 Star Lounger
    Join Date
    May 2002
    Posts
    155
    Thanks
    3
    Thanked 0 Times in 0 Posts
    I have Virtual PC installed and configured in my new workstation which is running Windows 7.

    I need Virtual PC to run my old Office 2000 applications which I am still using, pending buying Office 2010 when it is released next summer.

    My problem is that all my date fields in my existing Excel spreadsheets are displaying incorrectly. I know that the standard way of correcting this (under XP) is to go into Control Panel, Regional Settings, Set Date and Time, and set the correct short date format.

    The issue in my new machine is that the regional settings and short date format are all correctly set in Control Panel in Windows 7. The issue must therefore be that these settings are incorrect in the Virtual XP mode.

    But I can't find how to get to Control Panel in the Virtual PC mode (and indeed I don't know if there is such a function!).

    Can anyone help, or suggest a workaround?

    Many thanks

    Neil

  2. #2
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Vienna, Wien, Austria
    Posts
    5,009
    Thanks
    0
    Thanked 0 Times in 0 Posts
    If you are a UK-based user, and you are seeing dates based in US format, this may be a limitation of Virtual XP mode.

    For example, Remote Desktop always defaults to a US-based keyboard - no matter what settings are in operation on either the Host or Target machine. Thus, if you have a Password that uses a non-standard ASCII character (such as a vowel with an accent), you are automatically locked out of the target machine as the password cannot be entered.

    Hope This Helps
    Gre

  3. #3
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by neil View Post
    But I can't find how to get to Control Panel in the Virtual PC mode (and indeed I don't know if there is such a function!).
    I can get to the Control Panel running XP in Virtual PC via
    Start > Settings > Control Panel > Regional....
    just as in an ordinary installation.

    Are you saying you can't?

    (I would have said the date format in Excel was set by the cell formatting which seems to work for me...)

  4. #4
    2 Star Lounger
    Join Date
    May 2002
    Posts
    155
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by malcolm wagner View Post
    If you are a UK-based user, and you are seeing dates based in US format, this may be a limitation of Virtual XP mode.
    I am indeed Malcolm, and dates in US format is exactly the issue!

    Quote Originally Posted by malcolm wagner View Post
    ...Hope This Helps
    Not sure it helps, Malcolm, but it definitely helps explain...!

    Neil

  5. #5
    2 Star Lounger
    Join Date
    May 2002
    Posts
    155
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Leif View Post
    I can get to the Control Panel running XP in Virtual PC via
    Start > Settings > Control Panel > Regional....
    just as in an ordinary installation.

    Are you saying you can't?
    No, that works for me too Leif. What I am saying is that the Control Panel I reach with those keystrokes is the "Windows 7" Control panel, and the settings in that are exactly right (ie. regional settings = UK, short date format = dd/mm/yy).

    My problem was that because these (short date format) settings were not reflected in my Excel (2000) spreadsheets in Virtual PC mode (as they always were in previous XP machines), then I was wondering if there was a "second Control Panel" into which I had to enter settings relating to programs running under Virtual PC (and if so, where I found such a Control Panel!).

    But it seems I was wrong. There is actually only one Control Panel, and the issue is why the short date settings from that, are not reflected in Excel running under Virtual PC.


    Quote Originally Posted by Leif View Post
    (I would have said the date format in Excel was set by the cell formatting which seems to work for me...)
    I can use cell formatting to correct existing cells which are displaying incorrectly, but every new "short date" I subsequently enter still appears in US format. It is this I was trying to fix!

    Thanks

    Neil

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    My XP Mode Virtrual PC has its own control panel, accessible from the XP Mode start button. Even though I had configured regional settings as United Kingdom on the Windows 7 PC, I found that the default on the XP Mode was US, so I changed it to UK and everything seems to work normally for me.

    Are you SURE that you don't see control panel on the XP Mode start menu?

    The attached screenshot shows the two regional settings dialog boxes displayed at the same time, just to prove a point.

    [attachment=87246:Regional Settings.png]
    Attached Images Attached Images

  7. #7
    2 Star Lounger
    Join Date
    May 2002
    Posts
    155
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Ah, so there is a separate Control Panel! That definitely looks promising, Stuart! The problem is that I can't seem to get to it!

    I am entering Virtual PC from my windows 7 screen, by clicking Start, then All Programs, then scrolling down to the bottom of the list where there are 3 different Virtual PC options.

    I'm not at the pc in question now - I'm at work - but from memory the options are Virtual PC Applications, Virtual PC Settings (or Administration) and a third which I can't remember.

    What I have never found, as such, is the "XP Mode start menu" to which you refer.

    I'm probably just being shortsighted, or missing the point completely...

    Everyone's help so far is much appreciated.

    Neil

  8. #8
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Quote Originally Posted by neil View Post
    ...
    What I have never found, as such, is the "XP Mode start menu" to which you refer.
    ...
    I never thought to ask WHAT Virtual PC product you are running. My screen shots are from Windows XP mode.

  9. #9
    2 Star Lounger
    Join Date
    May 2002
    Posts
    155
    Thanks
    3
    Thanked 0 Times in 0 Posts
    I've found it now, and entered the correct settings, and solved my problem - thanks everyone for your help (and in particular to StuartR who made me realise it must be there somewhere!).

    Just in case anyone was wondering how I could have "lost" XP-mode Control Panel, it was because I was already running Excel 2000 when I had the date issue, and went looking for control panel. It seems that if you already have an application running in Virtual PC, and click start button, all programs, Windows Virtual PC, XP Mode - you just get a list of the applications running. You can't drill down or access Control Panel in such circumstances.

    As soon as you follow the same keystrokes with no Virtual PC applications running, you are presented with a normal XP desktop, with Control Panel accessible as normal.

    So yes, I was probably being a bit slow, but not that slow...

    Cheers

    Neil

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •