Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Ipswich, UK
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am the Administrator on a small home network running 4 PCs (WinXP Pro, Vista Home Premium, and Win7 Home Premium - getting Access Denied msgs when I try to access folders on the Vista PC via the network. The folders are shared, I am the 'owner'. What do I need to do to allow access to these folders via the network?

  2. #2
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Quote Originally Posted by Howard Smith View Post
    I am the Administrator on a small home network running 4 PCs (WinXP Pro, Vista Home Premium, and Win7 Home Premium - getting Access Denied msgs when I try to access folders on the Vista PC via the network. The folders are shared, I am the 'owner'. What do I need to do to allow access to these folders via the network?
    When you access files across a network there are two separate sets of permissions that are checked.

    The File / Folder permissions are checked in exactly the same way as if you access the files locally.
    In addition the Share permissions are checked, to see if you are allowed to access that share.

    Have you checked both of these?

    In addition it is a good idea to check what user Windows thinks you are when you connect via the network.
    On the Vista PC you should right click on Computer and choose Manage, expand "Shared Folders" in the left pane and click sessions. This will show what usernames are being used by users connected over the network.

  3. #3
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,162
    Thanks
    47
    Thanked 976 Times in 906 Posts
    And make sure Windows firewall allows file sharing.

    cheers, Paul

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    Ipswich, UK
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for all replying; As an example, if I check my Vista (C drive, it is shown as 'Shared' (Share name: Drive C - Vista). If I click on Permissions, under Group or user names is shown: 'Everyone' and
    'Howard' (Amd-PC\Howard). I am the only administrator. For both these entries, Permissions show the 'Allow' boxes ticked for 'Full Control', 'Change', and 'Read' (the only entries). Do I need to (or can I) add entries for users on other PCs?

    Interestingly, when I check Shared Folders, Sessions (on the Vista PC) the only User shown is 'Guest' on Computer 'Trendsonic' (the Windows 7 PC). But I know that the 'Guest' user is disabled on that PC, and that its current user is 'Howard' (Administrator). Also, if I check Shared Folders, Sessions on the Trendsonic PC, no users are in evidence.

    Each of the PCs (obviously) has a unique name, and both share the same workgroup name 'WORKGROUP'. My network is a 'Private' one, an all the 'Sharing and Discovery' options are ticked (i.e. On) except 'Password protected sharing which is Off.

    Am I missing something here?

  5. #5
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Howard,

    There is lots of information here, so please forgive me if I don't respond to all your issues.

    Permissions on a computer can only be granted to local users, not to remote ones. So when someone connects over the network they will be given a local identity. If they provide a valid username and password then this may be a normal user account, otherwise it is probably going to be guest. When you say that the guest user is disabled, I suspect this is just for local logins, not for remote connections. To ensure that the guest account is configured correctly you can install the ntrights tool from the Window resource kit and issue the following commands from a command prompt:
    • ntrights +r SeNetworkLogonRight -u Guest
    • ntrights -r SeDenyNetworkLogonRight -u Guest
    • net user guest /active:yes


    The easiest way to ensure that access to shares works the way you expect is to create identical usernames, with the same non-blank password, on both computers. Then log into this account. There are other ways to get it to work but this one is certainly the most simple.

  6. #6
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts
    Also note that Vista and Windows 7 likes to see the SAME user name and passwords (yes, it MUST be a password) on all machines, to work smoothly

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  7. #7
    2 Star Lounger zigzag3143's Avatar
    Join Date
    Dec 2009
    Location
    NYC
    Posts
    195
    Thanks
    13
    Thanked 3 Times in 3 Posts
    Hi and welcome

    I just wonder if you are set up using workgroup or home group.

    Ken
    Microsoft Most Valuable Professional-- Windows Expert Consumer 2009---2015
    MCC 2013-2015

    Wanikiyi & Dyami--Team ZigZag3143

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •