Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Nov 2002
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    word does not respond after run the following cod (1)

    I encounter a problem with the following code, when running it, word does
    not respond.

    Sub Macro1()
    MsgBox ActiveDocument.Sections(13).Footers(3).Range.Frame s.count
    End Sub

    I use word97 on sp1

    Thank you very much

  2. #2
    Gold Lounger
    Join Date
    Dec 2000
    Location
    Hollywood (sorta), California, USA
    Posts
    2,759
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: word does not respond after run the following cod (1)

    Well, that line of code assumes a document that has at least 13 sections, 3 footers in the 13th section and at least one frame in the 3rd footer. If that is not the case, you will get the error:

    "Requested memeber of the collection does not exist."

    UNLESS, you have On Error Resume Next above that line somewhere. In that case you won't see any error message.
    Kevin <IMG SRC=http://www.wopr.com/w3tuserpics/Kevin_sig.gif alt="Keep the change, ya filthy animal...">
    <img src=/w3timages/blackline.gif width=33% height=2><img src=/w3timages/redline.gif width=33% height=2><img src=/w3timages/blackline.gif width=33% height=2>

  3. #3
    BAM
    Guest

    Re: word does not respond after run the following cod (1)

    Hi bwang,

    The code should function correctly in Word 97. Since you are not patched to SR2 and the post service release that's the first thing I would suggest. Although I can't find anything specific to the code you are running, there were various bugs corrected in the additional patches.

    Here is some information on obtaining SR2b and the post service release patches:

    SR2b: <A target="_blank" HREF=http://officeupdate.microsoft.com/articles/sr2fact.htm>http://officeupdate.microsoft.com/articles/sr2fact.htm</A>

    Post Service Release:
    <A target="_blank" HREF=http://support.microsoft.com/support/kb/articles/Q265/3/74.ASP>http://support.microsoft.com/support/kb/ar...s/Q265/3/74.ASP</A>
    ~~~~~~~~~~~~
    Cheers! <img src=/S/flags/USA.gif border=0 alt=USA width=30 height=18>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •