Results 1 to 3 of 3
  1. #1
    Lounger
    Join Date
    Jan 2003
    Location
    Brisbane, Queensland
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi

    Hope someone can help. Over the years I've had odd occasions where spell check seems disabled. I'm using Word 2007 but reasonably confident it happened in a previous version as well. I've checked the settings (eg that 'hide spelling errors' isn't ticked etc) and all seems as it should be. If I start a new document spell check is fine, but if I copy & paste the problematic document into a new one the 'glitch' goes with it. I'll just have to put my spelling hat on for this one as I'd got too far into it before I noticed, but would appreciate any suggestions for future occurrences.

    Thanks ... Katie

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 28 Times in 27 Posts
    Hi,

    Not clear whether you're referring to the "Check Spelling As You Type" kind of spell checking, or the kind of spell checking where you spell check the entire document at once. Anyway, here are a few things to check:

    In Word Options > Proofing, see if there's a checkmark next to "Check Spelling As You Type" (if you want that kind of spell checking).
    Also, in that same part of the dialog, there's a 'Recheck Document' button - clicking this will reset the spelling and grammar checker for the current document - so it would be worth a try if the spell checker doesn't seem to be working.

    And also, you could select the entire document, or just the suspect part of the document, and then on the Review tab, click on Set Language to display the Language dialog. There's a checkbox there for "Do not check spelling or grammar" which in this case, you want to make sure is not checked.

    Gary

  4. #3
    Star Lounger
    Join Date
    May 2007
    Location
    Seattle, Washington, USA
    Posts
    85
    Thanks
    0
    Thanked 2 Times in 2 Posts
    (Gary said pretty much what I was about to post, but since I've got it all typed up, I'm going to post it anyway!)

    Three things that have caused similar situations for me:

    (1) some or all of the text is marked to be in another language, or

    (2) some or all of the text has no language applied to it at all, or

    (3) the text has had SpellCheck run on it previously and is retaining the “ignore” instructions applied by the previous user.

    Re (1): Text for documents in my office comes from all over the place, and often has a language setting (and styles) other than ours applied to bits and pieces of it. I’ve gotten into the habit of, when I get documents that have been edited by other users, (a) selecting all of the text in the document, and (b) then hard-applying the language I need (and also un-ticking “Do not check spelling or grammar”).

    These Set Language settings can be reached via the “Set Language” icon on the Review tab, Proofing Group. (I’ve added that command to my QAT because I use it so often.).

    In the Set Language window I always physically click on my language, even if it is already highlighted, because I don’t trust the window to be an accurate reflection of every language in my document.

    Re (2): Our Scan/OCR software has an output setting of “no formatting,” and it took me a while to figure out that “no formatting” involved more than just paragraph settings and font settings, it also means there is no language at all applied to the resulting text! So, as above for (1), I select all and proceed to “Set Language.”

    Re (3): F7 opens the Spelling Window (on Review ribbon), which displays an “Options” button, which opens the Word Options Proofing window, on which is a “Recheck document” button. Pushing Recheck document clears all the previous “ignore” instructions, and SpellCheck will again stop on all unknown words.

    By the way, This “Recheck document” command can be added to the QAT, but it doesn’t seem to work there, for me anyway. In fact, this command, when added to custom toolbars in Word 2003, never worked for me either.

    Judy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •