Page 1 of 4 123 ... LastLast
Results 1 to 15 of 46
  1. #1
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Not having much luck finding what setting somehow got changed.

    On a XP laptop where one user ID belongs to a domain, I was not able to change the password that was about to expire. After re-joining the domain I was then able to change my password (I also use a XP desktop but was logged out at the time).

    Since then the option to Shut Down is not available (button & from drop down list), only Logoff the current user. After that user is logged off & you give the 3 finger salute (ctrl alt delete) the shut down option(s) are then available.

    This is for all accounts on the machine, not just the 1 for the domain (that is a Admin account. This also happens with my local admin account).

    This is annoying having to go through a 2 step process to shut down from what it should be.

    Any ideas on what I need to change back?

    TIA!
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  2. #2
    New Lounger
    Join Date
    Dec 2009
    Location
    Australia
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Not sure if this helps, but you can shutdown your computer with the command Shutdown.exe -f -s

    To see all the shutdown options, open a command window and type shutdown.

    I use this command to shutdown after doing evening backups.

    You could write a batch file and create a desktop shortcut pointing to it.

    Peter

  3. #3
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Peter, I am familiar with that one & even have it as a shortcut on my desktop computer giving me a 30 second window (helps when remote desktop to that machine to force a re-boot).
    (%windir%\system32\shutdown.exe -r -t 30 -c "Rebooting computer")

    Unfortunatly to me this is not as "graceful" of a shut down as I would like to do on this machine & would like to restore the shut down options from just Logoff (Shut Down, Restart, Stand By, Hibernate).

    After I logoff & ctrl-alt-delete again I do then have these options. I just don't know where to make the changes to get those options back when logged into the machine.

    Thanks.
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,554
    Thanks
    2
    Thanked 614 Times in 550 Posts
    Quote Originally Posted by jhimes View Post
    After I logoff & ctrl-alt-delete again I do then have these options. I just don't know where to make the changes to get those options back when logged into the machine.
    See if the left side of item #131 at Kellys-Korner XP Tweaks helps.

    JOe

  5. #5
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts
    This being on a Domain network, the IT people may have done something requiring that one log off first.
    Check with the IT people.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  6. #6
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    DaveA, no out admins have not applied such a policy, but thanks for the idea.

    JoeP, thanks for the link. I will take a look at the registery setting that file attmepts to modify when I get home.
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer]
    "NoClose"=dword:00000000

    Currently my XP desktop that does not have this issue also does not have this particular key entry.
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  7. #7
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So far, still no luck.
    http://support.microsoft.com/kb/555449 - This is to edit the setting in gpedit.msc - User Configuration\Administrative Templates\Start Menu and Taskbar This is set to not configured.

    http://support.microsoft.com/kb/303070 - This is about adding it back to the Classic menu. does not help in this situation.

    I did look at this:
    Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy
    Expand the Local Policies and click "User Rights Assignment"
    Shut Down The System is applied to all user groups.

    Also under the Security Options - Shutdown allowed w/o having to log on is also enabled.


    I also tried adding - [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer]
    "NoClose"=dword:00000000


    JoeP, sorry that did not work either.

    I think for now I will create 2 desktop shortcuts, one to Shutdown & one for Restart as that option is also missing until I (or someone else!) can figure out what needs to be changed as the logging out & then shutdown is getting old.

    Update: When I try & use the shutdown.exe command I am now getting the message "A required privilege is not held by the client."
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  8. #8
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So far, still no luck.
    http://support.microsoft.com/kb/555449 - This is to edit the setting in gpedit.msc - User Configuration\Administrative Templates\Start Menu and Taskbar This is set to not configured.

    http://support.microsoft.com/kb/303070 - This is about adding it back to the Classic menu. does not help in this situation.

    I did look at this:
    Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy
    Expand the Local Policies and click "User Rights Assignment"
    Shut Down The System is applied to all user groups.

    Also under the Security Options - Shutdown allowed w/o having to log on is also enabled.


    I also tried adding - [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer]
    "NoClose"=dword:00000000


    JoeP, sorry that did not work either.

    I think for now I will create 2 desktop shortcuts, one to Shutdown & one for Restart as that option is also missing until I (or someone else!) can figure out what needs to be changed as the logging out & then shutdown is getting old.

    Update: When I try & use the shutdown.exe command I am now getting the message "A required privilege is not held by the client."
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  9. #9
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So far, still no luck.
    http://support.microsoft.com/kb/555449 - This is to edit the setting in gpedit.msc - User Configuration\Administrative Templates\Start Menu and Taskbar This is set to not configured.

    http://support.microsoft.com/kb/303070 - This is about adding it back to the Classic menu. does not help in this situation.

    I did look at this:
    Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy
    Expand the Local Policies and click "User Rights Assignment"
    Shut Down The System is applied to all user groups.

    Also under the Security Options - Shutdown allowed w/o having to log on is also enabled.


    I also tried adding - [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer]
    "NoClose"=dword:00000000


    JoeP, sorry that did not work either.

    I think for now I will create 2 desktop shortcuts, one to Shutdown & one for Restart as that option is also missing until I (or someone else!) can figure out what needs to be changed as the logging out & then shutdown is getting old.

    Update: When I try & use the shutdown.exe command I am now getting the message "A required privilege is not held by the client."
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  10. #10
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So far, still no luck.
    http://support.microsoft.com/kb/555449 - This is to edit the setting in gpedit.msc - User Configuration\Administrative Templates\Start Menu and Taskbar This is set to not configured.

    http://support.microsoft.com/kb/303070 - This is about adding it back to the Classic menu. does not help in this situation.

    I did look at this:
    Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy
    Expand the Local Policies and click "User Rights Assignment"
    Shut Down The System is applied to all user groups.

    Also under the Security Options - Shutdown allowed w/o having to log on is also enabled.


    I also tried adding - [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer]
    "NoClose"=dword:00000000


    JoeP, sorry that did not work either.

    I think for now I will create 2 desktop shortcuts, one to Shutdown & one for Restart as that option is also missing until I (or someone else!) can figure out what needs to be changed as the logging out & then shutdown is getting old.

    Update: When I try & use the shutdown.exe command I am now getting the message "A required privilege is not held by the client."
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  11. #11
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So far, still no luck.
    http://support.microsoft.com/kb/555449 - This is to edit the setting in gpedit.msc - User Configuration\Administrative Templates\Start Menu and Taskbar This is set to not configured.

    http://support.microsoft.com/kb/303070 - This is about adding it back to the Classic menu. does not help in this situation.

    I did look at this:
    Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy
    Expand the Local Policies and click "User Rights Assignment"
    Shut Down The System is applied to all user groups.

    Also under the Security Options - Shutdown allowed w/o having to log on is also enabled.


    I also tried adding - [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer]
    "NoClose"=dword:00000000


    JoeP, sorry that did not work either.

    I think for now I will create 2 desktop shortcuts, one to Shutdown & one for Restart as that option is also missing until I (or someone else!) can figure out what needs to be changed as the logging out & then shutdown is getting old.

    Update: When I try & use the shutdown.exe command I am now getting the message "A required privilege is not held by the client."
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  12. #12
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So far, still no luck.
    http://support.microsoft.com/kb/555449 - This is to edit the setting in gpedit.msc - User Configuration\Administrative Templates\Start Menu and Taskbar This is set to not configured.

    http://support.microsoft.com/kb/303070 - This is about adding it back to the Classic menu. does not help in this situation.

    I did look at this:
    Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy
    Expand the Local Policies and click "User Rights Assignment"
    Shut Down The System is applied to all user groups.

    Also under the Security Options - Shutdown allowed w/o having to log on is also enabled.


    I also tried adding - [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer]
    "NoClose"=dword:00000000


    JoeP, sorry that did not work either.

    I think for now I will create 2 desktop shortcuts, one to Shutdown & one for Restart as that option is also missing until I (or someone else!) can figure out what needs to be changed as the logging out & then shutdown is getting old.

    Update: When I try & use the shutdown.exe command I am now getting the message "A required privilege is not held by the client."
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  13. #13
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So far, still no luck.
    http://support.microsoft.com/kb/555449 - This is to edit the setting in gpedit.msc - User Configuration\Administrative Templates\Start Menu and Taskbar This is set to not configured.

    http://support.microsoft.com/kb/303070 - This is about adding it back to the Classic menu. does not help in this situation.

    I did look at this:
    Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy
    Expand the Local Policies and click "User Rights Assignment"
    Shut Down The System is applied to all user groups.

    Also under the Security Options - Shutdown allowed w/o having to log on is also enabled.


    I also tried adding - [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer]
    "NoClose"=dword:00000000


    JoeP, sorry that did not work either.

    I think for now I will create 2 desktop shortcuts, one to Shutdown & one for Restart as that option is also missing until I (or someone else!) can figure out what needs to be changed as the logging out & then shutdown is getting old.

    Update: When I try & use the shutdown.exe command I am now getting the message "A required privilege is not held by the client."
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  14. #14
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    So far, still no luck.
    http://support.microsoft.com/kb/555449 - This is to edit the setting in gpedit.msc - User Configuration\Administrative Templates\Start Menu and Taskbar This is set to not configured.

    http://support.microsoft.com/kb/303070 - This is about adding it back to the Classic menu. does not help in this situation.

    I did look at this:
    Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy
    Expand the Local Policies and click "User Rights Assignment"
    Shut Down The System is applied to all user groups.

    Also under the Security Options - Shutdown allowed w/o having to log on is also enabled.


    I also tried adding - [HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer]
    "NoClose"=dword:00000000


    JoeP, sorry that did not work either.

    I think for now I will create 2 desktop shortcuts, one to Shutdown & one for Restart as that option is also missing until I (or someone else!) can figure out what needs to be changed as the logging out & then shutdown is getting old.

    Update: When I try & use the shutdown.exe command I am now getting the message "A required privilege is not held by the client."
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

  15. #15
    Star Lounger
    Join Date
    Oct 2003
    Location
    Colorado, USA
    Posts
    55
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I should also add that when I run:
    gpedit.msc

    Then Go to
    Computer Configuration\Windows Settings\Security Settings
    \Local Policies\User Rights Assignment\

    Double click on "Shut down the system"

    It is listing the groups as the *S-1-.... Also the buttons for ADD USER or GROUP and Remove are also disabled. It does not matter what admin account I am logged in, bit it local or connected to the domain.
    When comparing this woth some other groups, it does appear that the Admin & other groups may have gotten removed?

    Not to bood in safe mode & see what happens, yeach!
    Stealing from one is call plagiarism, stealing from many is called research. ;-)~

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •