Results 1 to 4 of 4
  1. #1
    4 Star Lounger
    Join Date
    May 2003
    Location
    Sterling Heights, Michigan, USA
    Posts
    553
    Thanks
    0
    Thanked 0 Times in 0 Posts
    When I first tried to install SP2, it failed with an error code 8007371C. I found a posting on MS Technet about using the System Update Readiness Tool and the full standalone package of SP2 after that. Followed the posting exactly, but even after that the installation failed saying "The SMI primitive installer failed during setup or servicing." This is a Sony laptop, running Vista Home Premium 32-bit.

    No one on Technet has come forward with any suggestions. Help!

  2. Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,554
    Thanks
    2
    Thanked 614 Times in 550 Posts
    Quote Originally Posted by JJDetroit View Post
    When I first tried to install SP2, it failed with an error code 8007371C. I found a posting on MS Technet about using the System Update Readiness Tool and the full standalone package of SP2 after that. Followed the posting exactly, but even after that the installation failed saying "The SMI primitive installer failed during setup or servicing." This is a Sony laptop, running Vista Home Premium 32-bit.

    No one on Technet has come forward with any suggestions. Help!
    Can you post the Technet link? We don't want to ask the same questions or propose the same steps as Technet.

    Also, you can get free installation support for Vista SP-2 until Feb. 26, 2010 from Microsoft. See Help and Support.

    Joe

  4. #3
    Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, California, USA
    Posts
    96
    Thanks
    0
    Thanked 2 Times in 2 Posts
    If all else fails JJDetroit, re-install Vista. You may have a corrupted installation of Vista and it needs to be repaired by re-installing Vista on top of Vista:

    read here:
    http://social.answers.microsoft.com/...b-acf88d70e4f3

    after re-installing Vista with the Vista CD that came with your Sony laptop, install full SP1 pack then install full SP2 pack. done.

  5. #4
    4 Star Lounger
    Join Date
    May 2003
    Location
    Sterling Heights, Michigan, USA
    Posts
    553
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Noel R. Piring View Post
    If all else fails JJDetroit, re-install Vista. You may have a corrupted installation of Vista and it needs to be repaired by re-installing Vista on top of Vista:

    read here:
    http://social.answers.microsoft.com/...b-acf88d70e4f3

    after re-installing Vista with the Vista CD that came with your Sony laptop, install full SP1 pack then install full SP2 pack. done.
    Microsoft provided me with a Vista CD which had SP2 included, and that let me do a Repair Install.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •