Results 1 to 9 of 9
  1. #1
    5 Star Lounger
    Join Date
    Jan 2001
    Posts
    1,119
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I just got a new computer. I created a Personal.xls and loaded all my macros. Something happened and I lost everything. I rebooted but everything is still gone. I tried to recreate my Personal.xls but when I do, I get - Personal macro workbook in the startup folder must stay open for recording. I hit OK and get - Unable to record. What should I do??

    How do I get to the Start Up folder? I am lost. Maybe I should have them reload Excel but I think there must be any easier way to correct this

  2. #2
    5 Star Lounger AndrewKKWalker's Avatar
    Join Date
    Apr 2001
    Location
    Cambridge, UK
    Posts
    1,020
    Thanks
    0
    Thanked 3 Times in 3 Posts
    There is more than one place where this might go.
    Also the default location depends upon


    Operating system and also version of Office

    What OS and Office version are you using?
    Andrew

  3. #3
    5 Star Lounger
    Join Date
    Jan 2001
    Posts
    1,119
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Windows XP Pro - Service pack II

  4. #4
    5 Star Lounger AndrewKKWalker's Avatar
    Join Date
    Apr 2001
    Location
    Cambridge, UK
    Posts
    1,020
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Not sure what the problem is, but below are places that you might look.

    The Standard Place for Personal.xls if you record something into it on XP is most likely

    C:\Documents and Settings\LogOnName\Application Data\Microsoft\Excel\XLSTART


    LogOnName is Your Logon.


    If you have NO logon it might be admin or maybe not there at all.


    The Other Place it could be is in the XLSTART folder where Office is installed

    This varies with Version of Office

    C:\Program Files\Microsoft Office\OFFICE11\XLSTART


    So Office

    2003 is OFFICE11
    2007 is OFFICE12

    At least it will give you somewhere to start looking.
    Andrew

  5. #5
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts
    Linda, I edited the title of your post to be more specific, as the "thread description" does not show in the Forum thread listing view.
    -John ... I float in liquid gardens
    UTC -7ąDS

  6. #6
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts
    Quote Originally Posted by LindaR View Post
    Windows XP Pro - Service pack II
    You didn't mention which Office version. When you press Alt-F11, on the left side of the VBE "project explorer", do you see personal.xls listed? (If you don't see a project explorer toggle it on with Ctrl-R.)
    -John ... I float in liquid gardens
    UTC -7ąDS

  7. #7
    5 Star Lounger
    Join Date
    Jan 2001
    Posts
    1,119
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I found where the start is and deleted the Personal.xls. I created it again but now when I open Excel my macros are gone. I have to open the Personal.xls workbook in the start folder and then my macros show. It doesn't open automatically. I have to open it manually first.

  8. #8
    Bronze Lounger
    Join Date
    Sep 2007
    Posts
    1,203
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Personal.xls should always remain open, but it is normally hidden from view. You should select the sheet, then FORMAT | SHEET | HIDE.

    When you close (Save changes to Personal.xls [being the hidden view]) and re-open excel, your macro's should then be available.

    Regards
    Nathan

  9. #9
    5 Star Lounger
    Join Date
    Jan 2001
    Posts
    1,119
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I looked on Google and found the answer - under Help, About MS Excel there is a buttom called "Disabled Items". I checked under there and I checked enable and I am now back in business.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •