Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Location
    East Hanover, New Jersey, USA
    Posts
    83
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thanks to Woody's article on networking Windows 7 and XP computers, I've been able to get my new Windows 7 (64-bit) laptop to network well with three Windows XP machines. File & printer sharing works fine as well.

    The reason I have a new Windows 7 laptop is to replace an old Windows XP laptop. I'm in the process of migrating applications and files to the new laptop.

    When I took both laptops to our weekend home, they suddenly don't see each other. They can connect to the web just fine; they're just invisible to each other.

    I've tried to make both locations as much the same: the wireless routers have the same WEP code. All computers are in a workgroup named HOME. The only difference between the two locations is the physical router.

    When I returned home and plugged the two laptops in, everything went back to normal - file & printer sharing works great. Now I'm back at my weekend home and the computers (once again) don't see each other.

    What else is there that could be making this difference?

    The Default Gateway is different between the two locations could that be the culprit? At one location it's 192.168.1.1 and at the other location it's 1982.168.0.1. Both laptops get their IP address automatically through DHCP.
    Bill Treloar
    Rank Magic Blog

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts
    When you connected to the router with the Windows 7 machine at the weekend place, did you declare it as a Private or Public connection?

    If Public, then all other machines are blocked.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  3. #3
    Star Lounger
    Join Date
    Dec 2009
    Location
    East Hanover, New Jersey, USA
    Posts
    83
    Thanks
    0
    Thanked 1 Time in 1 Post
    I didn't declare it as anything, AFAIK. Let me check .....

    Here's what's turned on:
    • network discovery
      file & printer sharing
      public folder sharing
      128 bit encryption for file sharing connections (I'll change that to 40/56 bit encryption now


    Password protected sharing is OFF.
    Homegroup connections uses user accounts, not Windows management (but since Homegroups only apply to Windows 7 to Windows 7 connections, I presume that's not an issue for me now.

    Still no connection to my old XP laptop. And on the old laptop, it finds nothing in the Home group but itself ... neither the new Windows 7 laptop nor my wife's XP laptop, which I was able to see earlier today before I changed the router's gateway IP address.
    Bill Treloar
    Rank Magic Blog

  4. #4
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Bill, the list of what's turned on, such as network discovery, are your Win 7 laptop settings, not router settings. I am assuming your router at your weekend place has a unique SSID that should have popped up asking for your WEP key when you powered up your laptops. If you did not see any notification, then maybe your router is not set for broadcasting.

    If your router is not broadcasting you will still be able to go on the internet but each machine may not detect the other. If broadcasting is disabled on your router, enable it to see if that makes the difference. If both your computers can see each other, then it would be a good idea to discard WEP and use WPA-PSK [TKIP] or WPA2-PSK [AES] if your router supports them. WEP is not safe to use if your router is broadcasting.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  5. #5
    Star Lounger
    Join Date
    Dec 2009
    Location
    East Hanover, New Jersey, USA
    Posts
    83
    Thanks
    0
    Thanked 1 Time in 1 Post
    When I first brought the new laptop to our weekend place, I did have to enter the WEP code. And while making changes today (I changed the IP Address of the router to match that of my home router) the workgroup got changed form HOME to WORKGROUP, and I had to change it back. At one point (very briefly) I was able to see the files on the old laptop's C drive. Sadly, the next time I looked, it was unavailable again, and I haven't been able to get it back. And of course, I can't replicate whatever it was that alloowed that temporary connection.
    Bill Treloar
    Rank Magic Blog

  6. #6
    Silver Lounger t8ntlikly's Avatar
    Join Date
    Dec 2001
    Location
    Chandler, AZ
    Posts
    2,162
    Thanks
    46
    Thanked 13 Times in 11 Posts
    Looks to me like you're just going to have to give up your weekend home
    Thanks John
    Teamwork is essential; it gives the enemy other people to shoot at. (Murphy's War Laws #39)

  7. #7
    Star Lounger
    Join Date
    Dec 2009
    Location
    East Hanover, New Jersey, USA
    Posts
    83
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Gerald View Post
    If your router is not broadcasting you will still be able to go on the internet but each machine may not detect the other. If broadcasting is disabled on your router, enable it to see if that makes the difference. If both your computers can see each other, then it would be a good idea to discard WEP and use WPA-PSK [TKIP] or WPA2-PSK [AES] if your router supports them. WEP is not safe to use if your router is broadcasting.
    Thanks!

    We're pretty isolated at our weekend house ... but I can check if my router can do WPA ... I set it to WEP because my old wireless access point at home doesn't do WPA, and I wanted both locations to be as similar as possible to reduce the chance of problems like I'm having now.

    Yes, my router supports WPA-PSK .. but first let me see if I can figure out if it's broadcasting, though I'm not sure I understand what that means ... how could it not?

    OK, I loked, but didn't find anything in router settings that says "broadcast" ... what should I be looking for?
    Bill Treloar
    Rank Magic Blog

  8. #8
    Star Lounger
    Join Date
    Dec 2009
    Location
    East Hanover, New Jersey, USA
    Posts
    83
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by t8ntlikly View Post
    Looks to me like you're just going to have to give up your weekend home
    Ouch!
    Bill Treloar
    Rank Magic Blog

  9. #9
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Quote Originally Posted by Bill Treloar View Post
    Thanks!

    We're pretty isolated at our weekend house ... but I can check if my router can do WPA ... I set it to WEP because my old wireless access point at home doesn't do WPA, and I wanted both locations to be as similar as possible to reduce the chance of problems like I'm having now.

    Yes, my router supports WPA-PSK .. but first let me see if I can figure out if it's broadcasting, though I'm not sure I understand what that means ... how could it not?

    OK, I loked, but didn't find anything in router settings that says "broadcast" ... what should I be looking for?
    I have a Linksys WRT54G router, and when I enter the router's IP number and enter my password to access the router home page, I click on the Wireless section and there is an option to enable or disable 'Wireless SSID Broadcast'. Whatever brand of router you have should provide you a similar option in the wireless section. When wireless broadcasting is enabled, anyone within range can "see" your wireless network, but if you have your router home page password protected and use one of the forms of WPA you are safe from compromise.
    Hope this helps.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  10. #10
    Star Lounger
    Join Date
    Dec 2009
    Location
    East Hanover, New Jersey, USA
    Posts
    83
    Thanks
    0
    Thanked 1 Time in 1 Post
    I found it, and SSID broadcast IS enabled. Skipping the issue of WEP/WPA for the moment, does this help figure out why my laptops can't see each other?
    Bill Treloar
    Rank Magic Blog

  11. #11
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Did you find it already enabled or did you find it disabled and have now enabled it? If you have just enabled it, can your computers see each other now?

    If broadcasting has been functional all along, then there is some other cause keeping your computers blind to one another. If this is the case, I would change to a new workgroup name such as 'WeekendHome' on both computers while in your weekend home, then create a new wireless home network specifying a new SSID and WPA key, and as DaveA said earlier, it must be declared a private (Home or Work) network rather than public or your machines will not be able to see each other. If nothing else, you will know for sure your network is private, and other possibilities can then be explored.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  12. #12
    Star Lounger
    Join Date
    Dec 2009
    Location
    East Hanover, New Jersey, USA
    Posts
    83
    Thanks
    0
    Thanked 1 Time in 1 Post
    Hi, Gerald,

    I found the SSID broadcast already enabled.

    We're heading back home shortly, so the changes you recommend will have to wait until next weekend. But could you help me better understand some of what you're recommending?

    Creating a "new" home network ...

    How do I change the SSID?

    On the router?How do I make sure the network is set to Private? Or are you referring to telling Windows 7 it's a Home network, not a work or public one? I'm not sure what the XP equivalent of that would be.....

    Thanks!
    Bill
    Bill Treloar
    Rank Magic Blog

  13. #13
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    First, give this a shot. If your router stays powered up all the time, shut it down, wait a few minutes and power it back up again. This will force it to refresh. Then check if your computers see each other.

    Make sure Windows 7 is set up as a Home network rather than a public one. Network discovery is disabled by default in the Public Network profile. The SSID is found on the router setup page. It will not be necessary for you to change your workgroup name on your computers but it would not hurt to change the SSID so you can have a unique network identifier in your weekend home. When you confirm your setup on the Home network profile, click on the ‘Change advanced sharing settings’ on the left side of the panel. If you do not see ‘Turn on network discovery’ selected, then select it. Do the same for File and Printer sharing and the Public folder sharing.

    When you power up your Windows 7 laptop it will advise you it cannot connect. Just click on the tray icon and select the new SSID you setup, enter your passphrase (key) when prompted and you should connect. Windows XP will do the same. If there are no problems, both computers should see each other on the network.

    If your laptops still cannot see each other, then 1) if you are using Windows Firewall on your computers then disable it temporarily to find out if the computers can be seen on the network. It is possible there is a conflict between this router and Windows Firewall. 2) check your router documentation for instructions on checking the status of the file and printer sharing ports on the router.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  14. #14
    Star Lounger
    Join Date
    Dec 2009
    Location
    East Hanover, New Jersey, USA
    Posts
    83
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thanks, Gerald,

    I'll have to wait on this until Thursday to try it out. I'm at home now, and my new laptop easily sees all six other computers on the LAN. That's WITH the Norton 360 Smart Firewall turned ON. I'm not using the Windows firewall, so I think this rules out the firewall as the culprit.

    Bill
    Bill Treloar
    Rank Magic Blog

  15. #15
    Star Lounger
    Join Date
    Dec 2009
    Location
    East Hanover, New Jersey, USA
    Posts
    83
    Thanks
    0
    Thanked 1 Time in 1 Post
    First, give this a shot. If your router stays powered up all the time, shut it down, wait a few minutes and power it back up again. This will force it to refresh. Then check if your computers see each other.

    No change

    Make sure Windows 7 is set up as a Home network rather than a public one. Network discovery is disabled by default in the Public Network profile.

    Already set up that way


    The SSID is found on the router setup page. It will not be necessary for you to change your workgroup name on your computers but it would not hurt to change the SSID so you can have a unique network identifier in your weekend home.

    It is different: treloar-wireless at home and Pond Home for the weekend.

    When you confirm your setup on the Home network profile, click on the ‘Change advanced sharing settings’ on the left side of the panel. If you do not see ‘Turn on network discovery’ selected, then select it. Do the same for File and Printer sharing and the Public folder sharing.

    Already set up that way.

    When you power up your Windows 7 laptop it will advise you it cannot connect. Just click on the tray icon and select the new SSID you setup, enter your passphrase (key) when prompted and you should connect. Windows XP will do the same. If there are no problems, both computers should see each other on the network.

    Windows 7 laptop connects fine, but tells me it :Could not reconnect all network drives" and the only drives it sees are its own.


    If your laptops still cannot see each other, then 1) if you are using Windows Firewall on your computers then disable it temporarily to find out if the computers can be seen on the network. It is possible there is a conflict between this router and Windows Firewall.

    Windows Firewall - It tells me "These settings are being managed by vendor application NORTON FIREWALL PROVIDER. Under advanced security settings, it says Windows Firewall is ON, I elected to turn the firewall OFF for Domain Profile, Private Profile, and Public Profile.

    Trying to check my other laptop across the network reported "An error occurred while reconnecting L: to \\Tal\tal c (c) - Microsoft Windows Network: the network path was not found. This connection has not been restored."

    FWIW, trying to check my wife's laptop from my old XP laptop (which I sometimes can on weekends) says it's not accessible and I may not have permission to view it. Looking at the Home workgroup shows only my old laptop and nothing else.


    2) check your router documentation for instructions on checking the status of the file and printer sharing ports on the router.

    Port forwarding is on
    DHCP is on.
    LAN Port displays proper IP address, IP Subnet Mask, and MAC address


    Anything else I can do?
    Bill Treloar
    Rank Magic Blog

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •