Results 1 to 6 of 6
  1. #1
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    Specifically, when I press Ctrl+A to highlight the entire Word 2007 doc, then choose Review>Set Language>Language, I see a blue highlight mark in Do not check spelling or grammar. I unselect this so the box is blank, and uncheck Detect language automatically, then OK. (I don't want Word to skip any of the document for spell checking). Problem is, when I press Ctrl+A again and retrace these steps, the blue highlighting is back in the Do not check spelling or grammar setting. Grrr. I have toggled off and on the Detect langauge automatically setting in the hopes that this would allow the spelling grammar check setting to stick. No luck.

    This is pretty important, as I need to force Word to check the entire document. Anyone got any advice? Thanks.

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    I'm unable to reproduce the behavior you're reporting in Word 2007. If I set a portion of the document content to "Do not check spelling or grammar' and then select all and return to the Language dialog, there is a green (not blue) highlight next to that checkbox (indicating a mixed condition within the selection), but I then click twice (to set that setting to unchecked), then that setting 'sticks' next time I select all and reopen the dialog.

    It sounds like there's something else going in your document, to make that setting revert - could you attach a copy of the document (with any confidential information removed) so we can take a look?

    Gary

  3. #3
    Star Lounger
    Join Date
    May 2007
    Location
    Gloucester, Gloucestershire
    Posts
    60
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I've only tried this in Word 2003 but can produce a similar problem if there is a style in the attached template with "Do not check spelling or grammar" switched on, and "Automatically update document styles" is switched on. With the latter setting, the styles always revert to their definition in the attached template. Could this be the problem?

    Anne

  4. #4
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    Very good guess, Anne. I will check the settings for the styles to see if this is occurring. Gary, to be clear- I am selecting the entire document through Ctrl+A, not simply a portion of it.

  5. #5
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    Hmmm...I removed all unnecessary Heading Styles from a document, verified that the Do not check spelling or grammar box was not checked or highlighted in the remaining Styles, and verified that Word Options>Proofing>Grammar and Style was configured correctly, but still encounter the blue highlighting in it when I select the entire contents of the document (both via Ctrl+A and by just dragging and highlighting the document contents). Sure enough, I misspelled some words in the document and Word is not flagging them with red underlining. This is not good, and I need to enforce the proofreading capabilities in Word.

  6. #6
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    Quote Originally Posted by ben000 View Post
    Hmmm...I removed all unnecessary Heading Styles from a document, verified that the Do not check spelling or grammar box was not checked or highlighted in the remaining Styles, and verified that Word Options>Proofing>Grammar and Style was configured correctly, but still encounter the blue highlighting in it when I select the entire contents of the document (both via Ctrl+A and by just dragging and highlighting the document contents). Sure enough, I misspelled some words in the document and Word is not flagging them with red underlining. This is not good, and I need to enforce the proofreading capabilities in Word.
    Just to be sure, it is possble to set all the styles so that the 'Do not check spelling or grammar' setting is cleared, and yet still have some document content set to 'Do not check spelling or grammar', since that can also be applied to specific content as direct formatting, overriding what the style was set to do.

    Selecting the entire document and clearing the check boxes should work, but for some reason isn't in your document - which is why I suggested attaching a (cleaned up) copy so we may try to track down what condition in the document is preventing this setting from clearing.

    The following might be worth a try - it visits each paragraph in the document, and clears that setting for the entire paragraph.

    Code:
    Sub EnforceSpellSettings()
       Dim aPara As Paragraph
       For Each aPara In ActiveDocument.Paragraphs
          aPara.Range.NoProofing = False
       Next 'aPara
    End Sub
    Gary

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •