Results 1 to 14 of 14
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Location
    North Yorkshire
    Posts
    54
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I set File and Printer Sharing for Microsoft Networks to ON in my LAN adapter properties. When I reboot it has turned itself off.

    My PC runs Windows 7 64bit.
    With File & Printer Sharing on, I am able to access folders on another Windows 7 32bit PC and that PC can access mine. After a reboot of my PC, neither is possible - file & printer sharing has turned itself off in the adapter properties.
    In Control panel / Advanced Sharing Settings I also have the file and printer sharing option specified - and that stays on across a reboot. But it appears it is not sufficient to allow these two PCs to see each other.

    When I turn File & Printer sharing back on in the adapter properties, both PCs can then see each other (no reboot necessary).

    On the other PC, file & printer sharing survives across a reboot without being reset.

    I withdrew both PCs from our homegroup last night in an attempt to narrow down where the problem lies.
    My PC is using the standard Windows firewall t present.

    This is one aspect of various strange problems I have been "enjoying" with Windows 7 networking which I have mentioned in other threads Following suggestions in those threads I have turned off jiumbo packets and have created an identical logon id on both systems. The Intel web site confirms I have the up-to-date Intel network card driver.

    This is very strange. Any suggestions will be much appreciated.

  2. #2
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Have you tried to go through the the Control Panel, Network and Internet, Network and Sharing Center, Change advanced sharing settings????

    You can type sharing in the search box, or right click on you taskbar internet status icon and choose Open Network and Sharing Center. The problem may lie in the advanced settings. I have enabled home groups and have all 3 PC's (desktop and 2 laptops) set up in the same home group with very good results.

    oops, sorry I just reread your posting and see you have already been here!!
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  3. #3
    Star Lounger
    Join Date
    Dec 2009
    Location
    North Yorkshire
    Posts
    54
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Thanks, Ted. If possible, what might help would be to know what kinds of system functions turn File 7 printer sharing off - and in what circumstances.

    I see my post has been moved from the Windows 7 forum to Networking. Fair enough from one point of view, but I posted originally in Win 7 forum because I wonder if there is some subtlety in Win 7 that is affecting this. I don't recall seeing this"spontaneous switch off" in Vista.

  4. #4
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Quote Originally Posted by David Hutton-Squire View Post
    ...I wonder if there is some subtlety in Win 7 that is affecting this. I don't recall seeing this"spontaneous switch off" in Vista.
    Have you configured your home network as a Private Network, or does Windows think this is a Public Network?

  5. #5
    Star Lounger
    Join Date
    Dec 2009
    Location
    North Yorkshire
    Posts
    54
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by StuartR View Post
    Have you configured your home network as a Private Network, or does Windows think this is a Public Network?
    Thanks for the reply. Yes, it is definitely a Home network.

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Quote Originally Posted by David Hutton-Squire View Post
    Thanks for the reply. Yes, it is definitely a Home network.
    I don't recall a setting of "Home", just "Public" or "Private".

  7. #7
    Star Lounger
    Join Date
    Dec 2009
    Location
    North Yorkshire
    Posts
    54
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by StuartR View Post
    I don't recall a setting of "Home", just "Public" or "Private".
    On Windows 7 Control panel / Network & Sharing Centre the choices offered are: Home, Work or Public. My network is set to Home.

  8. #8
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Quote Originally Posted by David Hutton-Squire View Post
    On Windows 7 Control panel / Network & Sharing Centre the choices offered are: Home, Work or Public. My network is set to Home.
    My error, that's what happens when relying on memory instead of going to look.

  9. #9
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Two things just to ckeck that I have found sometimes upset the proverbial apple cart. In the network adapter properties is the TCP/IPv6 protocol enabled and active? There seems to be some dependancies now on IPv6 even though the protocol isn't employed in most cases (as far as I know). Also, are you using a router and letting the local IP be assigned or are you specifying the local IP? Try specifying your own IP address if not already doing so.

    I think if you take a system out of homegroup status, public network is specified instead of private. That's the way it worked on my system at least.

    The only other thing I can think of is intentional altering either by antivirus/firewall/network configuration software or by malware.

  10. #10
    Star Lounger
    Join Date
    Dec 2009
    Location
    North Yorkshire
    Posts
    54
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I thought I had posted a reply but it has disappeared......

    Thanks Byron,
    TCP/ip v6 was active; it was required for the Homegroup that i disabled last night.

    But the train of thought and investigation initiated by your post led me remember that this Thinkpad comes with Lenovo's access Connections software. Buried deep in the settings of that is a "security2 option to turn off file and Printer Sharing. It was set to do that. I have changed that and will do a reboot later this evening.

    So thanks for starting me down the line of thought that led me to think about Access Connections - it was also resetting the ip address allocation to automatic. I will leave that for the moment to see how things now function.

  11. #11
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    828
    Thanks
    4
    Thanked 38 Times in 34 Posts
    Do you have Windows Live installed? I ran into an issue with sharing things because Live was installed. Once I removed Live, sharing worked again without any problems.

  12. #12
    Star Lounger
    Join Date
    Dec 2009
    Location
    North Yorkshire
    Posts
    54
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Peter Johnson2191 View Post
    Do you have Windows Live installed?
    Yes, some Windows Live components are installed. But we don't have problems with sharing now, after I rectified what Lenovo's Access Connections was doing in turning off file & printer sharing..
    I do still have a problem on my 64 bit system with a printer attached to a NAS box; curiously it works on the 32 bit system. That is the subject of another thread.
    Thanks.

  13. #13
    New Lounger
    Join Date
    Jun 2012
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Davidhs View Post
    ....after I rectified what Lenovo's Access Connections was doing in turning off file & printer sharing...
    Old thread yes BUT important information - thank you for pointing Lenovo's Access Connections! Damn software turned on all of these things itself after new WLAN profile created:
    - Disable File and Printer sharing
    - Disable internet connection sharing
    - Enable Windows Firewall

    o__O

    Need to edit a profile --> Additional settings --> tick off Network security

  14. #14
    4 Star Lounger
    Join Date
    May 2012
    Posts
    404
    Thanks
    0
    Thanked 49 Times in 39 Posts
    I suggest the following steps.

    1. Click Start and in the Search field, type (or copy/paste from here) devmgmt.msc
    2. Click the link which appears to take you to Device Manager.
    3. Expand "Network Adapters"
    4. Right click your network adapter and go to "Properties".
    5. Click the "Power Management" tab and then remove the checkmark from: "Allow computer to turn off this device to save power".
    6. Click Apply/OK.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •