Results 1 to 14 of 14
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    15
    Thanks
    0
    Thanked 2 Times in 1 Post
    Does anyone know how to turn IE8 Inprivate Filtering on by default

    Additionally does anyone have an explanation as to why Microsoft didnt make this a default option in the first place.

    Thanks

    Simon

  2. #2
    Gold Lounger Rebel's Avatar
    Join Date
    Jul 2001
    Location
    Canada
    Posts
    3,024
    Thanks
    0
    Thanked 1 Time in 1 Post
    "Does anyone know how to turn IE8 Inprivate Filtering on by default"

    From IE's Help contents:

    "To turn on InPrivate Filtering for the first time, follow these steps:
    Click to open Internet Explorer.
    Click the Safety button, click InPrivate Filtering, and then do one of the following:
    Click Block for me to block websites automatically.
    Click Let me choose which providers receive my information to choose content to block or allow. When you're finished, click OK.

    If you've already turned on InPrivate Filtering, follow these steps:
    Click to open Internet Explorer.
    Click the Safety button, and then click InPrivate Filtering Settings.
    Do one of the following:
    To automatically block websites, click Automatically block.
    To manually block websites, click Choose content to block or allow.
    To turn off InPrivate Filtering, click Off.
    Click OK."

    "Additionally does anyone have an explanation as to why Microsoft didnt make this a default option in the first place."
    This is a personal option. Some users want filtering in place - others don't. MS is simply giving you a choice.
    John
    A Child's Mind, Once Stretched by Imagination...
    Never Regains Its Original Dimensions

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    15
    Thanks
    0
    Thanked 2 Times in 1 Post
    Thanks Rebel,

    Your instructions are very clear but I dont think I made it clear what I want to do.

    I can turn Inprivate Filtering on but it only works for that browser session.
    Closing IE8 turns of the Inprivate Filtering and it has to be turned on again for every new browser session.

    I know the filtering isnt perfect but I would like to use it as an extra layer of security each time I use IE8.

    I know I can turn it on each time I start a new browser session and have been doing so with Ctrl+Shift+F although sometimes I forget to do so and both my wife and my daughter just cant be bothered with stuff like that.
    It would be better if I could have Inprivate Filtering turned on by default so that it is automatically turned on each time IE8 is opened

    I have tried this on 4 different computers a Sony Vaio, IBM THinkpad, HP G70, and Dell Inspiron, Running 3 different OS's, XP Pro, Vista Home Premium and Win7Ultimate. All have the latest software updates and its the same on all of them. Inprivate Filtering wont stay turned on.

    I understand that microsoft have given us all a choice to use Inprivate Filtering but it seems odd that once we make that choice it isnt remembered like other user settings are.

    Maybe Microsoft will correct this with an update.

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,583
    Thanks
    5
    Thanked 1,058 Times in 927 Posts
    Quote Originally Posted by Simon Hayward View Post
    I understand that microsoft have given us all a choice to use Inprivate Filtering but it seems odd that once we make that choice it isnt remembered like other user settings are.
    See Command line arguments in Internet Explorer 8 | The Windows Club.

    Joe
    Joe

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    15
    Thanks
    0
    Thanked 2 Times in 1 Post
    Thanks Joe,

    I did it "C:\Program Files\Internet Explorer\iexplore.exe" –private

    It works a dream so much easier than all those registry hacks that Ive seen. Didnt want to mess with the registry.

    I will also make good use of the -k command for kiosk mode that I noticed on the link. One of my laptops is a 15 inch widescreen, or as I call them less tall screens, so not much window space for scrolling. The kiosk mode will come in handy to automatically give more space for scrolling.

    Thanks

    Simon

  6. #6
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,583
    Thanks
    5
    Thanked 1,058 Times in 927 Posts
    Quote Originally Posted by Simon Hayward View Post
    I will also make good use of the -k command for kiosk mode that I noticed on the link. One of my laptops is a 15 inch widescreen, or as I call them less tall screens, so not much window space for scrolling. The kiosk mode will come in handy to automatically give more space for scrolling.
    You might want to get used to using F11 for full screen mode. You can start IE normally and have easy access to all the IE options. Just press F11 to enter full screen mode and then press again to leave full screen mode.

    Joe
    Joe

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    15
    Thanks
    0
    Thanked 2 Times in 1 Post
    Thanks for the F11 tip Joe

    However I just realised that the -private command is actually turning on in private browsing and not in private filtering.

    I would idealy like to have in private filtering turned on by default so that my favourite and trusted websites can use cookies to remember me for instance.

    The in private browsing seems to block everything.

    is there a comand to open IE8 with in private filtering already turned on

  8. #8
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,583
    Thanks
    5
    Thanked 1,058 Times in 927 Posts
    Quote Originally Posted by Simon Hayward View Post
    However I just realised that the -private command is actually turning on in private browsing and not in private filtering.

    I would idealy like to have in private filtering turned on by default so that my favourite and trusted websites can use cookies to remember me for instance.

    The in private browsing seems to block everything.

    is there a comand to open IE8 with in private filtering already turned on
    Sorry for the confusion on my part. By default IE is enabled to save cookies. Have you disabled that?

    Joe
    Joe

  9. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    15
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quote Originally Posted by JoeP View Post
    By default IE is enabled to save cookies. Have you disabled that?
    Thanks Joe.

    I just tried disabling cookies, but from my point of view that does exactly the same as In Private Browsing. ie it rejects all cookies and my favorite trusted sites dont remember me.

    What I like about the In Private Filtering is that it filters cookies, rather than indiscriminately blocking them all, it allows cookies from my trusted favourite sites but blocks others.

    This is such a great feature but having to manually turn it on for every new browser session means that half the time I will probably forget to use it.

    Simon.

  10. #10
    Silver Lounger t8ntlikly's Avatar
    Join Date
    Dec 2001
    Location
    Chandler, AZ
    Posts
    2,162
    Thanks
    46
    Thanked 13 Times in 11 Posts
    Just saw a video on this very subject over on CNET.com. I then went into the Internet Options and un checked the Disable Tool Bars and extensions. Only thing I don't like about this is that when I open a session in IE I get the standard you are now in private browsing page, and have to click on the home button to make my home page(s) come up. Oh well I guess that that is livable unless anyone knows a way around that too.
    Thanks John
    Teamwork is essential; it gives the enemy other people to shoot at. (Murphy's War Laws #39)

  11. #11
    Star Lounger
    Join Date
    Jan 2010
    Location
    San Diego, CA, USA
    Posts
    89
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The problem is ths: By the time you turn the filtering on, the tracking cookies from your homepage are already loaded! This is done by Microsoft to allow these privacy violators to make money when they really have no business doing so! I run a quick scan with my Security Suite directly turning on InPrivate Filtering and deny these people any information at all! The more I can do to destroy Internet advertisers, the better the Internet will be. Do your part, declare war on Internet advertisers who violate your privacy. Use InPrivate Filtering and scan and remove all tracking cookies from your system!

  12. #12
    Star Lounger
    Join Date
    Jan 2010
    Location
    San Diego, CA, USA
    Posts
    89
    Thanks
    0
    Thanked 0 Times in 0 Posts
    You did this command line? It wouldn't work at all for me. Some Windows bullhockey about it couldn't recognize the command. Yeah, Windows won't do anything to hurt the bottom line. Their "partners in crime" have to make money now regardless of ethics. "I'll scratch your back if you scratch mine!"
    Quote Originally Posted by Simon Hayward View Post
    Thanks Joe,

    I did it "C:\Program Files\Internet Explorer\iexplore.exe" –private

    It works a dream so much easier than all those registry hacks that Ive seen. Didnt want to mess with the registry.

    I will also make good use of the -k command for kiosk mode that I noticed on the link. One of my laptops is a 15 inch widescreen, or as I call them less tall screens, so not much window space for scrolling. The kiosk mode will come in handy to automatically give more space for scrolling.

    Thanks

    Simon

  13. #13
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by Allen Morse III View Post
    The problem is ths: By the time you turn the filtering on, the tracking cookies from your homepage are already loaded!
    Try using a blank home page.

  14. #14
    New Lounger
    Join Date
    Dec 2009
    Location
    UK
    Posts
    15
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quote Originally Posted by Allen Morse III View Post
    You did this command line? It wouldn't work at all for me. Some Windows bullhockey about it couldn't recognize the command. Yeah, Windows won't do anything to hurt the bottom line. Their "partners in crime" have to make money now regardless of ethics. "I'll scratch your back if you scratch mine!"
    If it didnt recognise the command then check that you are running the command prompt as an administrator. Right click on comand prompt and from the menu choose run as administrator.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •