Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Stoke Poges, Bucks, England
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Sleep mode on my PC seems to ignore on going CPU and I/O activity. For example, I started a long numerical calculation which writes data to a results file and went off for a coffee. On returning I found the system asleep and, after bringing it out of sleep mode, it was obvious that the calculation still had a long way to go.

    Has anyone encountered similar problems? Any thoughts on how to fix this? I'm using Widows 7 Home Premium (64-bit).

    AlexB

  2. #2
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    828
    Thanks
    4
    Thanked 38 Times in 34 Posts
    AFAIK, "idle" means no user input (mouse or keyboard event). So if your PC is "idle", it will go to sleep even if there is an app that is consuming a lot of CPU. I know that there are certain apps that turn "sleep-on-idle" off, such as Media Center or other multimedia apps. But most don't.

    I fix this by never letting my system go to sleep automatically - turn off the screens, yes, but sleep, no. I have a keyboard key that will put the thing to sleep if that's what I want.

    I imagine another fix would be to change the shortcut that starts your to a script that first turns the "sleep-on-idle" off, then runs your app, and then turns "sleep-on-idle" on after the app exist.

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Alex Balfour View Post
    Sleep mode on my PC seems to ignore on going CPU and I/O activity. For example, I started a long numerical calculation which writes data to a results file and went off for a coffee. On returning I found the system asleep and, after bringing it out of sleep mode, it was obvious that the calculation still had a long way to go.

    Has anyone encountered similar problems? Any thoughts on how to fix this? I'm using Widows 7 Home Premium (64-bit).
    Try this utility. While it's running, Windows will not put itself to sleep - but you can force Windows to sleep by issuing the relevant command.
    Insomnia

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    Stoke Poges, Bucks, England
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Peter & Paul,

    Thank you for your helpful responses. Insomnia is ideal for my needs.

    AlexB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •