Results 1 to 3 of 3
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    San Francisco, California, USA
    Posts
    358
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi All!

    I'm getting some very strange behavior in Access 2003 (SP3). I have a form with a single checkbox on it. Eventually, I want stuff to appear/disappear when the checkbox is clicked. (ie. not as in a set of options, but as in yes/no)

    The strange behavior is that I can't seem to write any code for the checkbox! When I go to the properties and try to build "on click" code, or even just right clicking on the checkbox and selecting Build, the VB editor goes crazy and then shows nothing! If I go to the form and go to the editor, the checkbox is not available in the dropdown box! (the listbox that I want to appear or disappear based on the click status of the listbox does appear in the dropdown)

    Any clues as to why the funky behavior? They recently re-imaged my computer, so maybe some sort of patch was forgotten? Or maybe there's something else I forgot to do? I can't seem to find anything useful searching the internets....

    :-/

    TIA!

  2. #2
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts
    The usual event to use for that would be the After Update. If that is not offered, that suggests some database corruption.

    This post has a list of some of the things you can try to deal with corruption.
    Regards
    John



  3. #3
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    San Francisco, California, USA
    Posts
    358
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank goodness! That was it! The db isn't that old, so not sure why, but at least I'm not going crazy...

    Thank you, Thank you, Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •