Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Arrow

    Hi all,

    This is minor but puzzling. I set the mouse buttons on my Lenovo ThinkPad T400 reversed since I mouse left-handed. Quite often (but not always) when I restart the laptop from Sleep mode they've reverted to standard, and I have to go back into the Control panel to reset them the way I want. What's puzzling is that the Control Panel still shows them as switched (R-L and L-R) when I get there. Unchecking the "Switch primary and secondary buttons" box resets the buttons physically to the way I use them, but the Control Panel dialog box then shows them as unswitched. This is minor but annoying, but mostly I get nervous when my operating system acts illogically. Any ideas? I'm signed in as an Administrator if that makes a difference.

    Thanks!

    Best

    Jon Inge

  2. #2
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Hi Jon, and welcome to the Lounge!

    A couple of suggestions. First, have you tried hybrid sleep? Hybrid sleep combines the features of sleep, but also saves everything in ram to the hard drive as well. Maybe this will help the mouse setup to be maintained upon awakening.

    Second, assuming Windows is currently supplying the driver for your mouse and you are using the Windows mouse control panel to set it, does your mouse manufacturer provide drivers and software for mouse configuration? If so, I would give those a try.

    Perhaps first install their driver to replace the generic windows driver, and if that does not solve the issue, try their configuration software as well.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Gerald,

    Thanks for the quick response. I haven't heard of "hybrid sleep", and it's not an option on my Shut Down menu. Where is it and where could I find it?

    I wondered about mouse drivers too, but this happens mostly when I'm traveling, and so am using the trackpoint joystick and mouse buttons on the ThinkPad. At home I use a Logitech trackball. I turned the touchpad off; I found I was constantly selecting things I didn't want by inadvertently touching the surface, and I find the joystick more usable and precise anyway.

    The ThinkPad exhibits this behavior whether I put it to sleep through the Shut Down menu or directly by closing the lid on the laptop. Sometimes it awakens in just the same state, sometimes with the mouse buttons reversed from when it went to sleep. I haven't noticed a pattern.

    It may just be that, in my experience, laptops can't always be relied upon to come out of sleep mode at all. I haven't had this one stay asleep and need more drastic measures to revive (as used to happen with the first ThinkPads) but it does occasionally fail to go to sleep properly and tell me that "Windows was shut down improperly" when I open it up again. It always comes back but then displays auto-recovery versions of any documents I had open when I closed the lid.

    As with many minor intermittent problems it's probably not fixable without a great deal of unwarranted effort, but as I said it does make me wonder about the stability of the OS.

    Best regards

    Jon

  4. #4
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Jon, you can adjust the power schemes by going to Control Panel | Power Options or by typing in the Start menu search box "power options" and clicking when it appears on the search results. You should find a Balanced, High performance and power saver plans on the screen. Choose the one you use on your ThinkPad and click on "Change plan settings". On the next screen click on "Change advanced power settings" expand the "Sleep" setting and you will see "Allow hybrid sleep." Expand that and change setting to "on" if it is not already enabled. Click "OK" and you are good to go. You can also explore the advance power options to see the things that can be customized to your taste. You can configure the start menu power button to sleep, hibernate, or shut down the laptop when you click it. There are other settings you can adjust to your liking as well.

    You are not alone on the touchpad sensitivity deal. Perhaps you can use the trackpad utility to adjust the sensitivity. I had to do that on mine, because I brushed it with my sleeve all the time.

    As far as drivers go, did your ThinkPad come with Windows 7 installed or did you upgrade to Windows 7? If it came installed, then you could check Lenovo's support site to see if new mouse and stick/touchpad drivers are available for your version of WIndows 7 (32 or 64 bit). If you upgraded to Windows 7 did you let Windows 7 provide generic drivers for the mouse & stick/touchpad, or did you download Lenovo's Windows 7 drivers? The drivers Windows supplies are not likely to be as good as the ones Lenovo would have. Also check Logitech for new drivers.

    From the symptoms you have described it would seem that you might need newer drivers and possibly the latest BIOS update from Lenovo as well. Check their site for recommended updates.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks, Gerald. I found the hybrid sleep setting and activated it, and I did find a couple of driver updates on the Lenovo site; my ThinkPad came with W7 pre-installed. Appreciate the advice!

    Best regards

    Jon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •