Results 1 to 7 of 7
  1. #1
    Star Lounger
    Join Date
    Oct 2002
    Posts
    53
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I've had a search and indexing problem that's been a bit more befuddling,
    I'm going to be as detailed as possible. I apologize in advance for the length,
    but I figure it's better to put everything in, in case any detail means something
    to someone.

    Here goes --

    When I do my searches, I get a message that says, "For faster searches
    turn indexing on." I click where it says to click to turn on indexing,
    but I keep getting the message. When I access the "Indexing Options"
    window, it says that "indexing is not running." The Modify command
    is grayed out. (I *can* click on the Advance button, though.) However, if
    I go to Windows Explorer, right-click on the C-drive and click on
    "Properties," the box is checked next to "Allow files on this drive to have
    contents indexed."

    I found one "help" response online and checked with my tech guru who
    confirmed that I should do this. The advice was --

    Open Control Panel > System & Maintenance > Indexing Options. In the
    Advanced Options, Click on Restore Defaults and also Rebuild Index. Click
    OK.

    Next, type 'service' in your Start Menu Search Bar, and start Services.
    Scroll down to the 'Windows Search Service', and ensure that it is set on
    Automatic and Running. Restart this Service. You will also have to ensure
    that RPC (Remote Procedure Call) is running and set on automatic.

    ====================================


    When I go to the Advanced Options tab as recommended above, there is no
    "Restore Defaults" option, just a "Rebuild" button (to "delete and rebuild"
    the index.') I assume that's fine, though perhaps there's a Restore Defaults
    option elsewhere.

    I then went to Services, as suggested. I found "Windows Search" and set it
    to "Automatic."

    When I right-click on it, "Restart" is grayed out. However, there is
    another button in the window, "Start the service."

    However, when I click "Start the service" and got --

    "Windows could not start the Windows Search on the Local Computer. For more
    information, view the System Event Log."

    The Event Log has a various of error messages for my various attempts. They
    include --

    The Windows Search Service failed to start due to the following error:
    The service did not respond to the start or control request in a timely
    fashion

    A timeout was reached (30000 milliseconds) while waiting for the Windows
    Search service to connect.

    DCOM got error "1053" attempting to start the service WSearch with arguments
    "" in order to run the server: {7D096C5F-AC08-4F1F-BEB7-5C22C517CE39}

    ====================================

    If any of this makes sense to anyone, or if there are any suggestions,
    I offer my thanks in advance.


    Robert

  2. #2
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Don't know if this applies here or not but sometimes the only way to get a service to start is to disable it first, reboot, then enable (set to automatic) without starting, and reboot. If that doesn't do the trick then there is probably another dependency that the service is waiting on that in turn must be handled in a similar way before it will all work as far as services running goes. It mainly happens with application services though and not with Microsoft services so that might not be the problem.

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Did you check to make sure the RPC service was running?

    Joe
    Joe

  4. #4
    Star Lounger
    Join Date
    Oct 2002
    Posts
    53
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Byron Tarbox View Post
    Don't know if this applies here or not but sometimes the only way to get a service to start is to disable it first, reboot, then enable (set to automatic) without starting, and reboot. If that doesn't do the trick then there is probably another dependency that the service is waiting on that in turn must be handled in a similar way before it will all work as far as services running goes. It mainly happens with application services though and not with Microsoft services so that might not be the problem.

    Thanks for your response. Before I attempt this, I want to ask a question to the response below, since that might over-ride your suggestion here.


    Robert

  5. #5
    Star Lounger
    Join Date
    Oct 2002
    Posts
    53
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by JoeP View Post
    Did you check to make sure the RPC service was running?

    Joe
    Thanks for your reply. I just checked, and the answer is --- I'm not sure.

    There are two RPC listings under Services.

    One is RPC, and it's listed as "Started."

    The other is RPC Locator, and it's not running, but set to Automatic.

    Are you suggesting that both should be set to Automatic, or are you referring only to the first "RPC", which *is* running?


    Robert

  6. #6
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Quote Originally Posted by rje View Post
    Thanks for your reply. I just checked, and the answer is --- I'm not sure.

    There are two RPC listings under Services.

    One is RPC, and it's listed as "Started."

    The other is RPC Locator, and it's not running, but set to Automatic.

    Are you suggesting that both should be set to Automatic, or are you referring only to the first "RPC", which *is* running?


    Robert
    The RPC Locator does not have to be running. The Locator was utilized in Windows 2003 and earlier, but now is only for application compatibility and serves no other purpose in Vista or Win7. I have it set to Manual.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  7. #7
    Star Lounger
    Join Date
    Oct 2002
    Posts
    53
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Byron Tarbox View Post
    Don't know if this applies here or not but sometimes the only way to get a service to start is to disable it first, reboot, then enable (set to automatic) without starting, and reboot. If that doesn't do the trick then there is probably another dependency that the service is waiting on that in turn must be handled in a similar way before it will all work as far as services running goes. It mainly happens with application services though and not with Microsoft services so that might not be the problem.

    I just tried the above, and unfortunately got the same error message and problems. (I haven't changed that RPC Locator setting, as another note suggested, so perhaps that will have an impact. But I'm not holding my breath. The regular "RPC" service is running.)


    Robert

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •