Results 1 to 8 of 8
  1. #1
    2 Star Lounger
    Join Date
    Jun 2001
    Location
    Vancouver, BC
    Posts
    100
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I've got a PC with two physical hard drives. Before installing Windows 7 (Ultimate, 64 Bit), I deleted the partitions on both drives using my Windows XP SP3 disk (all data / documents safely backed up!).

    The install for Windows 7 went very smoothly - it partitioned and formatted the C drive and everything works fine. The only problem is that in (My) Computer, I don't see the D drive.

    If I check the system devices, it's listed there and Windows reports that there are no problems with it, but I can't access it to create a partition, format it, then use it for document and photo storage. I gather I should have had a partition on it before I went ahead and installed Windows 7.

    Any suggestions on how to do that now, short of buying a third party partitioning program? Can you do it within Windows 7? So far I haven't found anything to do that. Could I use either my W7 or XP install discs to boot from, then partition the drive, then exit without doing any installation?

    Thanks for any suggestions.

    John

  2. #2
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Milwaukee, WI
    Posts
    737
    Thanks
    23
    Thanked 64 Times in 52 Posts
    Windows 7 hides anything that is not in use, such as an empty DVD drive. Since your other isn't partitioned, you will not see it in Computer. When you say can see it in Devices, do you mean Device Manager, or Disk Manager? I'm going to assume for a moment that you haven't looked in Disk Manager. Right click on Computer, select Manage. Then click on Disk Management. You should see all available disks, whether they are partitioned or not. You can also create partitions and format them as needed. If you are not seeing it in Disk Manager, then somehow a non-Windows partition got created and Windows can't read it. If you can take a look and let us know, then I think we can make some further suggestions.
    Chuck

  3. #3
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    If its just an empty Windows partition the setting to reveal it in My Computer is under Folder Options>View.

    As mentioned, it should appear in Disk Management regardless of the view setting or current partition status.

  4. #4
    2 Star Lounger
    Join Date
    Mar 2010
    Location
    Midwest USA
    Posts
    120
    Thanks
    2
    Thanked 2 Times in 2 Posts
    If it doesn't show up after you try the tips from Chuck and Byron...toss the Win 7 install DVD in the drive and boot to it. Proceed to the partition function and create a partition on the missing drive then quit. Actually, I would disconnect the original drive first....not possible to partition the wrong drive that way.

  5. #5
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    I suspect when you do go to disk manager you will see the other drive (D) listed as unallocated space since you state you deleted both partitions before running Win 7 install. Win 7 did format and create the C partition but since you did not specify anything for the D partition, the install ignored it completely. Any partitioning tool including the Win 7 disk manager should be able to fix this pretty easily. Right click on the other partition (Be sure you DO NOT choose your Win 7 partition), format it and create a simple volume. You can then name it as drive letter D and a simple name to identify it.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  6. #6
    New Lounger
    Join Date
    Mar 2010
    Location
    Marysville,Michigan,USA
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I just went through the exact same thing. Try this: Open Computer Management by clicking the START button. Then click the CONTROL PANEL, click SYSTEM AND SECURITY, click ADMINISTRATIVE TOOLS, and then double click COMPUTER MANAGEMENT. If prompted for administrator password or confirmation, type the password or confirm. In the Left pane, Under STORAGE, click DISK MANAGEMENT and look for your drive. Hope this helps.
    Sincerely, Dave

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Winnipeg, Manitoba, Canada
    Posts
    14
    Thanks
    0
    Thanked 1 Time in 1 Post
    Try Control Panel -> Folder Options

    Go to the "View" tab and uncheck "hide empty drives in the Computer folder"

  8. #8
    2 Star Lounger
    Join Date
    Jun 2001
    Location
    Vancouver, BC
    Posts
    100
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks to everyone who replied - and sorry for the delay in responding (busy at work). All the solutions were great, and the very first one did the trick - I hadn't looked at Disk Manager. Took all of a few seconds and my second drive is back and ready for action.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •