Results 1 to 5 of 5
  1. #1
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Sacramento, CA, USA
    Posts
    116
    Thanks
    7
    Thanked 4 Times in 4 Posts
    I have a home built computer that used to run Windows XP, and a re-purposed little 5-watt Linux box on the LAN also. Under XP, I could wake up the deskside computer from sleep or hibernation by logging in to the always-on Linux box and run a wake-on-lan program with the deskside computer's Ethernet address.

    But since upgrading the deskside computer to Windows 7x64, the same wake-on-lan program doesn't wake up the computer. I know the computer is in sleep mode, it wakes normally when a key is pressed or the mouse moved. It just doesn't recognize a signal from the Ethernet anymore. Any ideas how to activate this in Win7?

  2. #2
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    828
    Thanks
    4
    Thanked 38 Times in 34 Posts
    First, make sure you have the latest driver for the NIC.

    Second, open the NIC's properties (Network and Sharing Center | Change Adapter Settings, right-click the adapter and select Properties, click Configure) and on the Power Management Tab check the "Allow this device to wake the computer option" box (abd the one underneath it.

  3. #3
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Sometimes there is a BIOS WOL option that must be enabled as well. Sometimes its tied into the type of sleep setting in the BIOS but most should be S3 these days which allows for WOL.

  4. #4
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Sacramento, CA, USA
    Posts
    116
    Thanks
    7
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by Peter Johnson2191 View Post
    First, make sure you have the latest driver for the NIC.

    Second, open the NIC's properties (Network and Sharing Center | Change Adapter Settings, right-click the adapter and select Properties, click Configure) and on the Power Management Tab check the "Allow this device to wake the computer option" box (abd the one underneath it.
    Device Manager says it's the latest driver. Under Properties->Advanced I made sure Wake on Magic Packet was Enabled.
    Under Power Management the "Allow this device to wake the computer" box was already checked, but not the one below ("Only allow a magic packet to wake the computer"). So I checked that too.

    Still doesn't work (wake up from sleep on receiving the WOL packet on the LAN).

    I notice Advanced there is an option for a Network Address, which right now is Not Present. I'm not sure what this is about: Ethernet address? NAT? Something else? Doesn't matter?

  5. #5
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,413
    Thanks
    33
    Thanked 195 Times in 175 Posts
    Might be worth you running WireShark to check whether the WOL packet has been issued, and that it is in the correct format. I checked on this for a Buffalo NAS to see what their software was doing (answer - sending a group of three WOL packets at a random number of seconds interval between 10 and 60, to keep it awake)...
    BATcher

    Time prevents everything happening all at once...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •