Results 1 to 6 of 6

Thread: Networking

  1. #1
    New Lounger
    Join Date
    Apr 2010
    Location
    Zephyr, Ontario, Canada
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have recently purchased a Windows 7 laptop which I would like to network with my XP desktop. As I am only on dial-up (yes, really!) I decided to use a crossover DSL patch cord rather than a router. I was able to configure the XP, and can in fact "see" the shared files on my laptop. But I cannot get the Windows 7 laptop to "see" the desktop. Hope this first post makes some sort of sense.

  2. #2
    5 Star Lounger
    Join Date
    Dec 2003
    Location
    Burrton, KS, USA
    Posts
    833
    Thanks
    0
    Thanked 2 Times in 2 Posts
    sounds like a firewall on the xp box could be blocking you.

    for a temporary test, turn off all firewall(s) on the xp box and see if it works. You may have multiple firewalls running depending on what security software you have installed. Unless you have manually changed something at least the Windows firewall is probably running.

  3. #3
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have several Win7 systems that, though they started out with full and non-discriminating network discovery processes, have come to display only other Win7 systems, maybe after an update, maybe its something about my network structure, don't know.

    So what you should try first before attempting to find out if security is actively blocking your attempts, is open your Network window in Win7, wait until the discovery process completes, and right click on Network in the address window and choose edit address and type in \\your xp computer name\ and wait a sec or two and see if a dropdown pops up with all the shares associated with the XP system.

    If that works then you know its something to do with the discovery protocols and not with anything blocking. If it doesn't work then look at actively blocking sources.

  4. #4
    New Lounger
    Join Date
    Apr 2010
    Location
    Zephyr, Ontario, Canada
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you both for your suggestions. I tried them both and was still unsuccessful. Thinking back, I wonder if my problem is that I did originally purchase and install a wireless router. It established a network with both computers and worked fine but due to the nature of my house, would not give me the range that I needed. I should have known better but I thought if I was going to have to leave them both side-by-side there was no point in using a router, hence the switch to a cross-over patch. I do remember that Windows 7 asked me to set up a workgroup which I did. Now I'm confused between workgroups, homegroups, and networks. I guess the first thing I need to do is work through the Windows 7 tutorial and try to learn more, as I am clearly out of my depth
    Thanks again.

  5. #5
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Hi Bob,

    Click on System in Control Panel on your XP computer and on System Properties, select the Computer Name tab and note the Workgroup name shown on the screen. Then make certain you have File and Printer Sharing check marked in the Network Connection Properties page.

    Then pick the folders on your XP computer you want to share with your Win7 machine and set them up as shared folders by right clicking the folder and selecting the Sharing tab and check mark Share this folder on the network followed by a click on the Apply button. Also go to Windows Explorer and select Tools| Folder Options|View and be sure the Automatically search for network folders and printers is check marked.

    Next go to your Windows 7 machine, and type in System in the Start Menu Search box . Look for the Workgroup name on this page and be sure to change it to the same name as on your XP computer. (the Workgroup name for Win7 defaults to WORKGROUP, and in XP it defaults to MSHOME.) Next go to the Network and Sharing Center , and click on Change advanced sharing settings on the left panel, and make sure Network Discovery is turned on, as well as File and Printer sharing. Also turn on sharing in the Public Folders, and turn off password protected sharing. Click on Save to set your changes.

    Hopefully you will be able to see and access the XP shared folders on your Windows 7 computer. Homegroups are not a factor as you cannot join XP computers to a homegroup.

    Hope this helps.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  6. #6
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok, since I had a little time and some curiosity, I did it, and here's how so maybe it will do the trick.


    I did it from the perspective of XP being the computer connected to the dial-up connection (cuz I don't know how to set it up on 7).

    First thing I did was go to network connections on the XP system and right click on the dial up connection>properties>advanced tab> and checked Allow other network users to connect through this computer's Internet connection. That makes the XP system the "boss" and sets the adapter connected to the crossover cable to 192.168.0.1 and it becomes the DHCP server through ICS (Internet connection sharing)

    Then on the Windows 7 side I enabled the adapter the other end of the crossover cable was connected to and it started up the Network connection window and I chose Home network and let it do its thing.
    Then I clicked on Network and just the Window 7 system appeared but when I used the Edit Address trick mentioned earlier, all the shared places on the XP system appeared and I could connect to anyone of them.

    Workgroups are the defaults MSHOME for XP and WORKGROUP for 7 but if you make them both the same you won't have to back up one level in the structure to see both workgroups (in XP).

    7 went right into XP like a hot butter knife but since I didn't set anything other than the shared folders in 7, I had to sign into the Win7 system from the XP side to get access but once I did it worked just as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •