Results 1 to 11 of 11
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Kangaroo Ground, Victoria, Australia
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi!
    This has been driving me nuts for a number of months now and I haven't been able to solve it.
    My Toshiba laptop with Vista pro ultimate wakes itself from hibernation, seemingly relatively randomly but commonly around 3AM.

    I have followed all the steps here to no avail. I've googled heaps but not found a solution for me - it seems a lot of people have this problem and the causes seem to be varied but I've not found any reason for this machine of mine to wake up unbidden by it's owner.

    The entry in my event viewer for the most recent wake states:
    Log Name: System
    Source: Microsoft-Windows-Power-Troubleshooter
    Date: 19/04/2010 3:17:37 AM
    Event ID: 1
    Task Category: None
    Level: Information
    Keywords:
    User: LOCAL SERVICE
    Computer: Karl-PC
    Description:
    The system has resumed from sleep.

    Sleep Time: 18/04/2010 11:17:21 AM
    Wake Time: 18/04/2010 5:17:34 PM

    Wake Source: RTC
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Microsoft-Windows-Power-Troubleshooter" Guid="{cdc05e28-c449-49c6-b9d2-88cf761644df}" />
    <EventID>1</EventID>
    <Version>0</Version>
    <Level>4</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8000000000000000</Keywords>
    <TimeCreated SystemTime="2010-04-18T17:17:37.306Z" />
    <EventRecordID>230844</EventRecordID>
    <Correlation ActivityID="{039A4016-8F5A-4271-A158-BB4CEDD23739}" />
    <Execution ProcessID="228" ThreadID="3808" />
    <Channel>System</Channel>
    <Computer>Karl-PC</Computer>
    <Security UserID="S-1-5-19" />
    </System>
    <EventData>
    <Data Name="SleepTime">2010-04-18T11:17:21.973Z</Data>
    <Data Name="WakeTime">2010-04-18T17:17:34.172Z</Data>
    <Data Name="SleepDuration">8702</Data>
    <Data Name="WakeDuration">1667</Data>
    <Data Name="DriverInitDuration">1041</Data>
    <Data Name="BiosInitDuration">3097</Data>
    <Data Name="HiberWriteDuration">0</Data>
    <Data Name="HiberReadDuration">0</Data>
    <Data Name="HiberPagesWritten">0</Data>
    <Data Name="Attributes">24594</Data>
    <Data Name="TargetState">4</Data>
    <Data Name="EffectiveState">4</Data>
    <Data Name="WakeSourceType">3</Data>
    <Data Name="WakeSourceTextLength">0</Data>
    <Data Name="WakeSourceText">
    </Data>
    </EventData>
    </Event>

    and when in cmd shell
    C:\Users\Karl>powercfg lastwake
    Wake History Count - 1
    Wake History [0]
    Wake Source Count - 1
    Wake Source [0]
    Type: Fixed Feature
    Timer Expired (RTC)

    C:\Users\Karl>powercfg -devicequery wake_armed

    returns nothing at all - I have previously disarmed all devices from waking.

    I have checked through all shceduled tasks and nothing is set to wake from sleep.
    I have checked all hardware devices, including, usb, network and none are set to wake from sleep.

    Does anyone know where I can go with this to find out what this RTC event is that is waking my machine up?

  2. #2
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Sydney, Australia
    Posts
    254
    Thanks
    0
    Thanked 5 Times in 5 Posts
    I haven't had a chance to look into this more carefully yet but have you tried disabling/re-enabling Hibernation? this resets the hibernation file (hiberfil.sys)

    I know it seems like such a simple task as I did skim over the extensive assist guide you linked to.

    You can do this easily via commandline: powercfg-h {on|off}

    I found that I had to do this when using Vista on a laptop often but Windows 7 has not caused me such grief so far.

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,568
    Thanks
    5
    Thanked 1,056 Times in 925 Posts
    3 AM is the default time for Windows to check for updates. What is your Automatic Update setting?

    Joe
    Joe

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    Kangaroo Ground, Victoria, Australia
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by JoeP View Post
    3 AM is the default time for Windows to check for updates. What is your Automatic Update setting?
    Hi Joe,
    Important updates --------------------------------
    "Check for updates but let me chose whether to download and install them"
    Install new updates: "Every day" at "9:00AM"

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    Kangaroo Ground, Victoria, Australia
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Josh B View Post
    I haven't had a chance to look into this more carefully yet but have you tried disabling/re-enabling Hibernation? this resets the hibernation file (hiberfil.sys)
    Thanks for this Josh, I think I'll try that. In all the randominity of this problem it didn't do it last night - it seems to skip days. OK so mental note to myself, the last time it did it was 3:17am Monday morning but not on Tuesday morning.

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    Kangaroo Ground, Victoria, Australia
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Well I have tried
    powercfg -h off
    powercfg -h on

    So we'll see what happens. It seems to switch instantaneously though - doesn't take any time deleting a 3GB hiberfil.sys

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Kangaroo Ground, Victoria, Australia
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Tuesday night and no auto re-start.

  8. #8
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Sydney, Australia
    Posts
    254
    Thanks
    0
    Thanked 5 Times in 5 Posts
    Quote Originally Posted by Karl Rolfe View Post
    Tuesday night and no auto re-start.
    For the time being I will cross my fingers because the originally I had a similar problem with a laptop where it would resume and flatten the battery. After a bit of research I found that using that command to essentially reset the hibernation file removed any "corruption" you may say.


  9. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    Kangaroo Ground, Victoria, Australia
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Wednesday and still no magic re-start, so far so good.

  10. #10
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    I disabled hibernation all together on my Win 7 systems. Even though I have a relatively large sized HD, I felt for the few if any times I used hibernate, I did not want to give up the 3+ GB size that the hyberfil.sys file consumed after a short period of time. I use sleep and shutdown, but not hibernation. I was having some problems on a desktop similar to this when Vista was installed but none since upgrading to Win 7.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  11. #11
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Sydney, Australia
    Posts
    254
    Thanks
    0
    Thanked 5 Times in 5 Posts
    Hi Karl,

    Just curious how this panned out for you, is everything still running smoothly as per your last post?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •