Results 1 to 3 of 3
  1. #1
    Star Lounger
    Join Date
    Mar 2004
    Location
    White Oak, Pennsylvania, USA
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Using Access 2002 - SP3 I am receiving and error message when I try to open the database:

    AO index is not an index in this table.

    I've tried repair the database but the repair process will not complete - I get the same error.

    We had a significant power outage here - lots of ons and offs in a rapid sequence so I fear the db got corrupted.

    Fortunately I have a backup from the previous day but I wonder if there is a way to recover the database.

  2. #2
    5 Star Lounger AndrewKKWalker's Avatar
    Join Date
    Apr 2001
    Location
    Cambridge, UK
    Posts
    1,020
    Thanks
    0
    Thanked 3 Times in 3 Posts
    This often means corruption in an Access System table, and can be a nightmare.

    You can try deleting any .ldb files with the database not running.

    Also could possibly try importing the database into a new database
    (although you might have to set up any startup options and references).

    Might be worth having a look at Allen Brownes Site AO Error here

    You need to scroll down the page a bit to find his possibly solution.

    You can also get to the Full Site HERE
    Andrew

  3. #3
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts
    You can try downloading the JetComp utility from the microsoft website. Sometimes it will fix problems the internal Repair won't.

    Otherwise, you might try a 3rd party service. www.vb123.com has one. You send them a zipped copy of your database, and they will tell you if they can fix it, and how much it will cost.
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •