Results 1 to 12 of 12

Thread: Word 2000

  1. #1
    Bill Atk
    Guest

    Word 2000

    Compile error in hidden module: Auto Exec
    How do I get rid of theis error message that comes up when starting Word 2000?
    Thanks, Bill.

  2. #2
    Platinum Lounger
    Join Date
    Dec 2000
    Location
    Queanbeyan, New South Wales, Australia
    Posts
    3,730
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word 2000

    Bill,

    It sounds like you've got an add-in. Look for any ".dot" files in the folder showing in your "Tools. Options, File Locations, Startup" folder.

    It may not be a good idea to remove anything there- if it's a company ccomputer, there may be corporate info there; or third party packages which interact with word can put stuff there.
    Subway Belconnen- home of the Signboard to make you smile. Get (almost) daily updates- follow SubwayBelconnen on Twitter.

  3. #3
    Bill Atk
    Guest

    Re: Word 2000

    Hello Geoff,
    no .dot files in the Statup folder.
    Regards, Bill

  4. #4
    Platinum Lounger
    Join Date
    Dec 2000
    Location
    Queanbeyan, New South Wales, Australia
    Posts
    3,730
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word 2000

    Bill,

    Have a look in your macro editor, in the Project Explorer Window. From Word, hit Alt + F11; it's usually the window on the left side, top half.

    If you've opened Word up from scratch, there's probably one line which says "Normal" and another which says "Project1 (Document1)". There will be things underneath that Project1, but are there any other on the same level?

    Click on the Plus sign next to Normal. Is there a line which says "Modules"? If so, click on the plus sign next to that, and let us know what they are.
    Subway Belconnen- home of the Signboard to make you smile. Get (almost) daily updates- follow SubwayBelconnen on Twitter.

  5. #5
    Bill Atk
    Guest

    Re: Word 2000

    Hello Geoff,

    Nothing on the same level as Project (Document 1),

    No line next to Normal which says Modules.

    Regards, Bill

  6. #6
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word 2000

    The problem can occur if the AutoExec is in the Normal template or in a template loaded at startup.

    Startup templates might be in any of a number of directories. Check Tools | Templates & Add-ins to see what you have.

    There's an AutoExec macro in one of those critters.

  7. #7
    Platinum Lounger
    Join Date
    Dec 2000
    Location
    Queanbeyan, New South Wales, Australia
    Posts
    3,730
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word 2000

    Bill,

    You've passed my limited knowledge of Word.

    The only 2 things I can suggest now (straw clutching) are:
    .Perhaps something to do with a COM add-in? But I don't know about these
    .If you open Word with the shift key held down (which is supposed to bypass macros) do you still get the error?
    Subway Belconnen- home of the Signboard to make you smile. Get (almost) daily updates- follow SubwayBelconnen on Twitter.

  8. #8
    Gold Lounger
    Join Date
    Dec 2000
    Location
    Hollywood (sorta), California, USA
    Posts
    2,759
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word 2000

    Bill,

    Just to be thorough, try forcing Word to create a new, blank Normal.dot. I think the other posters here are on to something in that you've got a normal.dot problem.

    If you know there is nothing of value in your Normal.dot, delete all copies of Normal.dot on your PC. Or rename the Normal.dot file Word is using. Which one is it using? One quick way to tell is if the folder containing Normal.dot also has a ~$Normal.dot file -- that's the one.

    When Word starts it looks for Normal.dot in these locations in this order:

    1. The User Templates folder. By default this is crogram filesmicrosoft officetemplates. But you can check the Options>File Locations>User Templates setting in Word to see what Word is using.

    2. The Workgroup templates folder. Again, check the File Locations tab for the folder name. If Word is using this in a networked environment and multiple users access this Normal.dot, you're asking for trouble. Don't let Word find a Normal.dot in Workgroup Templates.

    3. The Word folder: By default: crogram filesmicrosoft officeoffice

    4. The current (DOS or OS) folder.

    If you have no Normal.dot files on the PC and restart Word, it will create a new one. If you still have your compile error message, you've got to have an add-in or Word command line macro problem.
    Kevin <IMG SRC=http://www.wopr.com/w3tuserpics/Kevin_sig.gif alt="Keep the change, ya filthy animal...">
    <img src=/w3timages/blackline.gif width=33% height=2><img src=/w3timages/redline.gif width=33% height=2><img src=/w3timages/blackline.gif width=33% height=2>

  9. #9
    Bill Atk
    Guest

    Re: Word 2000

    Hello Kevin,

    Thanks for your suggestions. When I turned the machine on this morning (cold boot), the error message was gone, and Word has performed flawlessly since.

    I have no idea what happened, but I'm keeping your email on file in case the problem comes back!

    Thanks and regards,

    Bill

  10. #10
    Bill Atk
    Guest

    Re: Word 2000

    Hello Geoff,

    Thanks for your help. When I turned the machine on this morning (cold boot), the error message was gone, and Word has performed flawlessly since.

    I have no idea what happened!

    Thanks and regards,

    Bill

  11. #11
    Bill Atk
    Guest

    Re: Word 2000

    Hello Howard,

    Thanks for your suggestions. Kevin had some ideas as well, along similar lines.

    In the meantime, when I turned the machine on this morning (cold boot), the error message was gone, and Word has performed flawlessly since.

    I have no idea what happened, but I'm keeping your email on file!

    Thanks and regards,

    Bill

  12. #12
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word 2000

    Hi Kevin:

    FWIW, in Office 2000, the default for normal.dot (& user templates) is:

    C:WINDOWSApplication DataMicrosoftTemplates

    rather than Program FilesMS OfficeTemplates

    I don't know what it was in Office 97, but I know in Word 6 & Word 95, the default was in MS Office, as you mention.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •