Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    Ottawa, ON, Canada
    Posts
    43
    Thanks
    0
    Thanked 1 Time in 1 Post
    I know that this has been beat to death, but I'm still stuck.

    I have one Windows 7 Home Premium 64 bit machine and 4 XP SP3 machines.

    The windows 7 machine can access all the shared drives on the XP machines.

    The XP machines can print to printers physically connected to the 7 machine.

    The XP machines can see the shared drives on the 7 machine, BUT when I try to map to them, I get an "access denied" message.

    I've set all the sharing parameters on the 7 machine to allow sharing, to require no password and to allow full access. Still no luck. I've been at this for hours.

    Can someone walk me through this, please? I'm not a novice. I've had sharing with the xp machines for years and going from the 7 to the xp machines works fine.

    Thank you very much

    Grant
    Ottawa ON

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,594
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Joe

  3. #3
    Lounger
    Join Date
    Dec 2009
    Location
    Ottawa, ON, Canada
    Posts
    43
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thanks, Joe. I have looked at that article. He concentrates mainly on going the other way. That is, getting 7 to see a shared drive on an xp machine. I have that running fine. It's the other way that is driving me nuts. I've read Woody's articles and some other on Windows Secrets. None of their suggestions work.

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,594
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Is your Windows 7 networking configured as recommended in the article?

    What happens if you turn off your firewalls?

    Joe
    Joe

  5. #5
    5 Star Lounger
    Join Date
    Dec 2003
    Location
    Burrton, KS, USA
    Posts
    833
    Thanks
    0
    Thanked 2 Times in 2 Posts
    If you are trying it share the USER folders on the 7 machines, access will be denied unless you add permissions for the EVERYONE or GUEST groups.

    With password protection turned off, any file or folder that has permissions for Everyone or Guest can be accessed without authentication, HOWEVER, The user folders do NOT have everyone and guest permissions by default.

    You should be able to access the Public folders without any need to change file permissions.

    One more thing, You have to have the Everyone or guest group active on the XP machine for this to work. Otherwise the 7 machine does not see that user and will not share the file.

  6. #6
    Lounger
    Join Date
    Dec 2009
    Location
    Ottawa, ON, Canada
    Posts
    43
    Thanks
    0
    Thanked 1 Time in 1 Post
    This is good, thanks.Just to make sure that I understand you, I am trying to share drives - an E drive to be specific. The drive does map into xp, but when I try to access it, I get the access denied message

  7. #7
    Lounger
    Join Date
    Dec 2009
    Location
    Ottawa, ON, Canada
    Posts
    43
    Thanks
    0
    Thanked 1 Time in 1 Post
    Mercyh

    I turned Guest on in the xp machine. I added Guest to the permissions for the drive in 7. I still get the access denied message.

  8. #8
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,654
    Thanks
    7
    Thanked 113 Times in 97 Posts
    Quote Originally Posted by Grant Wilkinson View Post
    Mercyh

    I turned Guest on in the xp machine. I added Guest to the permissions for the drive in 7. I still get the access denied message.
    Now turn on permissions for the Everyone Group on your Win7 shares. Also, instead of sharing the entire E:\ drive, for a test, just select one or two folders on the E: drive to share with Everyone.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  9. #9
    Lounger
    Join Date
    Dec 2009
    Location
    Ottawa, ON, Canada
    Posts
    43
    Thanks
    0
    Thanked 1 Time in 1 Post
    Gerard

    I used "share with" on one folder on the drive. In "permission", it shows Everyone and Guest. This is all on the Win 7 machine. On the XP machine, I have Guest turned on.

    I still get the same message from XP when I try to access the folder. I can see the folder in the network list, and I can map to it, but I cannot access it.

    The Win7 firewall is configured to allow sharing.

    Tks for helping with this.

    Grant

  10. #10
    Lounger
    Join Date
    Dec 2009
    Location
    Ottawa, ON, Canada
    Posts
    43
    Thanks
    0
    Thanked 1 Time in 1 Post
    I got it!!

    The problem was that although I was configuring everything in the sharing tab, I did not go into the security tab to do it, too. I went into the security tab and added guest to the permissions list. Presto!

    Thanks to all who helped me through this. I really appreciate it.

    Grant

  11. #11
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Just to be clear when you are setting permissions you are going under the Security tab in the properties of a drive or folder right? That's where it needs to be set to Everyone with full permissions for Everyone. This is in addition to the Sharing permissions.

  12. #12
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hey, you got it while I was posting!! Or you were posting you got it while I was posting how to get it...or something like that...

  13. #13
    Lounger
    Join Date
    Dec 2009
    Location
    Ottawa, ON, Canada
    Posts
    43
    Thanks
    0
    Thanked 1 Time in 1 Post
    Byron

    Going into the Security tab was what I had been missing. I was doing everything in the Sharing menus, but not going into Security. As soon as I smartened up and went into the Security tab, I solved my problem.

  14. #14
    5 Star Lounger
    Join Date
    Dec 2003
    Location
    Burrton, KS, USA
    Posts
    833
    Thanks
    0
    Thanked 2 Times in 2 Posts
    You realize that you just took away a bunch of Windows 7 security by doing this........

    I know it is a bit of a pain but a better way is to have a user name and password on each machine that is the same, then give that user permissions on all your shares. Use this login when you start up all your machines and they will automatically authenticate against each other with password security turned on....

    If I bring my virus infected laptop onto your wireless network or plug an infected machine into your network, some viruses will find the shares and infect the other machines. If you have password sharing turned on and I don't have the correct user and password, my machine can't write to your shares so can't infect you.

  15. #15
    Lounger
    Join Date
    Dec 2009
    Location
    Ottawa, ON, Canada
    Posts
    43
    Thanks
    0
    Thanked 1 Time in 1 Post
    MercyH

    I know what you are saying. I intend to put identical user names and passwords on all our machines, but I wanted to at least figure out my problem first. I don't have a wireless set up at all. The house is wired in every room, and on the patio, so I've not found it necessary. The router is capable of it, but it's turned off.

    Thanks for your help with this

    Grant

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •