Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Thanked 0 Times in 0 Posts
    I suspect my issue is with an update/backup of Dell DataSafe that didn't write properly. Last night my Dell Inspiron laptop with a Dell image on it updated DataSafe and saved data out to its recovery partition. It asked to reboot and I let it. On reboot, after the Inspiron 'POST' status bar completes, it goes to a black screen with an 'underscore' cursor blinking in the top left of the screen. It never goes any further.

    I booted from the Win7 DVD and it didn't find any boot problems to fix with the "Startup Repair" option. I tried the "System Restore" option and it says that it successfully restored from my most recent point, but upon reboot it still won't proceed from the blinking cursor point. I let it sit at the cursor for about an hour with no change.

    It seems like the disk is still "good" but something is messed up with the partition table or the like.

    I don't have any recovery images. I'm thinking I might be able to boot to an alternate OS from a CD and get at the disk to pull off some data (my email .pst is really the only thing that hasn't been backed up recently, and I'd hate to lose it), but I'd like to pick the collective brains here about my options to repair the disk tables.

    It looks like my next step might be to go to the "Command Prompt" option and follow the steps in but I'm wondering how much the "Startup Repair" option has already tried of those steps, or what would be most likely to work based on the above symptoms.

    Any advice or background relating to the BCD would be greatly appreciated. I'm regretting not wiping the Dell image and starting from scratch when I got the laptop a couple of months ago.

  2. #2
    Super Moderator CLiNT's Avatar
    Join Date
    Dec 2009
    California & Arizona
    Thanked 608 Times in 556 Posts
    It looks like my next step might be to go to the "Command Prompt" option
    You could start with a CHKDSK C: /F or /R commands, followed by the "bootsect /nt60 C:\"
    "bootsect /nt60 SYS" (to repair the system partition) or "bootsect /nt60 ALL" (all partitions).
    [How to repair MBR on Windows 7 from eHow]

    (Run each command one after another)

    BootRec.exe provides the following command-line paramters:
    •/FixMbr. Re-writes the master boot record (MBR) of the system partition to start Windows Vista. This won’t overwrite the existing partition table.
    •/FixBoot. Writes a boot sector onto the system partition to start Windows Vista.
    •/ScanOs. Scans all disks for Windows Vista installations and displays them to you. Oddly, this didn’t work for me, even on a test system that was starting just fine.
    •/RebuildBcd. Scans all disks for Windows Vista installations and prompts you to pick the ones you want to add to the BCD.

    [from www*vistaclues*com/how-to-manually-repair-bcd-when-windows-wont-start]
    Some info here too

    Let us know if any of the above boot repairs work, I've not had the unfortunate pleasure
    in Windows 7 yet.
    Invest a little time and energy in a well thought out BACKUP regimen and you will have minimal down time, and headache.

    Build your own system; get everything you want and nothing you don't.
    Latest Build:
    ASUS X99 Deluxe, Core i7-5960X, Corsair Hydro H100i, Plextor M6e 256GB M.2 SSD, Corsair DOMINATOR Platinum 32GB DDR4@2666, W8.1 64 bit,
    EVGA GTX980, Seasonic PLATINUM-1000W PSU, MountainMods U2-UFO Case, and 7 other internal drives.

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Thanked 0 Times in 0 Posts
    Clint, thanks. BOOTREC with /fixmbr and then /fixboot worked. The rebuildbdc wouldn't run (something like no installations found, strange), but since I could boot into it I'm going to assume all is well. I guess I should run a chkdsk, too.

    No data loss. I went and uninstalled all the DataSafe products, too.

    Thanks again for confirming what I should try.

    Curiously, the Windows 7 DVD took about an HOUR to load up to get to the recovery options. I don't know if it's AMD, or the memory, or what, but that was the most painful part of this experience. BartPE took a normal amount of time to boot to XP from CD.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts