Results 1 to 7 of 7
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    Edmonton, AB, Canada
    Posts
    39
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Good day to all.

    I've been dabbling with my new Win 7 box for several months now but have not done any serious work with it. The main reason I've not put much time or effort into learning the new way of doing things is because I have not been able to get my other computers to access shares on my new Win 7 box.

    That is: the Win 7 box can access drives on all of my other computers, However, none of my other computers can access drives on my Win 7 box.

    After much searching via Google and much more playing around, I found that the only way to allow my other computers to be able to access my Win 7 box was to create accounts that have passwords. Yep - up til now, not one of my computers has passwords associated with any accounts. Sorry - I just can't be bothered.

    That discovery put a real damper on my Win 7 learning. Part of the problem associated with this notion of requiring the accounts to have identical usernames and passwords is that I need my computers to be easily accessed by everyone in my company. That means that I would have to create identical accounts having identical passwords on everyone's computer. Sorry - that just doesn't make any sense. Why have a password if everyone knows it?

    However, along my travels, I saw an oblique reference to a group policy that enforces that requirement. Hmm, sez me, Group Policy. I've spent some quality time with the Windows Group Policy Editor in the past - it has helped me make some useful changes to machines. So I went searching. And . . . I struck pay dirt.

    The following is a copy of the file I created to keep in my records. It repeats some of what I've written above but I've left that stuff intact so that others can simply copy that part of this post and save it as a text file on their machines if they want.

    Note: our network is a workgroup (peer-to-peer networking), not a domain. The following instructions probably won't help in a domain situation.


    Copy begins:

    Title: How to configure Windows 7 Pro to allow file sharing
    to other computers that have accounts without passwords.

    Windows 7 is configured by default to NOT allow other
    computers having accounts without passwords to access
    shares. That is: other computers having accounts without
    passwords cannot remotely access Win 7 shares

    Eg: None of my computers have accounts with passwords. My
    Windows XP box gets an "Access Denied" message whenever it
    tries to access a share on the Win 7 box.

    This can be fixed two ways:

    1) Create the same account name and password on all machines
    that will be using file sharing. Yuck!

    2) Use the Windows Group Policy Editor to modify the security
    settings in the Win 7 computer so as to allow other computers
    having accounts without passwords to access file shares on
    Win 7 computers.

    Unfortunately, this works only with Windows 7 Pro and higher
    because Win 7 Premium and lower does not come with the Group
    Policy Editor. Some other smart person might be able to come
    up with the registry changes needed instead of using GPE.

    This tip comes from
    http://www.windowsnetworking.com/art.../winxpgpe.html
    and is courtesy of Johannes Helmig of Gerber Technology.

    a) In the Windows 7 search box (Start button), type GPEDIT.MSC
    and click the result that shows up at the top of the results box.

    b) Expand the following key: Computer Configuration -> Windows
    Settings -> Security Settings -> Local Policies -> Security Options

    3rd entry down from top called
    Accounts: Limit local account use of blank passwords to console logon only

    Default is ENABLED

    Right-click on the Enabled and select Properties. Read the help
    description if you wish, then click Disabled.

    That's it!

    I rebooted my computer after doing this but that may not have been
    necessary - I didn't bother to try it.

    End of copy.

    I hope this helps others out of the same predicament that I was in.

    dwayne

  2. The Following User Says Thank You to DwayneR For This Useful Post:

    roadman (2013-10-10)

  3. #2
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,655
    Thanks
    7
    Thanked 112 Times in 97 Posts
    Hi Dwayne,

    First, the instructions I am listing apply to workgroups, not domains. Second, I would encourage you to set up user names and passwords for all computers in your company, if for no other reason than to keep outsiders from accessing your computers. It is not necessary to set up an identical user name and password for each computer in the workgroup. I have a unique user name and password on all my machines. I also did not have to modify Group Policy on my Windows 7 Pro computer.

    I have a home network based on workgroup. I have one machine running Windows 7 Pro and one running Windows 7 Home Premium, both of which are 64 bit versions (but 32 or 64 does not matter in networking). I have no problems in my XP machines finding shares on both these computers.

    Check to be sure all computers on your network use the same workgroup name. The Windows 7 default is WORKGROUP, while the XP default is MSHOME.

    The place to check first to ensure network connectivity in Windows 7 is the Network and Sharing Center which is under Control Panel. When you open the Center, check that your active network is a Home (or Work) network and not a Public one. Then click on Advanced Sharing Settings on the left side panel. Here you find the vital components to check. You want to confirm the following are turned on: Network Discovery, File and Printer Sharing, and Public Folder Sharing (when Public folder sharing is enabled, other computers can see your Public folders, and any files you place in them). The next thing to do is to Turn off password protected sharing . Of course, in a business workgroup you may want to require password protected sharing for enhanced security.

    Now enabling File and Printer Sharing does not automatically set up shares on your Windows 7 machine. You still have to do that before anyone can access your shares from an XP machine (the exception being the Public folders). Navigate in Windows Explorer to find a folder you want to share, right click on the folder and select Properties (Note that there is a Share with option in the context menu, but that relates to HomeGroups and is not relevant to XP computers). When the Properties sheet appears, select the Sharing tab. Click the Share button, and for example, type Everyone in the Add field, and click Add. Note that the Permission Level is set to Read. You can click the drop arrow and change it to Read/Write if you desire to grant everyone permission to change your files in the share. Next click the Share button. This sets up your shared folder as accessible to everyone on your network, which is fine for a Home network. In a small business environment you can set up each user name to whom you want to grant access. Next click on the Security tab to confirm that you have applied appropriate permissions to the Everyone group (or the individual user names). Click on Everyone (or each user name) and view the permissions that are currently allowed, changing any that you desire and click Apply.

    Barring any unusual circumstances, such as firewall settings or IP misconfigurations, this should enable your XP machines to see your Windows 7 shares and take any actions for which you grant permission.

    Hope this helps.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  4. #3
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I also don't think password-less accounts in a business environment is a good idea, but besides all that mentioned by Gerald (which I can verify works, and I further don't even use the same workgroup names for everything (Windows 7 just ignores workgroups anyway but its usefull for segregating purpose-driven XP systems), you can use a special run command called control userpasswords2 and set it so an account will just automatically log on and function visibly as if it didn't have a password. Again though, probably not wise in a business environment.

  5. #4
    Lounger
    Join Date
    Dec 2009
    Location
    Edmonton, AB, Canada
    Posts
    39
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Hi there, Gerald.

    I had previously done all that you mention in your post to my Win 7 box. That is: enabling network discovery, disabling requiring passwords, etc. And, of course, I had shared the drives that I want shared (drives D & E). I don't allow the boot partition to be shared on any new machines that I set up but some (much) older machines have everything in the C drive - which then has to be shared. Just not worth the effort to fix that up on old machines.

    Anyway, the only way that I could allow my other machines to access the Win 7 drives was to create accounts with passwords. Like I mentioned, I just can't be bothered. Part of that is maintenance issues - I'd either have to create another account on everyone else's computers so that I can do maintenance and repairs, or rely on everyone to let me know what their passwords are, or force everyone to use the same password.

    That said, I'll take a closer look at the passwords issue. My current passwords policy dates back to my Windows 3.11 network era and I've just kept doing the same thing all these years, even as our networks and computers have changed.

    I don't have any Win 3.11 machines left running anymore but still have 3 Win 98se machines alive and doing well - they handle the old software and hardware that simply won't work on newer machines. I expect them to remain running for at least another 5 to 10 years. Those machines will also need to access the Win 7 box.

    Finally, the reason I posted my original message is that it took me a lot of time to actually find out WHY my other computers couldn't access my new Win 7 box. Very few places actually mention that the default security settings in Windows 7 requires that your other computers must have passwords on the accounts that will be accessing the Win 7 box. That's just not emphasized (or even mentioned) on most of the guides that I've seen.

    Plus, of course, I'm also telling you how to fix the problem if you don't want to use passwords on your accounts.

    dwayne

  6. #5
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    Location
    North Carolina, USA
    Posts
    2,655
    Thanks
    7
    Thanked 112 Times in 97 Posts
    Dwayne,

    For what it is worth, I can go to one of my XP computers that does not have a password, and connect to and work with shared folders on either of my Windows 7 computers. A Windows password is not required on my XP machines, and I have never had to resort to Group Policy to change any settings.

    If you follow all the directions and then set up your Windows 7 shares as I described in the fifth paragraph, then grant "Everyone" full permissions you should be good to go.

    You said in your last post that you set up drives D & E as shares. Try this: remove sharing from the whole drive and just select one folder on that drive, set it up as a share and grant permissions as directed earlier, and see if that works for you. If it does work, you can set up as many shared folders as you like.

    I do not share entire drives or partitions unless I map the drive as a network drive.
    Deadeye81

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  7. #6
    2 Star Lounger
    Join Date
    Jan 2004
    Location
    Kingwood, Texas, USA
    Posts
    112
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Deadeye81 View Post
    Hi Dwayne,

    I have a home network based on workgroup. I have one machine running Windows 7 Pro and one running Windows 7 Home Premium, both of which are 64 bit versions (but 32 or 64 does not matter in networking).
    This is exactly my situation, but I have some problem that I can not get past. On my Pro system I can see and connect to my Premium system and share any/everything I have set up on it for sharing (drives, folders, printers). But from the Home system, I can not get access to any of the shares I've setup on the Pro system. If I do a Map Network Drive and do a browse I "see" both the Home and Pro computers in the list, however clicking on either brings up the dreaded "\\NameOfComputer is not accessible... The specified network provider name is invalid." An observation - on the pro system doing the same thing, i.e. browsing for connections, shows both computers and when I click on either one I get the list of shares for that computer.

    Something is messing me up and I don't have any idea where the problem is. I've even tried setting up a homegroup with the same result. Help please. Thanks.

  8. #7
    New Lounger
    Join Date
    Oct 2013
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by DwayneR View Post
    Finally, the reason I posted my original message is that it took me a lot of time to actually find out WHY my other computers couldn't access my new Win 7 box. Very few places actually mention that the default security settings in Windows 7 requires that your other computers must have passwords on the accounts that will be accessing the Win 7 box. That's just not emphasized (or even mentioned) on most of the guides that I've seen.

    Plus, of course, I'm also telling you how to fix the problem if you don't want to use passwords on your accounts.
    I've searched high and low for why my other 2 computers (win8 and XP) were denied access to win7's shared files. You are right, the requirement that other computers have a password to access win7 files is, as you say, not emphasized or mentioned often.

    I've spent many hours trying out different solutions and yours was the one that finally worked. Thanks a ton for your post.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •