Results 1 to 9 of 9
  1. #1
    5 Star Lounger
    Join Date
    Dec 2000
    Location
    Calgary, Alberta, Canada
    Posts
    707
    Thanks
    4
    Thanked 0 Times in 0 Posts
    I am preparing one of my first "from scratch" Word 2007 documents, most of the previous ones have been to reuse old Word 2003 documents and find that each new line in the document has a little black square at the start of it. I am not sure what this is, but I suspect it has something to do with the formatting. It only occurs when I start a new paragraph or bullet point, but it does not occur if the paragraph or bullet point carries over to a second or third line in the document. I would like to get rid of these, or at least hide them, or turn them off, somehow, but I would really also like to know what they are. Any insight that anyone can provide as to what they are and how to get rid of them or hide them is greatly appreciated. Thanks.

    Ron M

  2. #2
    3 Star Lounger
    Join Date
    Apr 2008
    Location
    Northridge, California, USA
    Posts
    230
    Thanks
    1
    Thanked 12 Times in 11 Posts
    Hi, Ron,

    Typically, you see a little black square to the left of a paragraph when "Keep with next," "Keep lines together," or "Page break before" has been applied to a paragraph -- or when a heading style has been applied. (You should see the square only when "Show Non-Printing Characters" is enabled.) To find out whether one of those three options has been applied, insert your cursor into one of the paragraphs that displays a square, then either (1) click the dialog launcher at the lower right side of the Paragraph group in the Home tab or (2) simply press Alt O, P. When the Paragraph dialog opens, click the Line and Page Breaks tab and take a look at the options at the top of the dialog (under "Pagination").

    If one (or more) of the options has been checked and you're sure you don't want to apply it in the current circumstances, go ahead and uncheck it, then OK out of the Paragraph dialog.

    If the options appear to be enabled by default -- that is, if they are in effect in every new blank document (which isn't typical) -- you can click to uncheck them, then click the Default button at the bottom of the Paragraph dialog. When Word asks if you want to change a setting that will affect all new documents based on the NORMAL template (or other underlying template), click "Yes." Then OK out of the Paragraph dialog.

    To hide the black squares, just turn off "Show Non-Printing Characters." You can do so either by clicking the paragraph symbol in the Paragraph group on the Home tab (it's a toggle, so one click turns the display of the non-printing characters on and another click turns it off) or by pressing the key combination Ctrl Shift * (asterisk) / Ctrl Shift 8.

    Does that help? Let us know.

    Jan
    Author, Formatting Legal Documents With Microsoft Word 2010
    and Formatting Legal Documents With Microsoft Office Word 2007

    For Word and WordPerfect tips, visit my blog at http://compusavvy.wordpress.com

  3. #3
    5 Star Lounger
    Join Date
    Dec 2000
    Location
    Calgary, Alberta, Canada
    Posts
    707
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Jan, thanks for your reply. I guess my problem is that I want to keep the setting "Keep with next", etc. When I click on the paragraph symbol in the Paragraph group, the only thing that gets "turned off" are the little dots that show the spaces between words. The actual Paragraph marks and the "little black squares" seem to stay put. Personally, I would just like to be able to turn off the "little black squares" without having to compromise any other settings. Right now, it makes for a very cluttered document, with all these "little black squares" everywhere. I will experiment with what you have given me to consider, to see if I can come up with some kind of a compromise, but right now, unless there is another way to turn them off, I am stuck with them. Good old Microsoft does it again - another undocumented feature that I don't need or want.

    Thanks for your help.

    Ron M

  4. #4
    3 Star Lounger
    Join Date
    Apr 2008
    Location
    Northridge, California, USA
    Posts
    230
    Thanks
    1
    Thanked 12 Times in 11 Posts
    If the paragraph symbols and black squares display even after you click the paragraph symbol, click the Office Button, Word Options, Display and look to see if "Show all formatting marks" is checked. If it is, uncheck it and click the "OK" button at the lower right side of the Word Options to save your changes. Note that when "Show all formatting marks" is checked in the Word Options, the formatting marks will remain visible even when you click the paragraph symbol in an attempt to hide the non-printing characters.

    As for "Keep With Next," you really don't need to use that option -- and it's probably best not to -- except when headings fall at the bottom of a page and get separated from the text that follows. If you do have a heading at the bottom of a page, be sure to select both the heading and the blank space that follows it before checking the "Keep With Next" option. Otherwise, the heading will "keep with" the blank space that follows, but the blank space will not "keep with" the line of text that comes after it. (That should become clearer when you experiment a little.)

    "Keep Lines Together" ordinarily is used if you don't want a paragraph to split across pages -- i.e., you want the whole paragraph to be on one page or the other.

    And "Page Break Before" obviously is something that you would use somewhat sparingly (only where you need to force something to start on the next page -- but typically not in situations where "Keep With Next" would do the trick).

    Let us know if turning off the "Show all formatting marks" choice in the Word Options does the trick for you. I have a feeling it will.

    Jan
    Author, Formatting Legal Documents With Microsoft Word 2010
    and Formatting Legal Documents With Microsoft Office Word 2007

    For Word and WordPerfect tips, visit my blog at http://compusavvy.wordpress.com

  5. #5
    5 Star Lounger
    Join Date
    Dec 2000
    Location
    Calgary, Alberta, Canada
    Posts
    707
    Thanks
    4
    Thanked 0 Times in 0 Posts
    "Show all formatting marks" is checked; however, when I uncheck it and click on OK, nothing happens - the little black squares are still there - and I closed and re-opened the document just to be sure(?) that the changes would take hold. If I uncheck the "keep with next", I am left with a first page with one line on it and the rest of the document moves forward to pages 2 and 3(?). Don't know what this is all about, but it is sure beginning to confuse me. It almost seems like I am missing something very obvious.

    You know, this is very frustrating to me, because I was working at a very advanced level, some would say expert level, with the previous version of Word and this new version @#$%^&*()_ makes me angry, but that is Microsoft, when you have a good thing going, find a way to screw it up and confuse everyone.

    I am not sure how to proceed - maybe I don't. Jan, thanks for your help with all this and bearing with me through this "learning" curve (I am definitely learning where a lot of the things are "hidden" in this new version). Any other suggestions are appreciated.

    Regards,

    Ron M

  6. #6
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by Ron M View Post
    "Show all formatting marks" is checked; however, when I uncheck it and click on OK, nothing happens - the little black squares are still there - and I closed and re-opened the document just to be sure(?) that the changes would take hold. If I uncheck the "keep with next", I am left with a first page with one line on it and the rest of the document moves forward to pages 2 and 3(?).
    As noted above, you almost never want "Keep with next" and you should go ahead and remove it from all paragraphs. Then they should flow naturally.

    Regarding the display of non-printing characters, there are individual checkboxes in the options for them. I don't know which one controls the little black squares (there isn't a specific checkbox for those). I personally prefer to work with tabs and paragraph marks displayed, but not spaces.

  7. #7
    3 Star Lounger
    Join Date
    Apr 2008
    Location
    Northridge, California, USA
    Posts
    230
    Thanks
    1
    Thanked 12 Times in 11 Posts
    Hi, Ron,

    Don't panic! If you uncheck "Show all formatting marks" and you're still seeing formatting marks, click the paragraph symbol in the Paragraph group on the Home tab. That symbol acts as a toggle that alternately displays and hides the non-printing characters -- unless "Show all formatting marks" (or, as Jefferson points out, any of the other choices in that section of the Word Options) is checked. When a "Show" option is checked in the Word Options, that setting takes precedence and the paragraph symbol doesn't toggle the non-printing characters off. But when the "Show" options are all unchecked, the paragraph symbol works normally to toggle the display of the non-printing characters on and off.

    Again, the key is to apply the "Line and Page Break" options thoughtfully. "Keep With Next" keeps a paragraph with the paragraph that follows; if all of the paragraphs use that setting, they will all try to stay together, which can cause problems. (Some years ago, I saw that behavior with an earlier version of Word -- I think it was Word 97 -- where a secretary was working with a document where the "Keep With Next" option somehow got applied to all of the paragraphs in the document. As a result, the paragraphs kept moving around! It sounds odd, but I saw the behavior myself. As soon as I selected the paragraphs and unchecked "Keep With Next," the offending paragraphs went back to their preferred locations in the document and all was well again.) As I mentioned before, that setting ordinarily is used to keep a heading that happens to fall at the bottom of a page with the text that follows the heading.

    With luck, this advice, and Jefferson's, should help you regain control over your document.

    Hang in there, and let us know.

    Jan
    Author, Formatting Legal Documents With Microsoft Word 2010
    and Formatting Legal Documents With Microsoft Office Word 2007

    For Word and WordPerfect tips, visit my blog at http://compusavvy.wordpress.com

  8. #8
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 28 Times in 27 Posts
    Quote Originally Posted by Ron M View Post
    If I uncheck the "keep with next", I am left with a first page with one line on it and the rest of the document moves forward to pages 2 and 3(?). Don't know what this is all about, but it is sure beginning to confuse me. It almost seems like I am missing something very obvious.
    Ron,

    As far as I know, the actual functionality of 'keep with next' hasn't changed for 2007 - it should still work the way it always has.

    Hard to tell for certain without seeing the document, but: If you turn off 'keep with next' for just the first paragraph, but leave it on for the others, that would produce the behavior you describe - where you'd be left with just one paragraph (or even just a line or two) on the first page and everything else jumps to the next page.

    Try selecting the entire document, and then turning off 'keep with next'. Then, if you really need it in specific instances, go back and reapply it only to those paragraphs that really need it. One example where 'keep with next' is appropriate and desirable is with one or two-line headings that precede a run of regular text - you'd almost always want the heading to keep with the text paragraph that follows it. That's why the built-in Heading styles default to having 'keep with next' on.

    Gary

  9. #9
    5 Star Lounger
    Join Date
    Dec 2000
    Location
    Calgary, Alberta, Canada
    Posts
    707
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Gary, that is exactly what I ended up doing...highlighting the entire document and then unchecking the "Keep with next" option and everything fell into place appropriately. When I went back to the Word Options ==>> Display and unchecked the Show all formatting Option (don't why it was re-checked because I had unchecked it before?), the little squares went away and now things seem to be working the way I had hoped that I could get them to work. At least now, I know how and where to find the "culprits" if this happens again. Gary, thanks for pointing out the default for Headings as "keep with next". I should be able to control this as required in the future.

    Thanks to you all, Jan, jscher and Gary for all your help in getting this problem resolved - well maybe not a "problem" but at least it could be called an annoying situation. Thanks.

    Regards,

    Ron M

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •