Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Canal Winchester, Ohio, USA
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have run afoul of a Windows 7 "feature". Whenever the volume control is touched, either by me or by a running app, the speaker automatically unmutes. This is a problem for me because I use my laptop for making professional presentations and I generally mute the speaker to prevent extraneous computer generated noise from detracting from the presentation. If I accidently touch the volume control on the laptop (the physical controls) or an app running in the background wants to set the volume control, I get "ding-ding-ding" in the middle of my presentation. Very unprofessional.

    I have learned from a Microsoft representative that this is "as-designed" and is an "industry standard". When asked if there was any way to configure this, via a control panel setting or registry setting, the answer was no. Apparently Microsoft has decided that this should be the standard behavior starting with Windows 7 and there is no way to disable it other than to remove the speaker/volume control drivers. I have asked that that this be revisted and the answer was that there are not enough requests for this to make it an issue. In the meantime, it is a HUGE issue for me.

    Do any of the good folks here know a way around this behavior other than removing the drivers?
    Darrel Damon

  2. #2
    3 Star Lounger jockmullin's Avatar
    Join Date
    Dec 2009
    Location
    St-Eustache,QC,Canada
    Posts
    239
    Thanks
    10
    Thanked 21 Times in 20 Posts
    How about plugging some earphones into the audio out port?
    On most systems that disables the onboard speakers.

    Jock

  3. #3
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    793
    Thanks
    3
    Thanked 27 Times in 25 Posts
    I have an earphone plug - the earphones broke so I nipped off the cable at the plug and made sure the wires inside the cable do not touch. I keep the plug in my laptop bag and plug it in whenever I am in a situation where I don't want the sound to come on accidentally.

    . Apparently Microsoft has decided that this should be the standard behavior starting with Windows 7 and there is no way to disable it
    [rant]Aren't you glad that people who have infinitely more intelligence that us poor morons are looking out for our well being and deciding how we should be allowed to use our computers?[/rant]
    I have no idea why they can't just provide an option to control this and let us decide how we want things to work. I'm a computer programmer and I know it is not that hard to provide such an option. By the way, I have used this same rant on various Linux forums, and this rant is the primary reason I avoid Apple products.

  4. #4
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Have you tried setting system sounds to No Sound and applying? (Control Panel>Sound>Sounds tab>Sound Scheme> No Sounds)

  5. #5
    Super Moderator CLiNT's Avatar
    Join Date
    Dec 2009
    Location
    California & Arizona
    Posts
    5,444
    Thanks
    128
    Thanked 495 Times in 455 Posts
    If I accidently touch the volume control on the laptop (the physical controls) or an app running in the background wants to set the volume control, I get "ding-ding-ding" in the middle of my presentation. Very unprofessional.
    This isn't the fault of the operating system, It's yours. Don't touch the volume controls.
    I don't know what you mean by "or an app running in the backgrownd wants to set the volume control".
    Please clarify this for me.
    DRIVE IMAGING
    Invest a little time and energy in a well thought out BACKUP regimen and you will have minimal down time, and headache.

    Windows 8.1, 64 bit
    Motherboard: DX58SO2*Chipset: X58 Express/Intel ICH10*BIOS: SOX5820J.86A.0888.2012.0129.2203*Processor: Intel Core i7 CPU X 990
    GPU: Nvidia GTX 580*Memory: Corsair 12 GB, 4x3@1600*PSU: Corsair HX1000*Hard drives: REVO X2 160GB*OCZ VERT X3 120GB*5 mechanical storage drives (12 TB) total.

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    Canal Winchester, Ohio, USA
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Clint Rossmere View Post
    This isn't the fault of the operating system, It's yours. Don't touch the volume controls.
    I don't know what you mean by "or an app running in the backgrownd wants to set the volume control".
    Please clarify this for me.
    "Don't touch the volume controls" is the answer I got from MS too, and that is a cop out. It would be nice to say that, in a perfect world, I would never accidently bump or touch a volume control. But since the volume control can be adjusted in any number of ways (a physical volume control wheel, software keys, accidental mouse clicks, etc), it is unrealistic to say the answer is don't touch the volume control. And besides, running apps can touch the volume control when I am not even physically near the computer (more below).

    As another said, the simple answer is to provide the end user the option. That is also the solution that a few people have asked MS to implement. Why they don't and insist that this is the industry standard is a mystery to me.

    In Windows 7 (I don't know about Vista because I never adopted it), apps can have independent control of the volume. They can set the volume level inside the running app. When they touch the volume, the speakers auto unmute. All under programatic control, not under control of the user.

    I know, the next answer is that I should have no other apps running in the background. That is also not realistic. If I wanted to go that route, I'd step back to DOS.

    So far, the most practical answer, until MS decides in it's wisdom to let the end user control the option, is the headphone jack.
    Darrel Damon

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Canal Winchester, Ohio, USA
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Byron Tarbox View Post
    Have you tried setting system sounds to No Sound and applying? (Control Panel>Sound>Sounds tab>Sound Scheme> No Sounds)
    That seems to only stop Windows from sending sounds. Other apps still control and unmute the speakers and can send sounds.
    Darrel Damon

  8. #8
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    2,378
    Thanks
    14
    Thanked 238 Times in 190 Posts
    Quote Originally Posted by Darrel Damon View Post
    That seems to only stop Windows from sending sounds. Other apps still control and unmute the speakers and can send sounds.
    If you have the speaker icon in the system tray, right-click and select "Playback devices". On that popup, click on the default device (mine is "Speakers") and select "Properties". On the next popup, click on the "Advanced" tab. Uncheck "Allow applications to take exclusive control of this device". OK your way back out.
    Create a new drive image before making system changes, in case you need to start over!

    "Let them that don't want it have memories of not gettin' any." "Gratitude is riches and complaint is poverty and the worst I ever had was wonderful." Brother Dave Gardner "Experience is what you get when you're looking for something else." Sir Thomas Robert Deware. "The problem is not the problem. The problem is your attitude about the problem. Do you understand?" Captain Jack Sparrow.
    Unleash Windows

  9. #9
    Star Lounger
    Join Date
    Dec 2009
    Location
    Kingston, ON, Canada
    Posts
    87
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have Realtek HD Audio Manager that came as part of my system so I don't know if it can be added separately.

    It resides in the System Tray as the volume control. When I open it, I am presented with bunch of audio sliders with a "Mute" button for each one. One is the master volume control and the others are for each application that might be using sound. For example, there may typically be one each for System Sounds, Windows Live Mail, Windows Media Center, and perhaps several for the browser tabs I have open. The volume and/or mute for each can be controlled separately while the Master will over ride everything.I don't believe the application will over ride these controls.

  10. #10
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    2,378
    Thanks
    14
    Thanked 238 Times in 190 Posts
    Quote Originally Posted by Chet Copeland View Post
    I have Realtek HD Audio Manager that came as part of my system so I don't know if it can be added separately.

    It resides in the System Tray as the volume control. When I open it, I am presented with bunch of audio sliders with a "Mute" button for each one. One is the master volume control and the others are for each application that might be using sound. For example, there may typically be one each for System Sounds, Windows Live Mail, Windows Media Center, and perhaps several for the browser tabs I have open. The volume and/or mute for each can be controlled separately while the Master will over ride everything.I don't believe the application will over ride these controls.
    Go through Control Panel > Sound. You should see an opportunity to select a default device (which in your case would probably be Realtek HD Audio Manager). If you highlight the default device and click on properties, it will bring up a tabbed box, one of those tabs being "Advanced".
    Create a new drive image before making system changes, in case you need to start over!

    "Let them that don't want it have memories of not gettin' any." "Gratitude is riches and complaint is poverty and the worst I ever had was wonderful." Brother Dave Gardner "Experience is what you get when you're looking for something else." Sir Thomas Robert Deware. "The problem is not the problem. The problem is your attitude about the problem. Do you understand?" Captain Jack Sparrow.
    Unleash Windows

  11. #11
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I don't believe the application will over ride these controls.
    Unless something's changed, I've always understood that apps could only invoke system sounds and could not override a master mute. Maybe if the OP could tell us which app(s) in particular is causing this issue? I don't seem to have any that will override mute speakers.

  12. #12
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    2,378
    Thanks
    14
    Thanked 238 Times in 190 Posts
    Quote Originally Posted by bbearren View Post
    Go through Control Panel > Sound. You should see an opportunity to select a default device (which in your case would probably be Realtek HD Audio Manager). If you highlight the default device and click on properties, it will bring up a tabbed box, one of those tabs being "Advanced".
    [attachment=88769:Speakers Properties.PNG][attachment=88770:Sound Properties.PNG]

    Perhaps "exclusive control" includes mute/unmute control as well.
    Attached Images Attached Images
    Create a new drive image before making system changes, in case you need to start over!

    "Let them that don't want it have memories of not gettin' any." "Gratitude is riches and complaint is poverty and the worst I ever had was wonderful." Brother Dave Gardner "Experience is what you get when you're looking for something else." Sir Thomas Robert Deware. "The problem is not the problem. The problem is your attitude about the problem. Do you understand?" Captain Jack Sparrow.
    Unleash Windows

  13. #13
    New Lounger
    Join Date
    Dec 2009
    Location
    Canal Winchester, Ohio, USA
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Byron Tarbox View Post
    Unless something's changed, I've always understood that apps could only invoke system sounds and could not override a master mute. Maybe if the OP could tell us which app(s) in particular is causing this issue? I don't seem to have any that will override mute speakers.
    Any application that changes the volume level results in an unmute. Try it yourself manually. Mute your speaker and then simply change the volume on the volume slider. When you do, the speaker will automatically unmute. Therefore, any app that causes a change in volume level will override the mute.

    The places I have seen it most are web pages that have some sort of audio coded in them. If the volume level of the audio is different than what my system is set at, it changes the volume and unmutes the speakers. I know this because I typically set my volume to zero and mute the speaker. When it gets unmuted, the volume level will be at some level above zero. Since it was at zero before entering the web page and at non-zero after going to the page, it seems that something on the page is setting a volume level.

    To be fair, it doesn't happen a lot. But it typically happens when not convenient. The only way I have found to prevent disruption is to use the dummy jack approach to silence the speakers even if they do get unmuted. That is a workaround for a "feature" that MS insists is "industry standard". Apparently, they decided it was industry standard with the release of Windows 7.

    In XP, changing the volume does NOT automatically unmute (when the apparent "industry standard" was different). All that I (and others) are asking is that MS allow us (the users of the OS) the flexibility (either through registry or some other method) to specify whether or not we want a change in volume to override the mute status. In the meantime, if anyone has a utility that will create this same effect, it would find a ready market.
    Darrel Damon

  14. #14
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    2,378
    Thanks
    14
    Thanked 238 Times in 190 Posts
    Quote Originally Posted by Darrel Damon View Post
    Any application that changes the volume level results in an unmute. Try it yourself manually. Mute your speaker and then simply change the volume on the volume slider. When you do, the speaker will automatically unmute. Therefore, any app that causes a change in volume level will override the mute.

    The places I have seen it most are web pages that have some sort of audio coded in them. If the volume level of the audio is different than what my system is set at, it changes the volume and unmutes the speakers. I know this because I typically set my volume to zero and mute the speaker. When it gets unmuted, the volume level will be at some level above zero. Since it was at zero before entering the web page and at non-zero after going to the page, it seems that something on the page is setting a volume level.

    To be fair, it doesn't happen a lot. But it typically happens when not convenient. The only way I have found to prevent disruption is to use the dummy jack approach to silence the speakers even if they do get unmuted. That is a workaround for a "feature" that MS insists is "industry standard". Apparently, they decided it was industry standard with the release of Windows 7.

    In XP, changing the volume does NOT automatically unmute (when the apparent "industry standard" was different). All that I (and others) are asking is that MS allow us (the users of the OS) the flexibility (either through registry or some other method) to specify whether or not we want a change in volume to override the mute status. In the meantime, if anyone has a utility that will create this same effect, it would find a ready market.
    I just muted my speakers, then opened a YouTube window and the speakers remain muted. If I want to hear something, I have to manually unmute my speakers. Of course, I run a far-from-normal setup, so maybe that has something to do with it.
    Create a new drive image before making system changes, in case you need to start over!

    "Let them that don't want it have memories of not gettin' any." "Gratitude is riches and complaint is poverty and the worst I ever had was wonderful." Brother Dave Gardner "Experience is what you get when you're looking for something else." Sir Thomas Robert Deware. "The problem is not the problem. The problem is your attitude about the problem. Do you understand?" Captain Jack Sparrow.
    Unleash Windows

  15. #15
    New Lounger
    Join Date
    Dec 2009
    Location
    Canal Winchester, Ohio, USA
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Try just changing your volume manually and you will see the speakers auto un-mute. You-tube was not one of the offenders that I have noticed that changes the volume level on the local machine.
    Darrel Damon

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •