Results 1 to 10 of 10
  1. #1
    New Lounger
    Join Date
    Aug 2004
    Location
    Renton, Washington, USA
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Outllook Rule Won't Autorun (2002)

    I created a simple rule in Outlook 2002 to move mail from a specific sender (email address) to a specific folder. The rule works fine when I go to the rules wizard and select "run now", but the rule will not work when I open Outlook and "send and receive" runs; the rule won't "autorun". The mail simply stays in my Inbox. Again, if I go to "run now", it works as expected. I've tried creating it with "organize" and starting from scratch in the "rules wizard". Neither creation method works. Any suggestions?

    Thank you,

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Outllook Rule Won't Autorun (2002)

    What's the exact rule? Here's a sample of one that runs automatically:

    Apply this rule after the message arrives
    with __________ in the subject
    delete it

    (I figure only spammers put 10 consecutive spaces in a subject line)

    The checkbox to the left of the rule is checked, and no prior rules halt the processing of rules.

  3. #3
    New Lounger
    Join Date
    Aug 2004
    Location
    Renton, Washington, USA
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outllook Rule Won't Autorun (2002)

    That is exactly what it looks like! Except I moved it to another folder rather than delete it. It was the first rule in the list. What I'm not sure about is if this rule doesn't run only when I *open* Outlook or if it won't run automatically when Outlook is open.The reason being is the particular sender's email has never *arrived* while Outlook is open. All I can say is it will only work if I manually run it.

  4. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Outllook Rule Won't Autorun (2002)

    Yes, I think "after the message arrives" means as mail is arriving in the Inbox. If it's there when you open Outlook, I think the rule will ignore it. Maybe there is another condition that would work better?

  5. #5
    New Lounger
    Join Date
    Feb 2001
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outllook Rule Won't Autorun (2002)

    This is a known bug in Outlook 2002 although Microsoft doesn't seem to acknowledge it yet. People in the microsoft.public.outlook newsgroup think it has something to do with the timing of when threads are started when Outlook 2002 opens. They think it retreives messages before the rules are activated. If you leave Outlook running long enough you will probably see that the rules work just fine on messages retrieved after Outlook 2002 has finished starting up.

    As a work around I had to resort to turning off automatic retreival of e-mail (Uncheck - Tools / Options | Mail Setup | Send/Receive | Schedule and automatic send/receive every [ ] minutes). Although not abvious by the wording, this also controls automatic checking when Outlook starts.

    I am hoping the latest Office service pack will fix the problem but Woody is advising to stay away from it for now.

  6. #6
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Roanoke area, Virginia, USA
    Posts
    3,729
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outllook Rule Won't Autorun (2002)

    I don't think it is fixed in the SR, but the issue is not a big problem on our exchange server, since most of our rules are server side. Because it wasn't an issue with us, i didn't check for it.

    As a partner, we've had some beta builds of the patch and have the RTM build. We haven't had any adverse affects from it.

    That said, i haven't seen the documents detailing the bug fixes and unless one of the bugs is a problem for you, there is no real rush to run out and install it. That's just plain common sense.

  7. #7
    New Lounger
    Join Date
    Feb 2001
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outllook Rule Won't Autorun (2002)

    OK, want to hear something bizzare? Yesterday I noticed that Outlook 2002 was automatically downloading my messages at startup and that the rules were working correctly. I am absolutely possitive that the last time I looked at that dialog that the box was unchecked. But now it is checked again and all the rules work even when Outlook first starts up. Perhaps if others who are having my problem try doing what I did it will somehow fix itself. I have seen stranger things happen.

  8. #8
    New Lounger
    Join Date
    Nov 2001
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outllook Rule Won't Autorun (2002)

    Hmm...yes I'm suffering the same symptoms. I've switched off the automatic checking for mail. I'll wait to see if this problem does sort itself. It's quite annoying splashing out so much for a new suite to find out it has such minor (yet irritating) glitches. If it's not sorted out then what's the point in wasting time creating rules? I'm off now to see if I can find a fix for that annoying request for your password every time outlook starts and tries to download mail!

  9. #9
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outllook Rule Won't Autorun (2002)

    I have a very vague suspicion that selecting another folder forces the rules to work first time - i.e. my Outlook is set to open in Inbox, if I click to select another as soon as downloading starts, the rules do work.

    Otherwise, password? These may help:

    <A target="_blank" HREF=http://support.microsoft.com/default.aspx?scid=kb;EN-GB;q290684&GSSNB=1>OL2002: The Save Password Setting Is Not Saved When You Connect to a POP3 Server (Q290684)</A>

    <A target="_blank" HREF=http://support.microsoft.com/default.aspx?scid=kb;EN-GB;q301475&GSSNB=1>OL2002: User Is Prompted for Password That Is Already Saved (Q301475)</A>

    <A target="_blank" HREF=http://support.microsoft.com/default.aspx?scid=kb;EN-GB;q287532&GSSNB=1>OL2002: How to Configure Internet E-mail Accounts (Q287532)</A>

  10. #10
    New Lounger
    Join Date
    Feb 2001
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outllook Rule Won't Autorun (2002)

    I think I may have noticed the same type of thing. But who wants to have to remember to quickly click on another folder every time they start outlook? I had previously stated that the rules were working again but that turned out to only be temporary. Now it seems that it ignores the rules for the first few messages and then applies them for the rest. It really leads me to believe that the person who theorized that it was a timing issue may be correct.

    I do have a dual 1GHz PIII system so maybe some things are happening faster than other things expect them to. However, good programmers would not depend on the timing of independent threads. A good programmer would make sure one process had finished before starting another, dependent process. I think I have decided to go back to Outlook 2000 SP-1a as recommended by Woody. I am about to give up on Windows XP as well, so I will just reinstall them both.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •