Results 1 to 7 of 7
  1. #1
    3 Star Lounger
    Join Date
    May 2002
    Posts
    253
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Don't know if this is an internet, Windows 7 or Outlook problem. I've just switched to a new Windows 7 x64 bit computer. Each time I now open Outlook I get this Internet Security Warning "This server you are connected to is using a security certificate that cannot be verified. The target principal name is incorrect. View Certificate and Do you want to continue using this server. I click Yes, and all is OK until the next time I close and reopen Outlook. What's going on. I use ATT-Yahoo.

    kdoc

  2. #2
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Do you get this with all sites or just a couple of sites? I've gotten this a few times, but on sites I do not normally go to. I would think this has to be a setting in IE. Have you tried FF to see if it continues to occur with another browser?

    By the way, perhaps this should be moved to IE or perhaps Win 7 forum. A moderator should be able to do this.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  3. #3
    3 Star Lounger
    Join Date
    May 2002
    Posts
    253
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It' occurs with Outlook (opening it), not with browsers.

    kdoc

  4. #4
    5 Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, CA
    Posts
    828
    Thanks
    4
    Thanked 38 Times in 34 Posts
    What you want to do is install the security certificate on your PC. There are a few ways I can think of to do this (I can't give a definitive answer because I haven't run into this exact error).

    It look like part of the error message has a "View Ceritificate" link. If you click on that, one of the options on the resulting dialog should be to download and install the ceritficate. Try that and see if the problem goes away.

    If not, try this: Does ATT-Yahoo have a web site you can use to access your email? If so, try going there with IE. Hopefully you will get the same security exception, but IE will give you the option of downloading and installing the certificate.

  5. #5
    3 Star Lounger
    Join Date
    May 2002
    Posts
    253
    Thanks
    0
    Thanked 0 Times in 0 Posts
    There is a button, to export file, but when in the wizard to do so I'm first asked to decide on the format (the default is DER encoded binary x509 (.CER), but then it asks me for the file name (and allows me to Browse for it. I don't know what to do with that.

    So then I went to IE (I normally use Moxilla, but did as you suggested), and went into ATT, receiving and sending an email--to no avail--it didn't ask me for the certificate. this must be something with Outlook 2007 and the newer Windows 7 x64, I'm guessing.

    kdoc

  6. #6
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by kcohn View Post
    I use ATT-Yahoo.
    First, check with Yahoo or AT&T to make sure you have the latest server names, because they sometimes change. For example, in this thread: Outlook 2007 Security warning - Windows Software.

    Should you need to import a certificate, this article describes the process: The Official SBS Blog : You Receive a “Target Principal Name is Incorrect” Certificate Error in Outlook 2007 When Connecting to Either POP3 or IMAP4 on SBS 2008.

  7. #7
    3 Star Lounger
    Join Date
    May 2002
    Posts
    253
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Here's how I just solved it. JSHER'S second suggestion seemed in the right direction, but I couldn't understand the link. And I tried changing the incoming mail, as also suggested above, but all that didn't do it. So I then remembered an old trick that ATT once taught me when I couldn't get mail to work. I uninstalled the mail account, and then reinstalled it. Well so far, it's working like a charm, though I haven't rebooted yet. Guess I'll do that now, and if the certificate request is still gone I won't report back, and we can consider this a workable solution!!

    Thank you all for your support

    kdoc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •