Results 1 to 8 of 8
  1. #1
    New Lounger
    Join Date
    Apr 2010
    Location
    Wales, Uk
    Posts
    16
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I'm having a problem at present which is slightly irritating rather than serious.

    I have my tv connected to my pc via a vga cable. The tv is my secondary display. This works fine when I want to watch a program I have recorded on my pc through the television.

    However if I allow my computer to hibernate, when I wake it any open applications have migrated to the television. Initially I was laboriously dragging them all back on to my pc monitor where they stayed until the next time it hibernated. Lately, I have discovered that if I open the Nvidia Control Panel( I have a Nvidia Geforce 7300 GS graphics card), the open windows return to the monitor without further ado. I don't have to do anything in the control panel; simply opening and closing it does the trick.

    The settings I have both in the nvidia and windows own settings are that the tv is the secondary display.

    Anyone know of any way I can stop the windows migrating in the first place?

  2. #2
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    You do not mention which version of Windows you have. This could make a difference in T/S suggestions.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  3. #3
    New Lounger
    Join Date
    Apr 2010
    Location
    Wales, Uk
    Posts
    16
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Sorry, should have said. I am running Windows 7 Home Premium.

  4. #4
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Is the PC allowed to hibernate while the second monitor (TV) is still enabled to display the contents of your PC? If this is so, perhaps the settings for this are saved as all other settings are during hibernate. Hibernate is a situation whereby all apps running, all data presently in use, etc are saved to memory in a large file called hiberfil.sys in your root directory (C:/Windows). When the PC is awakened all settings, apps etc, that were in use before hand will be brought back up. This does seem a logical explanation. You may have to disable the second monitor fuction before letting the PC hibernate.

    Just so you know that hiberfil.sys file is generally 3 GB or larger (very large). If you disable hibernate and use sleep instead, you can delete this very large file to save space. You can use this method to enable or disable hibernate.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  5. #5
    New Lounger
    Join Date
    Apr 2010
    Location
    Wales, Uk
    Posts
    16
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Yes, I am leaving the tv enabled tho' it is switched off. However I think I am letting the pc sleep rather than hibernate, as I do not have hiberfil.sys in my Windows drive. It looks like I either disable the second monitor when I'm not using it or use the current workaround of opening the nvidia control panel.

  6. #6
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Quote Originally Posted by Steph Needham View Post
    Yes, I am leaving the tv enabled tho' it is switched off. However I think I am letting the pc sleep rather than hibernate, as I do not have hiberfil.sys in my Windows drive. It looks like I either disable the second monitor when I'm not using it or use the current workaround of opening the nvidia control panel.
    You may not be able to see the hiberfil.sys file unless you have selected to show hidden system files and unchecked Hide protected operating system files. To do this go to Control Panel/Folder Options, View Tab. Check Show hidden files, folders and drives and uncheck Hide protected operating system files (Recommended). This should allow you to view all files on your PC. Unless you have disabled hibernate it is enabled by default. When you disable it there will not be an option to Hibernate on the Start Button, Shutdown.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  7. #7
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    South of the North Pole
    Posts
    919
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Somewhere in the Nvidia control panel settings for dual monitors there may be (depends on the version of the control panel in use) a setting to disable auto-detect displays or for force detect only. Even though you have the one set as secondary, upon waking its detecting that one first, not the primary and transfering to the one detected. If you switch off auto-detect it won't transfer (presumably).

  8. #8
    New Lounger
    Join Date
    Apr 2010
    Location
    Wales, Uk
    Posts
    16
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks for suggestions. I have hibernate disabled. (I checked.) So the migration is happening during sleep. I have also noticed that if sleep duration is less than approx 30 minutes, when I wake the pc, the windows are still on my primary monitor, so it only seems to happen during a longer sleep period.

    I had a look at the nvidia panel and I don't see an option to auto-detect. As you say, Byron, it appears to detect the tv first. I am fairly resigned to living with it as it isn't a huge problem and there doesn't appear to be an obvious solution.

    Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •