Results 1 to 2 of 2
  1. #1
    New Lounger
    Join Date
    Jan 2010
    Hackettstown, NJ
    Thanked 0 Times in 0 Posts
    I wasn't quite sure where to post this, so I chose this forum. I'm running Windows 7 Home Premium 64 bit. I've installed Virtual Box Version 3.2.0 r61806. I've installed Windows XP Pro as a guest in Virtual Box. Everything is working fine except for one thing. I can't figure out how to access my USB flash drives from the guest machine.

    In the Settings window of the VirtualBox software I have the two check boxes related to USB checked: Enable USB Controller and Enable USB 2.0 (EHCI) Controller. Yet after I start the XP guest machine and insert a flash drive, the guest software does not grab the device, the host software grabs it. I must be missing some basic trick that tells the host system to let the guest system have the device.


  2. #2
    5 Star Lounger
    Join Date
    Dec 2009
    Milwaukee, WI
    Thanked 64 Times in 52 Posts
    I got burned by this the first time I used Virtual Box. First, go to the Devices menu and install the Guest Additions. This installs the drivers needed to allow the pass through of the USB traffic. After you plug in your USB device, go to the Devices menu in Virtual Box and select USB Devices. You should see your device listed there. Simply click on it to enable it in your VM. The first time you do this, your Win7 host will install a USB driver for Virtual Box, in turn your VM will also install a driver. Be patient, it can take a minute or two. If you go back to the listing under the devices menu, you will see a check mark. To give the device back to Windows 7, simply uncheck the device.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts