Page 1 of 2 12 LastLast
Results 1 to 15 of 25
  1. #1
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I need help with a Word problem, please. Iím using Word 2000 in Office 2000, but I have to reason to believe that the same problem exists in later versions of Word.

    Iím Editor-in-Chief of an international scientific publication. Quite commonly, I will receive a Word document, most usually from an Asian country, in which the leading (the spacing between lines) is significantly greater that the standard single line spacing in the American version of Word. To be specific, I often receive Word documents from countries outside the US in which the font is Times New Roman, 12 pt, with Paragraph spacing Before and After set to 0 pt and Line spacing set to single, but in which the actual line spacing (the leading) is a significant fraction of a point larger than for the same text with the same settings in a US version of Word. As noted, this seems to happen most often with documents from Asian countries. I have tried changing all of the settings I can find to get the leading to match the US leading, without success. I have found only two ways I can get the leading to be set back to the US Word leading. The first is to save the Word document as text (e.g., MS-DOS text), and then import it back into a new Word document and reapply all of the formatting (which, for a document with a lot of equations and formatting, is a real pain!). The second method is to copy "chunks" of text from the foreign Word document into a new US Word document, being careful not to copy too much (less than a page long seems to be the maximum that works) and being careful not to copy the space (and thus the hidden formatting information) at the end of the last paragraph (copying too much or copying that hidden formatting information will cause the wider leading to show up in the new document). Unfortunately, this second method doesnít always work. No amount of changing styles; nor any of the options I've tried under Tools...Options...Compatibility; nor any of the options under Format...Font or Format...paragraph seem to have any effect on this.

    I have observed the increased leading coming from countries using the Asian versions of Word, but generally not from European or Middle Eastern versions. My conjecture is that the default for single space in Times New Roman in the Asian version of Word involves larger leading than for the US version of Word. Regardless, I can't seem to find any way of correcting the problem. I would greatly appreciate any help or suggestions. Thank you!

  2. #2
    2 Star Lounger
    Join Date
    Mar 2001
    Location
    California, USA
    Posts
    136
    Thanks
    0
    Thanked 0 Times in 0 Posts
    If you set the paragraph line spacing to "exactly" say 12 points, instead of single spacing, does that work for you?
    Are you seeing this problem in every line? Or just the lines wth equations and super or subscripts?
    J. Till

  3. #3
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    Can you post a sample document that demonstrates the problem? Remove any personal or company specific information in the document before you post it.

    What happens if you select all and change the font to something other than Times New Roman? What happens if you select all and press Ctrl-Space and Ctrl-Q. I assume the text is not in a table cell (in which case the table style settings can override the style settings).
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  4. #4
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    You are right, it does have to do with Asian fonts. Because I haven't had that problem for a long time, my memory is faint. I think you have to disable Asian fonts in the font dialog. (If they aren't already enabled, you won't see the choice to disable them.) Perhaps someone with more experience can answer better.

    Pam
    Pam Caswell

  5. #5
    4 Star Lounger
    Join Date
    Jan 2010
    Location
    Chichester, UK
    Posts
    401
    Thanks
    1
    Thanked 10 Times in 9 Posts
    I wonder if enabling Asian fonts, opening and saving the document, then doing the reverse will switch off the change in leading.

    From your description, the hidden trigger must be in the end of section breaks and/or end of document (final) paragraph marks. If we could download a two section example doc it may help.

  6. #6
    4 Star Lounger
    Join Date
    Jan 2010
    Location
    Chichester, UK
    Posts
    401
    Thanks
    1
    Thanked 10 Times in 9 Posts
    I've just thought...

    Under Compatibility options, there is a setting 'Don't add leading (extra space) between rows of text'. There's also some other 'Asian' rules regarding line breaks and leading. Just maybe one of them may resolve the problem?

  7. #7
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    You might get some useful information from this site:

    Word features for East Asian languages - Word - Microsoft Office Online

    Pam
    Pam Caswell

  8. #8
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I appreciate everyone's thoughts. I've appended an example document, containing a single paragraph with the problem I'm describing, to this post. I'll try to answer the questions raised so far:

    1. Yes, the problem is seen in every line. Setting the paragraph line spacing to an "exact" value would remove the problem. However, the text often contains inline equations and other items that require automatic adjustment of the leading, so that isn't a desirable solution.

    2. Changing the font doesn't affect the leading. Selecting all, pressing CTL-Space and CTL-Q doesn't change it, either. No, the text is not in a table cell.

    3. Two responders talked about enabling and disabling Asian fonts. How is that done, please?

    4. Checking "Don't add leading (extra space) between rows of text" under Tools...Options...Compatibility doesn't fix the problem.

    Again, I really appreciate your help!
    Attached Files Attached Files

  9. #9
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by RossStone View Post
    2. Changing the font doesn't affect the leading. Selecting all, pressing CTL-Space and CTL-Q doesn't change it, either. No, the text is not in a table cell.
    When I check the Normal style I see this --

    Normal
    Font: (Default) Times New Roman, 10.5 pt, (Asian) Chinese (PRC), (Other) English (U.S.), Justified, Line spacing: single
    -- but no obvious way to edit out "(Asian) Chinese (PRC)". I saved as RTF and looked at the tags, and there do appear to be a lot of Far East-related tags. However, I don't know whether any simple Find-and-Replace operations (viewing the RTF file as plain text) will strip those out.

  10. #10
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Jscher2000, I really appreciate this information. What version of Word are you using? When I look under Format...Styles at the Normal style in the Example.doc in Word 2000, I do not see the information about "(Asian) Chinese (PRC)" (the rest of the entry is the same as you have - and the 10.5 pt is puzzling, because Word thinks it is 12 pt). This certainly does suggest that my guess about there being a different version of the Times New Roman font involved might be correct. However, it can't be quite that simple, because changing the font (to another font on my computer, which should be a Western version of the font) doesn't change the leading. Assuming you're using a later version of Word, could you please try such a change, and see if the leading changes under your version?

    I wonder if the "single" setting for Line Spacing under Format...Paragraph is somehow being affected by the information that an Asian version of the font was involved?

    I must admit that I'm getting pretty desperate about this problem. It has cost me untold tens of hours of grief over the years. It used to be tolerable, because I wasn't receiving that many papers with the problem. However, the number of contributions from Asia has increased significantly (which is great), and most of them have this problem (which isn't so great).

    In looking back through the replies so far, I noted that two posters (Pam Caswell and Terry Farrell) suggested possibly disabling Asian fonts. How is that done, please? I couldn't find any reference to this in Word Help.

    I really appreciate everyone's help. Thank you.

    Ross

  11. #11
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    I have been exploring your sample file and can see how annoying this can be for you. I have also experimented in trying to remove the Asian language setting from the text but discovered that a one line macro can be used to remove the line spacing issue independent of the Language setting. In Word 2010 Beta the following line works to get the same spacing as other non-tainted documents.
    Code:
    ActiveDocument.Styles("Normal").ParagraphFormat.DisableLineHeightGrid = True
    If you used this, would you still need to remove the Asian font setting from the style?
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  12. #12
    4 Star Lounger
    Join Date
    Jan 2010
    Location
    Chichester, UK
    Posts
    401
    Thanks
    1
    Thanked 10 Times in 9 Posts
    That works for me too. Just open the document, select Alt+F11 and copy the VBA into the Immediate Windows (use Ctrl+G if you cannot see the Immediate Windows) and press Enter.

    This is really a weird bug!

    I also suggest that you remove the direct formatting (Ctrl+Spacebar) and apply normal style again (presuming that it is set for TNR 12pt on your PC).

  13. #13
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Andrew, Terry: THANK YOU! The VBA command you suggested did indeed restore the "normal, non-Asian" line spacing in Word 2000 for the document! That's the first progress that has been made on this problem in the several years over which I've been searching for a solution!

    However, when I then copy my Normal style into the document, the greater spacing returns. I even tried applying the VBA command, saving the document, closing Word, reopening Word and the document, and then applying Normal (which is set to TNR, 12 pt (English, US)). Part of the strangeness is that the Normal in the original document (with the wider spacing) is set to 10.5 pt, even though the font shows up as 12 pt when you select it and look at the setting under Font. I can probably work around not being able to apply the style I want, but I wonder if you have any ideas on how to solve this added bit of strangeness.

    Thanks again!

    Ross

  14. #14
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Quote Originally Posted by RossStone View Post
    Andrew, Terry: THANK YOU! The VBA command you suggested did indeed restore the "normal, non-Asian" line spacing in Word 2000 for the document! That's the first progress that has been made on this problem in the several years over which I've been searching for a solution!

    However, when I then copy my Normal style into the document, the greater spacing returns. I even tried applying the VBA command, saving the document, closing Word, reopening Word and the document, and then applying Normal (which is set to TNR, 12 pt (English, US)). Part of the strangeness is that the Normal in the original document (with the wider spacing) is set to 10.5 pt, even though the font shows up as 12 pt when you select it and look at the setting under Font. I can probably work around not being able to apply the style I want, but I wonder if you have any ideas on how to solve this added bit of strangeness.

    Thanks again!

    Ross
    I suspected that that would happen. Remember, the Asian font is specified in the normal for that document. Even the clear all formatting, supposedly leaving only plain text, of W2010 doesn't clear the Asian font or language. But I think I found something that does. I used the organizer to overwrite the normal paragraph style in the document with one from my normal.dot (m). I suspect any clean normal style would do. Changing normal did not change the grid, so I ran the macro as well.

    Between the two you should be good to go.

    Pam
    Pam Caswell

  15. #15
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    Good to hear we have made some progress. The following code is much more heavy duty than the test one liner and should be much more effective on your entire document. Note that you may need to re-run it anytime you import or copy content and/or styles from other documents.
    Code:
    Sub temp1()
      Dim aSty As Style, aPara As Paragraph
      For Each aSty In ActiveDocument.Styles
        If aSty.Type = wdStyleTypeParagraph Then
          aSty.ParagraphFormat.DisableLineHeightGrid = True
        End If
      Next aSty
      For Each aPara In ActiveDocument.Paragraphs
        aPara.Format.DisableLineHeightGrid = True
      Next aPara
    End Sub
    Andrew Lockton, Chrysalis Design, Melbourne Australia

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •