Results 1 to 11 of 11
  1. #1
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have successfully installed and gotten running Windows XP in compatibility mode under 64-bit Windows 7 Ultimate. However, XP applications and Windows Explorer can only see the Documents and Settings folder on the C: drive on the Windows 7 machine. They cannot access other files and folders on the C: drive. Is there some way to remedy this?

    What Im trying to do is to run LapLink Gold 12 under XP on the Windows 7 machine in compatibility mode (until a Windows 7 version becomes available). I have LapLink working fine in this mode, and I can transfer files both ways between the Windows 7 machine and an XP machine over the LapLink USB cable. However, I cannot access any files or folders with LapLink on the Windows 7 machine other than those in Documents and Settings. Any help would be greatly appreciated.

  2. #2
    3 Star Lounger jockmullin's Avatar
    Join Date
    Dec 2009
    Location
    St-Eustache,QC,Canada
    Posts
    239
    Thanks
    10
    Thanked 21 Times in 20 Posts
    Hi Ross

    I'm uncertain what you mean by "XP in compatibility mode". I use Win 7 XP mode, which is real XP running in a virtual machine under Win 7.

    If that is not what you are using, pls disregard this post because it is likely inappropriate.

    However, if you are running XP Mode, the reason you can't access the Win 7 C drive directly (except in Explorer) is because the XP mode virtual machine acts like a separate machine networked to the Win 7 machine. And, in order to access a drive over this "network" it has to be shared. So in order to do what you want you would have to share the C: drive by running Win 7 explorer as supervisor. Then you can map a network drive to it in the XP virtual machine.Then laplink should be able to see it using the mapped drive letter.

    Note that sharing your C: drive is discouraged because it is a security risk. However if you really want to do it will work.

    Jock

  3. #3
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Jock: Yes, I'm running XP in a virtual machine under Windows 7. I believe Microsoft refers to this as "compatibility mode" in some of its literature. It sounds like what you are proposing - in terms of mapping the C: drive as a network drive - would accomplish exactly what I need. Please forgive my ignorance, but could you please give me step-by-step instructions on how to do that in XP in the virtual machine (or point me to such instructions)? I really appreciate your help. Thank you!

  4. #4
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    There are many links available with a simple Google search. This link is just one.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  5. #5
    3 Star Lounger jockmullin's Avatar
    Join Date
    Dec 2009
    Location
    St-Eustache,QC,Canada
    Posts
    239
    Thanks
    10
    Thanked 21 Times in 20 Posts
    Hi Ross

    There are 2 major steps involved:

    1. Sharing the Win 7 C: drive, on the Win 7 desktop
    - Open "Computer"
    - Right click on C: Drive
    - Go down to "Share with ..." and click on Advanced Sharing
    - Click on Sharing tab
    - Click on Advanced Sharing button
    - Put a checkmark in "Share this Drive" and optionally give it a share name (defaults to C
    - Click apply and X your way out.

    2. Mapping a drive to the share just created on the XP desktop
    - Click on Start/Run and type in "explorer" and hit enter. Explorer opens
    - Click on Tools, then on Map Network Drive ... The Map Network Drive dialog opens
    - In the "Drive" box, pick a drive letter from the dropdown list which you want to use to refer to the Win7 C: drive
    - Click on the "browse" button to the right of the folder box. The Browse For Folder dialog opens.
    - Expand Microsoft Windows Network, and your local workgroup and find the name of the Win7 machine in the list
    - Expand the Win7 machine and you should see the share name for the Win7 C: drive you assigned in step 1. Select it & click OK
    - Now the Folder path should be filled in when you are returned to the Map Network Drive dialog
    - Put a checkmark in Reconnect at Logon so this mapping will be re-established automatically at startup
    - If the user credentials for the XP machine are different from those on the Win 7 machine, click on the "different user name" link and fill in a name and password which are valid on the Win 7 machine.
    - Click on finish, and a window should open up showing the contents of the Win7 C: drive.

    That should do it. Note that your rights on the root of the C: drive and its subfolders will be those of the credentials you supplied.

    Jock

  6. #6
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Jock, Ted: Thank you both VERY much! I'll go try it.

    Ross

  7. #7
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I tried this, and it appears to have worked. I'll give it the "acid test" with LapLink between two computers this evening.

    Ross

  8. #8
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Jock: I'm sorry: I wrote too soon. I followed the steps under 1 without a problem. I then (mistakenly) followed the steps under 2 on the Win 7 machine (of course, I had to improvise a bit to find Map Network Drive). While that resulted in a mapped network drive that I could see in Windows Explorer in the Win XP virtual machine, it did not result in LapLink being able to find that networked drive. Once I realized my mistake I started over. I "un-shared" the C: drive in the Win 7 machine. I then went through Step 1 again, without a problem I then went through Step 2 on the Windows XP virtual machine. When I got to the point where I was supposed to expand Microsoft Windows Network and the local working group, the local working group wouldn't expand. I therefore could not see the name of the Win 7 machine, and at that point, I was done.

    Do you have any suggestion? I appreciate your help.

    Ross

  9. #9
    Lounger
    Join Date
    May 2010
    Location
    San DIego, CA, USA
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    One other question, please, just to be sure. I will want to undo the sharing of the C: drive on the Win 7 machine before I connect it any external networks, for obvious security reasons. If I go through step 1, unclick the "Share this drive," and Apply and OK my way out, have I properly "undone" everything?

    Thanks.

    Ross

  10. #10
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Ross,

    That should effectively stop the sharing on your C Drive (Win 7). You should be able to choose to only share with other users on your network. This should effectively block users out of your network from accessing your PC. if you search for advanced sharing, Start, Search, Advanced Sharing, Manage advanced sharing settings, this gives further control to how you share your PC on your network.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  11. #11
    3 Star Lounger jockmullin's Avatar
    Join Date
    Dec 2009
    Location
    St-Eustache,QC,Canada
    Posts
    239
    Thanks
    10
    Thanked 21 Times in 20 Posts
    Hi Ross

    It sounds like your XP mode is not set to use the real network adapter.

    To check this:

    - shut down the XP mode virtual machine
    - on he Win 7 desktop, click on start and in the search box type "windows xp mode" (without the quotes), but don't hit enter.
    - in the list of results that appears, under files, look for "Windows XP Mode.vmcx". Point to it and right click, left click on "settings"
    - in the XP mode settings dialog, click on "Networking" on the left side. This should show the list of adapters in the right hand pane, which on most systems only has 1 adapter. Note the name of the adapter currently in there. It should be the real name of your physical network adapter, not Internal Network or Shared Network NAT.
    - assuming it is not your real network card, use the dropdown arrow and select the real one from the list and click on OK
    - restart the XP mode virtual machine and it should now see your network, assuming other network settings (IP address etc) are set to auto.

    Here is a screenshot of how it appears on my system:

    [attachment=88912:screenshot.jpg]

    Jock
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •