Results 1 to 12 of 12
  1. #1
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    509
    Thanks
    4
    Thanked 1 Time in 1 Post
    My client is requiring me to use Word 2007 instead of old familiar Word 2003, and I've hit a bit of weirdness that I can't get around.

    I've defined a style which includes "numbered list" and has different indents than a default numbered list. When I start a new list and reset the numbering to 1, it also resets the indents to the default! Reapply the style, and it sets the indents correctly but also resets the numbering to the next number after the previous list.

    Word 2003 has some weirdness in this area but it's easily avoided. In Word 2007 it seems unfixable.

    How do I deal with this?

    Later -- I noticed another problem that seems even more bizarre.

    Word is ignoring the before/after paragraph spacing in the style definition.

    The style definition says "before 0 pt, after 9 pt." When I assign the style to a paragraph, the paragraph says "before 0 pt, after 0 pt." I can change that... but there seems to be no way I can set it automatically.

    This looks like what I'd call a bug, but it's probably something that Microsoft, in its infinite obtuseness, did on purpose. :-(

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Quote Originally Posted by jsachs177 View Post
    I've defined a style which includes "numbered list" and has different indents than a default numbered list. When I start a new list and reset the numbering to 1, it also resets the indents to the default! Reapply the style, and it sets the indents correctly but also resets the numbering to the next number after the previous list.
    I reproduced this problem just as stated. I tried several adjustments and nothing worked. Then I noticed one of the little "smart tags" next to the 1st item in the 2nd list after reapplying the style. I clicked this and selected "Restart Numbering". From that point on when I restarted the numbering with the normal right-click menu it did NOT change my indenting to the default but kept it as I has set in the style. YMMV.

    The style definition says "before 0 pt, after 9 pt." When I assign the style to a paragraph, the paragraph says "before 0 pt, after 0 pt." I can change that... but there seems to be no way I can set it automatically.
    I could not reproduce this problem, sorry.

    I hope this helps.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    3 Star Lounger
    Join Date
    Apr 2008
    Location
    Northridge, California, USA
    Posts
    230
    Thanks
    1
    Thanked 12 Times in 11 Posts
    As for the issue of Word ignoring the before/after spacing, when you go into the style definition and open the Paragraph dialog, is the checkbox labeled "Don't add space between paragraphs of the same style" checked? If so, uncheck the box, make sure to select the "New documents based on this template" radio button, and click "OK" to save your modifications.

    Both Word 2007 and Word 2010 have this new "Don't add space between paragraphs of the same style" option. Many people are unaware that it is in effect, which can cause the sort of issue that you're experiencing.

    Let us know if that helps.

    Sorry so brief--on my way out the door.

    Good luck!

    Jan
    Author, Formatting Legal Documents With Microsoft Word 2016,
    Formatting Legal Documents With Microsoft Word 2010​,
    and Formatting Legal Documents With Microsoft Office Word 2007

    For Word and WordPerfect tips, visit my blog at http://compusavvy.wordpress.com

  4. #4
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    A couple of other things to take a look at:

    If you defined your numbered style as a new style, make sure you did not base it on any existing numbered style - you should always base new numbered styles on 'Normal' style. Basing a new numbered style on an existing numbered style can create some odd dependencies, so it's best avoided.

    Also, to check the indents, right-click in any paragraph to which you have your numbered style applied, and click on the Adjust List Indents option - this will display an "Adjust List Indents" dialog - this is the most reliable way to set list indents in Word 2007.

    Gary

  5. #5
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    To add to what Gary says, you can prevent the problem in your current documents by clicking on a number to "select" all the numbers in the list (gray shading--the actual number selected will also have the blue selection shading), right click, and from the flyout menu, click adjust list indents. Set the indents to match those you set in the paragraph style. After that, changing the number value won't seem to affect the paragraph indent, even for new paragraphs in that style.

    If you don't want to have to do that in the future, create a multilevel list (only one level is OK, & it could either be a part of or separate from heading numbering, for instance) in your template. Set the indents in the list and link the number level to an unnumbered and un-indented paragraph style.

    Pam
    Pam Caswell

  6. #6
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    509
    Thanks
    4
    Thanked 1 Time in 1 Post
    RetiredGeek: thank you, but unfortunately I wasn’t able to reproduce any of the things you reported.

    I haven't encountered smart tags before. I found an explanation of them on Microsoft.com, but it didn’t seem to relate to your description. It says that they’re marked with a purple dotted underline, but Word didn’t display any such marker (or any other marker) when I reapplied the tag style you suggested. Nor did it do so when I tried to reproduce the example in M$’s article (a text string which Word recognizes as a person’s name and automatically marks with a smart tag). I found a “Show smart tags” option in the Word Options > Advanced dialog, but it was already enabled. Turning on “display all formatting marks” made no difference.

    Any ideas how I might make it work for me the way it worked for you? If not, I’m afraid the mystery is only compounded.

    janbphd: You were right, the “don’t insert space between paragraphs with the same style” option was set. Why it was set for this style and not others remains a mystery. But I’ll know what to look for in the future.

    Gary: the style is based on Normal. The “Adjust Line Indents” dialog is interesting, but not what I need. The problem is not how to patch up the first entry in each list so that it looks right; it's how to make numbered lists work nicely so that each list doesn’t have to patched.

    Pam: that seems like a rather involved solution for a simple problem – too involved to try now, but I’ll try it the next time I need a list.


  7. #7
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Quote Originally Posted by jsachs177 View Post
    RetiredGeek: thank you, but unfortunately I wasn’t able to reproduce any of the things you reported.

    Pam: that seems like a rather involved solution for a simple problem – too involved to try now, but I’ll try it the next time I need a list.
    Forgive me. I'm usually thinking of long term or user friendly solutions, so I don't mind an "involved" effort for me (I can usually figure a way to automate it) if the result is a stable document and fewer problems for users. Still, my first suggestion is pretty simple: Right click on the first list number in your style and set the indent to match the indent setting in the style. Here's another: use one of Word's built-in list number styles with an indent that is close to what you want and don't modify its indent.

    Good luck,
    Pam
    Pam Caswell

  8. #8
    3 Star Lounger
    Join Date
    Sep 2001
    Location
    Jakarta, Indonesia
    Posts
    274
    Thanks
    3
    Thanked 9 Times in 9 Posts
    I have long experienced a similar problem, to the extent that I have given up on automatic numbering in Word. If I try to Restart at 1, it ALWAYS changes the indent from 7.5mm to 6.3mm.

    One thing I note is that the Style is defined as follows:

    Font: 11 pt, Indent: Left: 0 mm, Hanging: 7.5 mm, Don't add space between paragraphs of the same style, Tab stops: 7.5 mm, Left, Numbered + Level: 1 + Numbering Style: 1, 2, 3, … + Start at: 1 + Alignment: Left + Aligned at: 0 mm + Indent at: 6.3 mm, Style: Quick Style, Based on: Normal

    I do NOT add the "+ Indent at: 6.3 mm"; this is automatically added when I add the numbering to style. I do not know why; I cannot change it; as usual it seems that Word 'knows better' than I do about what I want.

    I seem to remember that in Word 2000 I could get rid of the automatic assumption that my indents were 'imperial' based, with fractions of 25.4mm always used by default. I have not yet been able to find the setting which allows me to change that to a decimal metric base (fractions of 10mm) as I'm sure I could with the previous version.

    As I say, I have long given up using automatic numbering in styles, but I'd sure like to find a way to make use of this very basic functionality...

    Chris

  9. #9
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    509
    Thanks
    4
    Thanked 1 Time in 1 Post
    Pam, unless I misunderstand what the procedure you described, it has to be applied to each individual list, including each list that I create in the future. That does not strike me as either a long-term solution or a user-friendly one.

    I want the style to apply as it's defined, without mysterious side effects. That doesn't seem like a requirement that should be difficult to satisfy. I'm still hoping to find a way to do it.

  10. #10
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    jsachs,

    If you open the template on which you base new documents, and use Adjust List Indent on the style that has numbering associated with it, that change should 'stick', and you should then get correct numbering indentation for all future documents created from that template - that's why Pam is saying it's worth taking the time to fix it (in the template) now, to avoid the problem in the future.

    Gary

  11. #11
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    Chris,

    Automatic numbering in styles really can be reliable, if you set it up a certain way (that is not exactly intuitive).

    What's going on in the case you describe, is that you've set the hanging indent and tab setting (at 7.5 mm) for the style, and this is conflicting with the 6.3 mm indent which is built in to the numbering list you've associated with the style.

    The trick to getting this to work right: when you first define your new numbering style, do not define any hanging indent or tab settings. Once you've associated the numbering you want, with that style, do the following: apply the numbered style to a paragraph in the document (or template if you're creating a template). Right-click and select 'Adjust List Indents'. In that dialog, you will see places to set the number position, the text indent (which is equivalent to the paragraph hanging indent setting in this case), and tab setting. Set the text indent and tab values to 7.5 mm, in that dialog.

    If you then go back and look at the definition of the style, you should see this:

    Font: 11 pt, Indent: Left: 0 mm, Hanging: 7.5 mm, Don't add space between paragraphs of the same style, Tab stops: 7.5 mm, Left, Numbered + Level: 1 + Numbering Style: 1, 2, 3, … + Start at: 1 + Alignment: Left + Aligned at: 0 mm + Indent at: 7.5 mm, Style: Quick Style, Based on: Normal

    - and your numbering style should then remain stable when you do restarts.

    If you need to fix this for an existing style: go in to Modify the style, and remove the hanging indent and tabs. Then follow the steps as outlined above, starting with a paragraph to which you have applied the numbering style. Once you set the text indent and the tab setting in the Adjust List Indents dialog, the style definition should become correct, as above.

    Basically, the key is to make sure that the list indents, as set via the Adjust List Indents dialog, always match the indents you want the style to have.

    Gary

  12. #12
    3 Star Lounger
    Join Date
    Sep 2001
    Location
    Jakarta, Indonesia
    Posts
    274
    Thanks
    3
    Thanked 9 Times in 9 Posts
    Gary,

    Wow! That finally did it! As you say, not exactly intuitive.

    Many thanks

    Chris

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •